7 Replies Latest reply on May 16, 2013 5:52 AM by ahe

    Missing application, but status is installed as Success

    Rookie

      Using LDMS 9.5

       

      We have an MSI that for a small vendor app we have been tying to get this pushed out to XP and 7 machines.

       

      With some tinkering we have managed to get a successful status but the application is not installed. The MSI does work if you manually run it.

       

      We have also manage to get this actually installed but on as the job own and not all users could this point to an issue with the MSI?

        • 1. Re: Missing application, but status is installed as Success
          Frank Wils ITSMMVPGroup

          What is written in the local sdclient log for this installation?

           

          Frank

          • 2. Re: Missing application, but status is installed as Success
            Rookie

            Frank me but where would that be :-)

            • 3. Re: Missing application, but status is installed as Success
              Frank Wils ITSMMVPGroup

              C:\program files (x86)\landesk\ldclient\data or C:\program files\landesk\ldclient\data

               

              There are sdclients logs with a number which corresponds to the TaskID from the Scheduled Tasks in your Console. Or match time/date from your install...

               

              Frank

              • 4. Re: Missing application, but status is installed as Success
                Rookie

                Its full of all sorts.................

                 

                Thu, 16 May 2013 11:38:24 File (\\apshqLD001\Software\VW_TEST\May_Test_Workstation_Install\ERPTest.msi) is not in cache

                Thu, 16 May 2013 11:38:24 Only go to source for download.

                 

                Thu, 16 May 2013 11:38:24 About to call DownloadFiles (1 files) with these settings:

                Thu, 16 May 2013 11:38:24 m_allowedBandwidthWAN: 100

                Thu, 16 May 2013 11:38:24 m_allowedBandwidthLAN: 100

                Thu, 16 May 2013 11:38:24 m_maxDiscoveryThreads: 15

                Thu, 16 May 2013 11:38:24 m_discardPeriodSeconds: 604800

                Thu, 16 May 2013 11:38:24 m_preserveDirectoryStructure: 1

                Thu, 16 May 2013 11:38:24 m_bUseWanBWForPush: 0

                Thu, 16 May 2013 11:38:24 m_bSynchronize: 0

                Thu, 16 May 2013 11:38:24 m_downloadControl: SourceOnly

                Thu, 16 May 2013 11:38:24 m_preferredServerControl: NoPreferredServer

                Thu, 16 May 2013 11:38:30 processing package 'Defacto_Live_ODBC' 1 of 2 total packages

                Thu, 16 May 2013 11:38:30 File (\\apshqLD001\Software\_Defacto Live Workstation Install\BAT\ODBC\ODBC.bat) is not in cache

                Thu, 16 May 2013 11:38:30 Will attempt Peer Download.

                 

                Thu, 16 May 2013 11:38:30 Will attempt Preferred Server Download.

                 

                Thu, 16 May 2013 11:38:30 About to call DownloadFiles (1 files) with these settings:

                Thu, 16 May 2013 11:38:30 m_allowedBandwidthWAN: 100

                Thu, 16 May 2013 11:38:30 m_allowedBandwidthLAN: 100

                Thu, 16 May 2013 11:38:30 m_maxDiscoveryThreads: 15

                Thu, 16 May 2013 11:38:30 m_discardPeriodSeconds: 604800

                Thu, 16 May 2013 11:38:30 m_preserveDirectoryStructure: 1

                Thu, 16 May 2013 11:38:30 m_bUseWanBWForPush: 0

                Thu, 16 May 2013 11:38:30 m_bSynchronize: 0

                Thu, 16 May 2013 11:38:30 m_downloadControl: AttemptPeer

                Thu, 16 May 2013 11:38:30 m_preferredServerControl: AttemptPreferredServer

                Thu, 16 May 2013 11:38:41 processing of package is complete, result -1918107543 (0x8dac0069 - code 105)

                 

                Thu, 16 May 2013 11:38:41 An error (-1918107543) occured installing package Defacto_Live_ODBC

                Thu, 16 May 2013 11:38:41 processing of package is complete, result -1918107543 (0x8dac0069 - code 105)

                • 5. Re: Missing application, but status is installed as Success
                  ahe Expert

                  Hello,

                   

                  could you check if you can find the log from MSI file?

                  \\apshqLD001\Software\VW_TEST\May_Test_Workstation_Install\ERPTest.msi

                   

                  What does this batch file do?

                  \\apshqLD001\Software\_Defacto Live Workstation Install\BAT\ODBC\ODBC.bat

                   

                  Regards

                  Axel

                  • 6. Re: Missing application, but status is installed as Success
                    Rookie

                    Hi That batch file just set the ODBC name the app requires it to be named specfically.

                     

                    Sorry where will that log file be is that not what i haved pasted in?

                    • 7. Re: Missing application, but status is installed as Success
                      ahe Expert

                      No, that's the LANDesk task log file.

                       

                      You can create a own log file during MSI installation... normally they will be stored in the system temp directory, for example c:\windows\temp

                       

                      Could you post the source of the batch?

                       

                      Do you know this document: Understanding Batch File Distribution Packages

                       

                      regards

                      Axel