6 Replies Latest reply on Jun 7, 2013 4:42 AM by SBW

    error when opening Service Catalogue

    evhoeke Rookie

      When i want to open Service Catalogue i receive following error

       

      System.NullReferenceException: Object reference not set to an instance of an object.

         at Touchpaper.Console.UI.Windows.UIQueryConditionValueRelatedSelector.ToString()

         at Touchpaper.Console.UI.Windows.ConditionSingle.ToString()

         at Touchpaper.Console.UI.Windows.UIQueryCondition.ValueText(Object conditionValue)

         at Touchpaper.Console.UI.Windows.UIQueryCondition.CreateConditionValueText(Boolean IncludeBrackets, Object value)

         at Touchpaper.Console.UI.Windows.UIQueryCondition.CreateConditionText(Boolean IsOperatorRequired)

         at Touchpaper.Console.UI.Windows.ConditionListViewItem.UpdateRuntimeText()

         at Touchpaper.Console.UI.Windows.ConditionListViewItem..ctor(IClassType rootClassType, IUIQueryCondition queryCondition)

         at Touchpaper.Console.UI.Windows.QueryConditionList.PopulateConditionList(IList conditionList)

         at Touchpaper.Console.UI.Windows.QueryConditionFilterList.SetupControl()

         at Touchpaper.Console.UI.Windows.QueryConditionFilterList..ctor(IConsoleView consoleView, ConsoleQueryBuilder consoleQueryBuilder, IList`1 runtimeConditionGuids)

         at Touchpaper.Console.SnapIn.ServiceCatalogue.ServiceCatalogueQueryPage.SetupQuery()

         at Touchpaper.Console.SnapIn.ServiceCatalogue.ServiceCatalogueQueryPage.SetupResultsControl()

         at Touchpaper.Console.SnapIn.ServiceCatalogue.ServiceCatalogueQueryPage.DrawPage()

         at Touchpaper.Console.SnapIn.ServiceCatalogue.ServiceCatalogueQueryPage.ActivatePage()

         at Touchpaper.Console.ConsoleViewTabbedContainer.ActivatePage(Int32 page)

         at Touchpaper.Console.SnapIn.ServiceCatalogue.ServiceCatalogue.Init()

         at Touchpaper.Console.ConsoleView.ViewInit(IConsoleViewInit consoleViewInit, String strUserOptions)

         at Touchpaper.Console.ConsoleForm.InitialiseView(IConsoleViewInit consoleViewInit)

         at Touchpaper.Console.ConsoleForm.CreateConsoleView(String name, IConsoleViewInit consoleViewInit)

         at Touchpaper.Console.ConsoleForm.OpenDocument(String strName, String strInit, IConsoleViewInit consoleViewInit)

         at Touchpaper.Console.ConsoleForm.OpenDocument(String strName, IConsoleViewInit consoleViewInit)

         at Touchpaper.Console.ConsoleShortcutBar.shortcut_GroupItemClick(Object sender, ShortcutBarGroupItemEventArgs e)

         at Touchpaper.Console.UI.Windows.ShortcutBarGroup.OnGroupItemClick(ShortcutBarGroupItemEventArgs e)

         at Touchpaper.Console.UI.Windows.ShortcutBarGroup.m_treeControl_MouseUp(Object sender, MouseEventArgs e)

         at System.Windows.Forms.Control.OnMouseUp(MouseEventArgs e)

         at Crownwood.DotNetMagic.Controls.TreeControl.OnMouseUp(MouseEventArgs e)

         at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)

         at System.Windows.Forms.Control.WndProc(Message& m)

         at Crownwood.DotNetMagic.Controls.TreeControl.WndProc(Message& m)

         at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)

         at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)

         at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

        • 1. Re: error when opening Service Catalogue
          ProServices

          Try unpublishing all your services in your catalog.  Rebuilding your catalog index, and then attempt to open your service catalog.  Does it allow you to open it then?

          • 2. Re: error when opening Service Catalogue
            evhoeke Rookie

            We try this but still the same error...

            any other solutions?

            • 3. Re: error when opening Service Catalogue
              evhoeke Rookie

              Or maybe we didn't unpublish all services on the right way...maybe you can explain how to do.

              thx

              • 4. Re: error when opening Service Catalogue
                ProServices

                So your published services work off the knowledge component in Service Desk.  When you open the service catalog component you'll have several tabs.  The last tab is publishing.

                 

                You'll want to select the publishing tab, and then choose to display the services by the Services tab below that.  I would then go into each of your Catalogue Hierarchy folders and right click on each service, select publish and make sure that no options are selected.  Also make sure "publish to all" is not checked.

                 

                Do this for each service. 

                 

                Then, right click on the publishing tab again, and select Rebuild Service Catalog index.

                 

                Then attempt to open your Service catalog.  If it does open, I would go and re-publish each service, one by one, and rebuild the service catalog index each time.  Then test the catalog, make sure it works.  Rinse, repeat.

                 

                 

                I know this may not be easy if you have a 350+ service item catalog(like I did), but what I found when the issue occurred to me was that one of my services was "corrupt".  When I rebuilt my Service Catalog index with this one "corrupt" service, it caused my entire Service Catalog to throw an error when a user would browse it.

                • 5. Re: error when opening Service Catalogue
                  evhoeke Rookie

                  Ok, we understand what you mean but our problem is that we can't open Service Catalogue, so we don't have the page with the several tabs.When we click on Service Catalogue we have immediately an error (like described in my firts post).

                  I've attached a screenshot, because one pictures tells more than thousands words

                   

                  screenshot Service Catalogue.jpg

                   

                  What we did until now is to uncheck manually on each CI the checkbox In Service Catalogue? en then we rebuild the Service Catalogue but it didn't help, it's still the same error.

                  We also tried to add a new Service Catalogue (in Catalogue Management, right click Add Component and choose Service Catalogue as selected component) but this gives us the same error.

                  • 6. Re: error when opening Service Catalogue
                    ProServices

                    Are you running the 32 bit version of the console?  Please make sure that you are.

                     

                    If you're running the correct version and you're getting this when you open the component, I suspect either a problem with one of your services and/or one of the default queries that you have showing you available services.  This is about the time I would take a backup of the DB and test your service queries that your service catalog is using.  See if any of those give you the same error.