2 Replies Latest reply on May 28, 2013 8:58 AM by trujello

    "Interactive" PowerShell deployment when it's not supposed to be

    trujello Rookie

      Has anyone seen this when deploying a PowerShell Package?

       

      In Win7, it shows the following:

      http://blogs.msdn.com/blogfiles/patricka/WindowsLiveWriter/WhatisInteractiveServicesDetectionandWhy_10926/image_thumb.png

      http://blogs.msdn.com/blogfiles/patricka/WindowsLiveWriter/WhatisInteractiveServicesDetectionandWhy_10926/image1_thumb.png

      and in WinXP it shows an empty PowerShell console.

       

      I've checked the delivery method and it's set to "Hide all feedback from user". I've even tried adding to the command line options "-WindowStyle Hidden -NonInteractive" to no effect.


      If I use VBS or if I use a CMD package to do the same thing that PowerShell is doing, it works as expected without popping anything up. Any ideas?

       

      Using LDMS 9.5.

        • 1. Re: "Interactive" PowerShell deployment when it's not supposed to be
          ProServices

          Hello,

           

          I think PShell run by default in interactive mode, so this is why it popups IDS (Interactive Services Detection) window.

          Since Windows Vista, Microsoft does not allow interactive mode when an app is triggered by 'local system' account (it runs quietly in the background without popup for the current logged user). In order to see what going on in the background (running apps by local system), Microsoft created a service names "Interactive Services Detection" that when enabled, it allows you to see the 'interactive windows' of the app running under the local system account.

           

          By default this service is not started, in your case it's running. So if you don't need it, you can disable IDS.

           

          ISD.png

          • 2. Re: "Interactive" PowerShell deployment when it's not supposed to be
            trujello Rookie

            Hi ToF, thanks for the reply.

             

            So, even though I've set it to non-interactive on the command line, it's still "interactive"? I think LANDesk is not processing my additional command line parameters... possibly a bug in 9.5?

             

            I have no desire to modify the Interactive Services Detection on all Win7 systems if I don't absolutely have to.