14 Replies Latest reply on Jun 7, 2013 6:54 AM by chrisbb

    Provisioning error and Win  7 deployment

    Rookie

      I'm probably just missing something really easy here, but I am trying to use provisioning to deploy a Win7X64 image to a new Dell Optiplex 9010. with Landesk 9.5

       

       

      Win PE loads, and it all goes well initially,

      • Loads t he template
      • it cleans the partitions so there is just a single partition on the disk.
      • the 2nd partition action which I'm assuming makes the first 100mb bootable  system partition is where it fails..  it gives me error: [80000000H] An unknown error  occured.  If the problem persists, contact your administrator.

                Execute result:  return: -1

       

      Tgen the action ends.   I'm assuming it's running into some kind of difficulty creating the new partitions but I am not sure what to do.  if I'm missing something in my script, or if it's something in the machine itself, or  what.

       

      I have tried it on two seperate computers, both same optiplex models so the hardware would be  identical and both brand new.  I've tried disabiling the CD drive to make sure that wasn't conflicting, but still not sure what else to try.    Any thoughts or suggestions would be greatly appreciated..

        • 1. Re: Provisioning error and Win  7 deployment
          Benjamin THIEN Specialist

          Hi, 

           

          try to setting the hard disk step like this fir WIn7 X64.

          prov5.jpg

          Ben

          • 2. Re: Provisioning error and Win  7 deployment
            Benjamin THIEN Specialist

            And the next windows...

            prov6.jpg

            • 3. Re: Provisioning error and Win  7 deployment
              Rookie

              Thanks Ben

               

              Looking at your screenshots, mine look the same, with two exceptions.  Once my assigned drive letter is "C" and  the other being I don't have  the map network share and map image tool actions since they were defined in the image deploy section.  Could this be the problem?  I wouldn't have thought so since it seems to be getting stuck in the partition creation section.

               

              1.jpg

              2.jpg

              • 4. Re: Provisioning error and Win  7 deployment
                SupportEmployee

                Can you attach a copy of your template? Also, can you get the logs from the x:\ldprovisioning folder?

                • 5. Re: Provisioning error and Win  7 deployment
                  Rookie

                  I wasn't able to find the log on the X drive of the target machine but I was able to get it from the core server in the ldlogs file.    It didn't even appear in the machine at all.   I have also attached the original template file I was using as I couldn't get my modified one to export.   It's all the same as the original other than the location of the install image location and the disk and drive letters as indicated by the screenshots above.  The Files are attached to my original post as I couldn't get them attached here in the reply.

                   

                  Thanks for any help!

                  • 6. Re: Provisioning error and Win  7 deployment
                    SupportEmployee

                    Don't see the attachment. Wouldn't export? Why not?

                    • 7. Re: Provisioning error and Win  7 deployment
                      Rookie

                      The attachments should be on the original post they are appearing for me as .zip files.   I appended them just prior to the previous message..

                       

                      I guess it may be my ignorance with the exporting... I can export the provisioning script... but I can't find where it is storing my original template file itself.  I see all the preloaded ones in the Templates folder, and I see the folder where I placed the one I used to import it, but I can't find the customized version..   We are just now starting to use Landesk so I'm still learning my way around the program.

                      • 8. Re: Provisioning error and Win  7 deployment
                        Frank Wils ITSMMVPGroup

                        Are you sure there are 2 partitions in your image?

                         

                        After provisioning fails, but still in WinPE, open a command prompt. Run Diskpart. This opens a new prompt. Run 'Select Disk 0' and than 'List Part'. Do you see 1 or 2 partitions in the list?

                         

                        Frank

                        • 9. Re: Provisioning error and Win  7 deployment
                          Rookie

                          When I look at diskpart after the provisioning, it wasn't creating any partitions on the disk..  That template is not attached to the original post.

                           

                          I did try pushing out the captured image as a single partition but that didn't work either..

                           

                          So I modifed the template to include 2 create partition actions in the PreOS install section.  which is now also attached to the original post with modified prefix.  This one created the partitions, but then upon OS deployment load, it then erros and fails with the same error as above

                          • 10. Re: Provisioning error and Win  7 deployment
                            Benjamin THIEN Specialist

                            Hi ChrisBB,

                             

                            I check your template...

                            Try to use this one, after settings your informations like image, user password and script.

                             

                            http://web.lerelaisinternet.com/benthien/Windows7_X64.rar

                             

                            Good luck.

                            Ben

                            • 11. Re: Provisioning error and Win  7 deployment
                              Benjamin THIEN Specialist

                              And you have to map drive for image tool and image.tbi folders.

                              You can see it in OS installation step "Map image share" and Map image tool" in my template.

                              Ben

                              • 12. Re: Provisioning error and Win  7 deployment
                                Rookie

                                Thanks Ben.  

                                 

                                I have made the adjustments to your template for our environment.  The drives appear to map properly, but then when it hits the deploy image portion of the template, it fails and stil gives the same error message.   I tried modifying the template to use the network drive mapped letter instead of the full UNC in the deploy image section to see if that was it, but that didn't seem to work either.

                                 

                                I'm going to keep poking around..  I'm sure it's just something really simple I'm just overlooking..  Might have to try rebuilding a image and try a new image capture maybe?  

                                 

                                The only other thing is I'm trying to deploy this off of my core server were the image resides but haven't set it up as a preferred server..  Do I need to setup my core server as a preferred server even if I want the image to come directly from the core?

                                • 13. Re: Provisioning error and Win  7 deployment
                                  Rookie

                                  I was running into an issue at the same place similar circumstances ... although I couldn’t find any docs…. I found short file names on the images worked better for some reason….???

                                   

                                  Example: win7hii.tbi or 1.tbi work,

                                   

                                  My limit was this…

                                  Anything over 7 characters failed. I believe this has to do with the maximum characters allow in the path… Depending how deep your file structure is will limit the URL or UNC you can use on the file name itself. So when the template calls imagew it can’t find the image file.. So thatsall you get and the process ends.

                                   

                                  My structure was http://XXXXXXXXX.XXXX.XXXXXXXXX.com/images/Windows7/winimage.tbi failed evertime.

                                  http://XXXXXXXXX.XXXX.XXXXXXXXX.com/images/Windows7/win7hii.tbi worked Just under the max path...

                                  Or I could have remove the domain suffix at the time if knew that….

                                  http://XXXXXXXXX/images/Windows7/winimageICanUseMoreHereNow.tbi failed

                                  I also remove the map drive step to the image as that also breaking the process..

                                  I also noticed this in packaging later, when the fully qualified names are used the dependent files end up error HTTP:// error 404, I can chop it to http://Server/packages/package and the subdirectories in package folder are now available… but the limit is riding pretty close still…

                                  My guess this is an IIS issue as with my experience with apache web servers your limited to 3 directories deep on a web server…

                                   

                                  You can certainly try the short image file name and see if imagew start.. if it does its finding the file!

                                  • 14. Re: Provisioning error and Win  7 deployment
                                    Rookie

                                    Ok after trying all the suggestions above I was finally able to get the image to push via image W, ultimatley instead of mapping to a drive letter I just had to connect to a network resource..  Not sure why but same path and then add a set of quotes around my image W command.  

                                     

                                    Now it runs, copies the iamge and makes the partitions and volumes, but then errors during the set active command to make the C drive the active drive as it can't find the MBR..   I'm going to try and recapture a image to make sure it isn't just the image itself that has gotten messed up...   But when it's going through the partitioning phase at the start of the provisioning it says it can't find the vboot partition..  So I'm at least making progress one small step at a time.

                                     

                                    Thanks everyone for all your  help on this.