12 Replies Latest reply on Jun 20, 2013 2:40 PM by AspenSkier

    Any ImageW users out there?

    Specialist

      I've been an Image for Windows v2 user since LDMS 90; having just updated my core to 95 I'm having some problems with getting the tool to work correctly with LDMS...hoping someone can shed some light on what might be wrong.

       

      I used the GUI with the new version of IFW to generate a command line which has been included in my landesk provisioning task.  I was able to test this exact command line on a client computer in WinPE and it does work.  When I run the provisioning task it fails at the point where the deploy image action item is executed.


      the following is the relevant excerpt from the provisioning log on the client computer:

       

      2013-06-20 16:44:28(1640-1852) ldprovision:*********  Begin an action - Deploy_image

      2013-06-20 16:44:28(1640-1852) ldprovision:Do EnvironmentCheck

      2013-06-20 16:44:28(1640-1852) ldprovision:Is WinPE Action=1, Is WinPe Environment=1

      2013-06-20 16:44:28(1640-1852) ldprovision:Report might reboot status to core.

      2013-06-20 16:44:28(1640-1852) ldprovision:Call web service SetActionStatus()

      2013-06-20 16:44:28(1640-1852) ldprovision:Start TryallWebService Attempt:0.

      2013-06-20 16:44:28(1640-1852) ldprovision:End TryallWebService Attempt:0. ExitCode:0

      2013-06-20 16:44:28(1640-1852) ldprovision:Download handler ok.

      2013-06-20 16:44:28(1640-1852) ldprovision:Launching action handler [DeployImageHandler.exe] with parameters ["]

      2013-06-20 16:44:28(1640-1852) ldprovision:handler launched.

      2013-06-20 16:44:30(1640-1852) ldprovision:Reporting action status: 5 to core

      2013-06-20 16:44:30(1640-1852) ldprovision:Call web service GetStatusString()

      2013-06-20 16:44:30(1640-1852) ldprovision:Start TryallWebService Attempt:0.

      2013-06-20 16:44:31(1640-1852) ldprovision:End TryallWebService Attempt:0. ExitCode:0

      2013-06-20 16:44:31(1640-1852) ldprovision:StatusString = The action failed.

      2013-06-20 16:44:31(1640-1852) ldprovision:Call web service SetActionStatus()

      2013-06-20 16:44:31(1640-1852) ldprovision:Start TryallWebService Attempt:0.

      2013-06-20 16:44:32(1640-1852) ldprovision:End TryallWebService Attempt:0. ExitCode:0

      2013-06-20 16:44:32(1640-1852) ldprovision:End of action - Deploy_image

      2013-06-20 16:44:32(1640-1852) ldprovision:Last action failed

       

      I used a different set of command line arguments from a provisioning template used in 9.0 with the older version of IFW and the failure happens at the same place and the provisioning log shows the same result.

       

       

      Is anyone haivng problems using image for windows in 9.5?

       

       

      It is worth adding that I am using the CONNECT RESOURCE option to connect the WinPE client to the imaging tool and the location of the images.  Without closing the command-line window in WinPE I can manually execute the IFW command and see that it works so I don't have a network access issue with the resources.

        • 1. Re: Any ImageW users out there?
          Specialist

          We saw some errors using our provisioning templates. I went into each template and clicked validate. This set the scripts back to a default and that fixed our issues. We were using some special commands in 9.0 that did not work in 9.5

          • 2. Re: Any ImageW users out there?
            Specialist

            I didn't want to use validate because it essentially eliminates the functionality of the imaging tool; it strips out the pieces which are necessary for it to do what we need it to do.

             

            I more or less figured I needed to rebuild my commands for IFW and at the suggestion of a Terabyte tech I used the GUI of the tool to generate updated commands that work with the new version.  I tested those commands and they work; the tool just won't run within a provisioning sequence.  The IFW window doesn't even pop up while the provisioning task is running.

             

            Still, I used validate and reran the provisioning task I was testing and the failure persists.  So it is something else.

            • 3. Re: Any ImageW users out there?
              SupportEmployee

              The deploy image action handler has changed in 9.5. More detail can be found here http://community.landesk.com/support/docs/DOC-26932. If you haven't changed your template, it should work. If you edited the template it will make you change the deploy image action. Once you do this the action will try to map drives and get the tool for you. If you already have drives mapped, often you get an error authenticating to windows again. Also if you do not have the core server setup as a preferred server this will fail.

               

              If you want to dig into the error look at the action handler logs. Any time an action handler launches another exe, the log detail will be in the handler log for that exe. In the case of your ldprovision log included, you see that deployimagehandler.exe was launched. It returned error 5, indicating a failure in the deployimagehander. If you instead open the deployimagehandler log you will see it launch maptopreferredhandler, meaning you would need to check that log. Mapropreferredhandler may or may not launch another handler because we are trying to do a lot of the work for you. Once you get to the log where the failure actually is the information should be pretty clear. Standard windows error codes are used at that level. Details can be found here http://msdn.microsoft.com/en-us/library/windows/desktop/ms681381(v=vs.85).aspx.

              • 4. Re: Any ImageW users out there?
                MrGadget Expert

                Not sure if this helps but you have to choose other instead of imagew.

                • 5. Re: Any ImageW users out there?
                  SupportEmployee

                  You only have to chose other if you intend to leave your mapped drives in the template. If not, the deploy action using imagew or imagex will automatically map the drives for you.

                  • 6. Re: Any ImageW users out there?
                    Specialist

                    So I don't need/care about drive mappings; in fact I dumped the drive letters and simply used CONNECT RESOURCE instead to authenticate the image share and to the OSD location for the tool.

                     

                    Eric, are you saying that I don't need anything extra to connect to OSD\ImageW 2?

                     

                    And that I need to configure preferred server settings for the core server?  I've never felt the need to do that because I don't need to restrict access by IP range and the replication stuff is useless in our environment.  Can I configure the core server as a preferred server only insofaras the credentials piece is concerned and leave the rest of the stuff blank?

                    • 7. Re: Any ImageW users out there?
                      SupportEmployee

                      Yes, we just need credentials. Only applies to provisioning, not OSD. In an environment where you did care about proper preferred server usage, you can always add an ip range that clients never get for the core such as 1.1.1.1-1.1.1.2. Then the core is not used as a preferred server for clients, but credentials can be used by provisioning.

                      • 8. Re: Any ImageW users out there?
                        Specialist

                        Thank you Eric,

                         

                        would you please clarify for me to what I need to grant READ access on the core server?  The dialog box for configuring the PS says only to grant "READ access to the preferred server" but it doesn't provide any other direction.  Is there a specific SHARE on the server that needs this read access?

                        • 9. Re: Any ImageW users out there?
                          SupportEmployee

                          It says read, but it can be read/write. The credentials will be used to access your image share, so the path to your image.

                          • 10. Re: Any ImageW users out there?
                            Specialist

                            Now I'm confused.

                             

                            I have an image share which is on one server and then my landesk core is on another server.  I thought we were talking about configuring PS for access to the imaging tools in LDMAIN\OSD, no?  In my case do I need 2 PS?

                             

                            I can certainly grant read access to my image share, did that already, but I have no idea what is suppose to get read access on my core.

                            • 11. Re: Any ImageW users out there?
                              SupportEmployee

                              No, only for share where the image file is located. The imaging tool is actually downloaded via http from the core for you.

                              • 12. Re: Any ImageW users out there?
                                Specialist

                                okay, 1 PS configured for the image share; no configuration for the landesk core.

                                 

                                I did find the following in the deployhandler log file:

                                 

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:Setting up environment for imagetype: LANDeskWinV2

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:Downloading imaging tool. Remotefile: http://LANDESK/ldlogon/provisioning/windows/imagew.exe, Local file: x:\ldprovision\imagew.exe

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:Starting download of file: http://LANDESK/ldlogon/provisioning/windows/imagew.exe

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:Debug download of file: http://LANDESK/ldlogon/provisioning/windows/imagew.exe

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:Getting free drive letter

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:Free drive letter: f

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:ExecuteCmd maptopreferredhandler.exe /path="\\tech\Images\HP8560p" /driveletter=f

                                2013-06-20 22:35:08(1020-1788) DeployImageHandler.exe:created process, file handle 60 with non-readonly parameter

                                2013-06-20 22:35:10(1020-1788) DeployImageHandler.exe:Process Exit Code: 1219

                                2013-06-20 22:35:10(1020-1788) DeployImageHandler.exe:Failed to setup envionment for imaging type LANDeskWinV2

                                2013-06-20 22:35:10(1020-1788) DeployImageHandler.exe:Tearing down Environment.

                                2013-06-20 22:35:10(1020-1788) DeployImageHandler.exe:ExecuteCmd maptopreferredhandler.exe /unmap /driveletter=f

                                2013-06-20 22:35:10(1020-1788) DeployImageHandler.exe:created process, file handle 5c with non-readonly parameter

                                2013-06-20 22:35:10(1020-1788) DeployImageHandler.exe:Process Exit Code: 2250

                                2013-06-20 22:35:10(1020-1788) DeployImageHandler.exe:execute failed with -1

                                 

                                --------testing------------

                                after creating a PS for the image share and nothing for the landesk core I think I'm good now.  My template no longer has separate authentication references; in fact I have just the image deploy action in that part of the template.

                                 

                                Image deployment is now running.  Next steps are to find out what works/fails later in the provisioning process.

                                 

                                Thanks again for the help.