5 Replies Latest reply on Jul 9, 2013 10:34 AM by reabbott

    Dates still showing in UK format ..

    Apprentice

      I read through a kb article that discussed making sure that all date formats on the application/web server were set to the correct region. Which they already were, but still in LDSD i am having the dates being shown in the UK format. Please see insert. How do i change the format of these dates to show month/dd/yyyy ?

       

      date.JPG

        • 1. Re: Dates still showing in UK format ..
          Jamie Cannon ITSMMVPGroup

          You will need to make sure in IIS the language is set to "Invariant".  Sometimes it'll stick in UK and throw it off.

           

          Also, have you verified that you have changed culture in the config file to en-US?  I believe there are 3 of those config files.

          • 2. Re: Dates still showing in UK format ..
            Apprentice

            Thanks Jamie. IIS was set to 'en' for the webaccess site and also the culture was set to 'en' in the tps.config files. Changed those settings, iisreset, all dates reporting correctly.

            • 4. Re: Dates still showing in UK format ..
              ITSMMVPGroup

              We implemented this change also, but I noticed that it would sometimes revert back to the default/British date format.  After the 3rd or 4th time changing it, some digging around revealed that you will also need to update the value for SystemCulture to "en-US" (or whatever your preference may be) in the ConfigurationData.xml file.  Everytime you edit the configured app in ConfigurationCentre, it copies settings from this xml file as a template and overwrites your tps.config (and the fix you've implemented above)

               

              • Find/Open the ConfigurationData.xml file in the ServiceDesk.ConfigurationCentre folder on your web access server (e.g., "\ \LDSDWEB\ServiceDesk.ConfigurationCentre")
              • Perform a search for "SystemCulture" and update the Value for the one associated with your WebAccess application to "en-US"/or your preference.
                (the xml file contains a VirtualDirectory for each of the Configured Applications (e.g., Framework, WebAccess, etc.) in your ConfigurationCentre, there are several SystemCulture entries)
              • Save the xml file.

               

               

               

              -Brian

              1 of 1 people found this helpful
              • 5. Re: Dates still showing in UK format ..
                Apprentice

                Thanks for the additional info, i made those changes too.