3 Replies Latest reply on Aug 8, 2013 8:05 AM by Ashley.Pyle

    Category not being picked up

    Apprentice

      I have this unusual problem with the category not being picked up when set:

       

      So we go, we want to start auditing our Self Service so a call is automatically opened and closed without human innervation, when the Self Service is used it generates an email to our service desk which automatically logs it, in the process I have a precondition hanging off the Open Status that looks in the Title field for a key word which is really long so we know the users will never use it

       

      Precondition.jpg

       

      If the precondition is met then I have two auto actions, the first one is to set the category to Applications - Self Service and then Close

       

       

      Automatic Process.jpg

      Inside the Automatic Process

       

       

      Category.jpg

      So the call logs and closes as it should but the category field does not get populated even tho its mandatory

       

      Results.jpg

      You can make out the yellow border as its looking for data, but not there

       

      I haven't set a mandatory category depth

       

      Has anyone got any ideas or seen this before?

       

      Any advice would be grateful

        • 1. Re: Category not being picked up
          Expert

          Hi Ashley

           

          Just checked in all my processes and any where I have an auto action that includes a category I have either an assignment or a status after it and the category holds for all of them.  Have you tried testing with something as a break between the 2 auto actions?  No idea if or why this might resolve it but worth a shot!

           

          Helen

          • 2. Re: Category not being picked up
            Apprentice

            Tired adding an assignment in the process but no good, I was thinking it was a permissions problem but still nothing, think I will log a quick support call to get this resolved as its guaranteed they will know as I would like to roll this out pretty soon.

             

            I will post the solution on here for everyone to see once I know.

            • 3. Re: Category not being picked up
              Apprentice

              Hi Hewy06

               

              Finally got it resolved and I knew it would be something silly, the automatic action I was using to set the category had allow association with window set to False, as soon as I created a new action in Business Objects in process designer setting this to True it worked as great.