8 Replies Latest reply on Dec 26, 2013 12:43 PM by Mach6

    Question - Multicast an Image

    ecoidan Specialist

      Have a customer with LDMS 9.0 and wants to multicast their image to 70 systems at once. How many systems has anyone out there imaged at once?  Just curious..

        • 1. Re: Question - Multicast an Image
          MarXtar ITSMMVPGroup

          Have you checked multicasting of the image is even working? Lats time I tried this any attempt to multicast an image file failed on my test systems and the customer's.


          In the past I have used to far more than 70 machines.


          Mark McGinn

          MarXtar Ltd/MarXtar Corporation


          LANDesk Expert Solution Provider



          The One-Stop Shop for LANDesk Enhancements

          - Wake-On-WAN - Distributed Wake-On-LAN, Scheduled Power Down, and SWDist Sequencing

          - State Notifier - Real-Time Device & User State Inventory Updating & Alerting

          Update - New Stand-Alone State Notifier Console for Service Desk Operators

          Update - State Notifier now detects machine and user Idle states

          Update - WoW & State Notifier now integrate for even more functionality

          • 2. Re: Question - Multicast an Image
            ecoidan Specialist

            I havent tried multicast in, well, cant remember its been so long.  Guess I'll test it out.

            • 3. Re: Question - Multicast an Image
              ecoidan Specialist

              I was looking at the fixed items for SP1 and came across this:

              • 48292 - OSD - Multicast fails to send correct packets during resend if the file is over 4gb


              I assume that means if the image was under 4GB then multicast has been working.. Guess I will be testing after SP install.

              • 4. Re: Question - Multicast an Image
                Eric Christensen SupportEmployee

                An image over 4gb would only fail if packets had to be resent. If the network was clean and the machine got the multicast packets on the first attempt, an image over 4gb would work without any issues.

                • 5. Re: Question - Multicast an Image

                  I have tried to use multicast for OSD in a clean and well managed lab network environment with only the core server a two client nodes and the OSD multicast always fails with error 'disk full' message in the multicast window of the core server (see my discussion http://community.landesk.com/support/thread/23461?tstart=0).  I have tried with images files over and under 4GB to no avail. Al ways same issue. Tried in other core servers in production and same issue. this is a solid bug in LDMS 9.5 sp1.

                  • 6. Re: Question - Multicast an Image

                    Hi all,


                    There is now a solution to this problem.  If you are using OSD with Multicast in 9.5 (any SP level) you will need to mount the boot.wim image and modify the startnet.cmd file.  There you'll need to move the line that runs tmcsvc.exe to below the tag marked : provisioning (without a space.  It tried to turn it into a stick your tongue out smiley when I did that, so I had to add a space between the : and the p).


                    Here's a quick rundown of the steps in more detail:

                    1 - Make an empty directory (such as C:\mount)

                    2 - Mount the boot.wim file.  This would do it from the normal install path to the C:\mount directory:

                         dism.exe /mount-wim /wimfile:"C:\Program Files (x86)\LANDesk\ManagementSuite\landesk\vboot\boot.wim /index:1 /mountdir:C:\mount

                    3 - Right click on C:\mount\windows\system32\startnet.cmd and choose edit

                         NOTE: Do not double click the file, it will attempt to execute.  You don't want that

                    4 - Search for "start tmcsvc.exe /no_service"

                         I found it on line 93

                    5 - Cut that line (and optionally the commented line above it) and move it to below the line that starts with : provisioning (again, no space).

                         For me this was line 124 BEFORE cutting the other lines

                    6 - Save the file and close notepad

                    7 - Unmount the boot.wim file, saving changes  This should work for the C:\mount path:

                         dism.exe /unmount-wim /mountdir:C:\mount /commit

                    8 - Redeploy your PXE reps (or otherwise update the boot.wim file on them)


                    This should make Multicast work again in OSD.



                    • 7. Re: Question - Multicast an Image

                      Thanks! now multicast is working again.

                      • 8. Re: Question - Multicast an Image

                        Glad to hear it!