6 Replies Latest reply on Jul 24, 2013 9:01 PM by Carl.Simpson

    Upgrade Database Fails

    Expert

      I have done several upgrades now to 7.5, 7.6, and 7.6.1 and with each version when I start the upgrade of the database it never does anything, it just hangs in limbo forever.  Then I happen to notice a pattern.  The first time I do an upgrade it fails and I was using an Integrated Only framework.  Then in each case I do the upgrade again using an explicit only interface and it works.  I meant to mention this with 7.6 but was reminded when it happened again with 7.6.1.

       

      Another thing I noticed is that with Integrated only, the Option box doesn't appear.  For explicit it is always there.  I don't see anything in the documentation about having to use Explicitonly.

       

      Anyone else see this?

        • 1. Re: Upgrade Database Fails
          dmshimself ITSMMVPGroup

          Our best practise is to always use explicit services for all upgrades and then just use or configure integrated.We only do that because of previous issues with integrated login or when integrated is not even set up, but why change something that works!

          1 of 1 people found this helpful
          • 2. Re: Upgrade Database Fails
            Expert

            I have been doing in place upgrades so I have been keeping the same frameworks in place.  Because of that I always have both integrated and explicit in place already.  I just never knew one works and one doesn't.  Why should it make a difference?  Both can talk to the database (and use the same SQL account in my case).  Smells like a bug to me.

            • 3. Re: Upgrade Database Fails
              dmshimself ITSMMVPGroup

              No particular views from me on that Carl.  It's just that as we are doing customer installs rather than our own, we tend to adopt practises that work everywhere (where possible).

              • 4. Re: Upgrade Database Fails
                jlmisenh Apprentice

                I am testing at at this point in time for a 7.6.1 go live next week.  I have the same DB server (different prod DB) and two new VM's for App/Web server.  Until last week, each time I copied over my 7.4 DB to my 7.6 DB and upgraded, it worked flawlessly, but since I upgraded 7.6 to 7.6.1 the upgrade process does the same...Hangs and does nothing.

                • 5. Re: Upgrade Database Fails
                  dmshimself ITSMMVPGroup

                  Watch out for the conversion in of text data types if you are using MS SQL as that can take ages and might be affected by different database servers performance.  Look at the log file to see what it is doing?  I'd also make sure you are using the second release of 761 and apply the BOD hot fix2 for 7.6.1

                  • 6. Re: Upgrade Database Fails
                    Expert

                    Did you increase the timeout value from 300?  There is another post about how mine still failed with a 600 but after adding a zero (6000) it then worked.  Like DM said they did some conversions and it takes a LONG time, much longer than normal.