5 Replies Latest reply on Jul 26, 2013 8:39 AM by dgaines

    HII not working in provisioning

    dgaines Apprentice

      Is anyone else having an issue with the hii program not installing network drivers on windows 7?   I have a intel network card on a lenvo T series laptop that worked and installed on the pre SP1 version.   After I upgraded to SP1 it quit installing.   I made sure that it was assigned to the model, but the HII log still comes up and says that no drivers were found.

        • 1. Re: HII not working in provisioning
          Tracy Expert

          This happened to me as well, and it turned out that my drivers.db3 file had been corrupted. Here is what I did to verify problem / fix


          1. Boot a machine into WinPE and run an HII template action.

          2. Check c:\windows\LDDriverstore to see if the driver I wanted, was injected

          3. Check HIIClient log.. I had a similar no drivers found error.

          4. checked the size of c:\windows\ldddriverstore\drivers.db3 to make sure it downloaded OK.

          5. Get a sql lite database viewer (I used Database Browser Portable) and open the drivers.db3 file from your HII repository store

          6. At this point, I could see that my db3 was corrupted, but if your db3 opens OK, you can query for the driver that is supposed to be getting injected to see if it actually exists in the repository database.




          7. The fix for me was to just rename my drivers.db3 file and then run "Build Library" from the HII Driver Management toolbox added in SP1. However if you still cannot query the database for the driver you need, you may need to look into why the HII tool isn't parsing the .inf and adding it to the DB.



          • 2. Re: HII not working in provisioning

            Something seems amiss with HII. We had a Win7 x64 HII image that worked flawlessly on multiple HP models, pre-SP1. Now, every model we use it on blue screen traps on boot as it tries to load the disk.sys driver. When we turn HII off, the image rolls out fine, but without drivers. Rebuilt the driver database and the imaging script/task to no avail. Have not done much sleuthing yet, as trying to debug HII image / driver issues make me want to harm puppies. Still, something in HII is broken in SP1 it would appear.



            • 3. Re: HII not working in provisioning
              Tracy Expert

              As I understand it, the HII in SP1 'should' do a better job at matching the drivers to hardware. It sounds like you need to do the first few steps I outlined above and see what drivers are in ldddriverstore, then go to a machine that was images before sp1 and look at the same folder and comapre. My guess is the injected mass storage driver will be different. In which case, just go into the HII toolbox and 'exclude' the driver that is causing the blue screens from that hardware, or assign a specific, correct driver.



              • 4. Re: HII not working in provisioning
                dgaines Apprentice

                Thanks for the suggestion.  I checked the database and the necessary infromation for the driver seems to be there but still no luck.   Am I right that the driver just has to be in the driver store and does not have be assigned?

                • 5. Re: HII not working in provisioning
                  dgaines Apprentice

                  Thanks to some help from support I found that my image had a c:\windows\lddriverstore folder.  I added a line in my provisioning task to remove that before the HII ran.   That fixed the problem I was having.