7 Replies Latest reply on Nov 19, 2013 1:58 AM by MarXtar

    Provisioning tasks don't auto boot


      Hoping someone can help us out quickly here. We are in the middle of rolling out new workstations to 100+ offices across the country.  The first 90% of them have gone fine.  Imaging over 1000 PCs so far.  Then all of a sudden 2-3 weeks ago, the provisioning tasks won't auto load past the Press F8 menu at boot. 



      Every workstation must now be manually booted, with monitor and keyboard just to press F8 and load into WinPE Provisioning.  Once that WinPE system loads up it auto starts the task that is already started and continues the image without issue.  We just cannot get them to auto-load past the Press F8 menu.  They used to prompt the menu ONLY when a scheduled task is not already started for that MAC.  Now it doesn't matter if he have a task already started, it still prompts the menu, and if we don't hit F8 and choose provisioning it just loads into the stock OS from the manufacturer.



      We have tried re-deploying our PXE rep multiple times to no avail. 



      We are having some other issues with Provisioning as well that might be related.  I'll mention here only in case they are related.  I am the admin on the LD system and provisioning works fine for me (besides the issue above).  But for other users when they try to choose an provisioing task in the menu, it will delay and say Loading template.... over and over and over.  Sometimes it will eventually kick in, or else they just give up and I login and start it right away.



      Please help us out.



      LD 9.0 (I know there is an upgrade available just haven't got around to it yet).





        • 2. Re: Provisioning tasks don't auto boot

          I had the same problem, but ended up ignoring it because manually PXE booting made more sense for my team. Afterwards, it was suggested to me that I make sure that there are no other tasks existing tasks for the machine I was trying to get to autoboot. Perhaps check this?

          • 3. Re: Provisioning tasks don't auto boot

            Thanks for the reply.  Unfortunately ignoring is not an option for us as we image so many devices, it will take forever to get through them one by one.  There are no other tasks in there as these are brand new machines.  They are out of the box and we need to put an image on them before we package them back up and ship them out.


            Someone must have come across this before?

            • 4. Re: Provisioning tasks don't auto boot
              dwagner1 Apprentice

              We have techs that start the PXE/USB/CD boot from the physical machine, OR some of them log into the console and start the job.


              I have tried this before...putting a reboot as the only action in the "System Migration" and then scheduling the task, are rebooting the machines, then it picks up the template automatically.


              Reboot into PXE.png

              • 5. Re: Provisioning tasks don't auto boot

                Thanks for the reply.  I don't think people are understanding the problem though.  I don't expect the machines to reboot, or someone to reboot it to pick up the template.


                Normal process:

                • From console
                  • Enter Bare Metal Server item
                  • Schedule Template...
                  • Add the Bare Metal item to the Scheduled Task
                  • Start the Scheduled Task
                  • Item goes to Pending in the status
                • On the physical machine, power it on...
                  • It defaults to NIC boot
                  • Gets a DHCP lease
                  • Recognizes that there is a Scheduled imaging task already to go and auto-boots into WinPE
                  • Starts the task automatically
                  • Completes


                Where ours goes wrong is the bold section above.  This never happens.  Even with the task already started, the machine boots, gets a DHCP lease, and then offers the PXE Menu and says Press F8 for menu....


                If we press F8 at this time, AND manually choose WinPE provisioning, then it will load to WinPE and start the task by itself.  If we DO NOT press F8 and manually choose WinPE provisioning, then it will timeout the F8 option in 10 seconds, and move to boot frokm HDD. 


                Therefore the scheduled task never gets done as it never gets to WinPE to do it.


                Any ideas here?  I tried confirming and using different delivery methods on the task but nothing seems to kick it to auto-load past the F8 menu and into WinPE.

                • 6. Re: Provisioning tasks don't auto boot
                  PaulPretorius Rookie

                  I totally believe you FYidoctors.  We have the exact same issue at our place and it drives me insane!

                  Found that sometimes removing and redeploying the PXE Rep fixes it.  Other times, i have restarted the scheduler service on the core server. It still happens now and I havent been able to pin it to anything yet. We're running 9.5 Sp1.


                  Have you managed to resolve your issue yet?

                  • 7. Re: Provisioning tasks don't auto boot
                    MarXtar ITSMMVPGroup

                    What are you using as the identifier in your bare metal import? I've always had best success with MAC address. However, are you certain nothing is getting in between with a different MAC address (such as a docking station)?


                    Mark McGinn

                    MarXtar Ltd/MarXtar Corporation


                    LANDesk Expert Solution Provider



                    The One-Stop Shop for LANDesk Enhancements

                    - Wake-On-WAN - Distributed Wake-On-LAN, Scheduled Power Down, and SWDist Sequencing

                    - State Notifier - Real-Time Device & User State Inventory Updating & Alerting

                    Update - New Stand-Alone State Notifier Console for Service Desk Operators

                    Update - State Notifier now detects machine and user Idle states

                    Update - WoW & State Notifier now integrate for even more functionality