14 Replies Latest reply on Aug 21, 2013 7:29 AM by RobLent

    Cannot deploy image

    RobLent Specialist

      We have a new install of LDMS 9.5 SP1.


      There has been no upgrade as this was a fresh install from the start and this is our first time using LDMS for deployment.


      We had a test system in our Lab before going ahead with the purchase and we had it working fine although it was not SP1.


      I have my captured image from our Lab environment and put it in our live server but I cannot deploy the image.


      All I get is the following error:


      Action Type=Deploy_image


      error:[80001803H]The action failed.

      Execute result:




      That is it.  There is nothing more in the log on the client either.


      Can anyone shed any light on what this error is and how to resolve it?


      Many thanks,



        • 1. Re: Cannot deploy image
          Frank Wils ITSMMVPGroup

          Is there a deployimagehandler.log on the client?



          • 2. Re: Cannot deploy image
            RobLent Specialist

            There is Frank.


            All seems to go fine until this:


            2013-08-19 21:42:34(1352-1308) DeployImageHandler.exe:Getting free drive letter

            2013-08-19 21:42:34(1352-1308) DeployImageHandler.exe:Free drive letter: e

            2013-08-19 21:42:34(1352-1308) DeployImageHandler.exe:ExecuteCmd maptopreferredhandler.exe /path="\\myservername\deployment\os\win7\W7Sp1V1-1.tbi" /driveletter=e /pathisfile

            2013-08-19 21:42:34(1352-1308) DeployImageHandler.exe:created process, file handle 68 with non-readonly parameter

            2013-08-19 21:42:36(1352-1308) DeployImageHandler.exe:Process Exit Code: 1219

            2013-08-19 21:42:36(1352-1308) DeployImageHandler.exe:Failed to setup envionment for imaging type LANDeskWinV2

            2013-08-19 21:42:36(1352-1308) DeployImageHandler.exe:Tearing down Environment.

            2013-08-19 21:42:36(1352-1308) DeployImageHandler.exe:ExecuteCmd maptopreferredhandler.exe /unmap /driveletter=e

            2013-08-19 21:42:36(1352-1308) DeployImageHandler.exe:created process, file handle 5c with non-readonly parameter

            2013-08-19 21:42:36(1352-1308) DeployImageHandler.exe:Process Exit Code: 2250

            2013-08-19 21:42:36(1352-1308) DeployImageHandler.exe:execute failed with -1


            I have changed the serve name parameter but it is correct in the actual log.






            Just found a MaptoPreferredHandler.log file and this is more helpful.  It seems it cannot map the drive!


            Yet I can if I do that in a command prompt myself.

            • 3. Re: Cannot deploy image
              bnelson Employee

              Have you set up the core as a preferred server? Have you tested the credentials used to ensure it has rights?

              • 4. Re: Cannot deploy image
                RobLent Specialist

                Yes. Core server is a preferred server.


                Currently using my credentials to get it working.  The test credentials button on the preferred server setup is sucessful.


                EDIT again!


                Just found that the http authentication is failing.  Will take a look at that!

                • 5. Re: Cannot deploy image
                  RobLent Specialist

                  I think I may have found the issue but am unsure how to fix it.


                  To assist in our DR we have a drive on this server presented from our SAN which is then replicated to our DR SAN.


                  All our deployment files are on this drive but obviously that drive is outside the normal LANDesk web structure.


                  Is there a document anywahere that explains how to re-direct the web sites to the folder on the presented disk?


                  Or one that shows how to add a new directory into the LANDesk web structure?



                  • 6. Re: Cannot deploy image
                    RobLent Specialist

                    Well I am a little lost.


                    I can use a map drive command n the template and this maps to the image location fine.


                    It is only when the deploy image task tries to run that I get the failed message.


                    Really not sure what is going on here.  I have checked all the permissions against the folders and they seem to be correct.


                    I can browse to them via HTTP and UNC now..


                    Anyone any other thoughts?



                    • 7. Re: Cannot deploy image
                      bnelson Employee

                      Do not map to the drive using the MAP Drive action. Just call the executable and put the UNC path to the image file. Make sure the path is fully qualified and that you created the preferred server using the FQDN. Mapping to it will create issues, just allow the preferred server utility to get you there.

                      • 8. Re: Cannot deploy image

                        Hi Rob,


                        This happened to me after updating to SP1 last Thursday. I needed to redeploy my PXE representatives in order for them to get the new Win8 kernel. It's kind of hard to extrapolate that from not being able to map to a drive, but give it a try and let me know if this works for you.



                        • 9. Re: Cannot deploy image
                          RobLent Specialist

                          Hi Jon,


                          Many thanks for the reply.  I have tried redeploying the PXE representative as you sugested.


                          Unfortunatley I am still getting the same error.


                          Everything is fine until it comes to the deploy image task.


                          I have removed teh map drive task and put in the full URL as sugessted by bnelson but this still fails.


                          In the MaptoPreferredHandler.log I am getting errors 1219, 2250 and 86.  All relating to mapping a drive to the preferred server.


                          I am guessing this is a permissions issue but I cannot figure out where.


                          This is a clean install of LDMS with the only difference being that the location of our deployment files is on a seperate drive.


                          I am going to raise a support call for this as I need to get this wiorking soon!!



                          • 10. Re: Cannot deploy image

                            I'm a bit confused on the steps that you have in your template... Could you take a screenshot similar to mine attached and post it?


                            I'm confused because you said URL when images should be mapped via UNC.

                            Screen Shot 2013-08-20 at 1.03.52 PM.jpg

                            • 11. Re: Cannot deploy image
                              RobLent Specialist

                              I think it is pretty much the same as yours.


                              But I have it working now!


                              Well, to a point.  It is deploying the image but when it reaches HII it fails.  It seems there is no C: drive at this point for it to copy the files to.  But if I reboot the PC it boots into Windows fine so there is a c drive!


                              Would this be my image at fault here?



                              • 12. Re: Cannot deploy image
                                bnelson Employee

                                You are missing a few tools. I will post a template that should help in a little bit.

                                • 13. Re: Cannot deploy image
                                  bnelson Employee

                                  I tried to add the template but I cannot attach it to the post. I posted two screen shots of the tools you will need to run to resolve the issue you are having now.temp1.JPG




                                  • 14. Re: Cannot deploy image
                                    RobLent Specialist

                                    Excellent.  Many thanks for your help.


                                    I will give these a try and let you know how it goes.