2 Replies Latest reply on Aug 31, 2016 1:07 AM by Positiv

    Failed: Can't launch ldav.exe - AV install

    MarcRBT Rookie

      Hi

      I have created a server agent that includes an AV install, this works and installs on a number of devices. These devices show as having upto date pattern file dates in Security activity. However I have a number of devices that fail, they show as out of date pattern files. They never update. When i connect the failed devices and attempt to open 'LANDesk Antivirus' it does not open the GUI.

       

      I have been installing using 'Install/ Update security components' in security activity. When they fail the log below shows the error.....

       

      Extracting C:\Program Files (x86)\LANDesk\LDClient\ldavhlpr.dat to C:\ProgramData\vulScan\ldavhlpr

           Done

      Installing LANDesk Antivirus client

      Contacting server...

       

       

           Failed: Can't launch ldav.exe

      Contacting server...

       

       

      I'd be grateful for an pointers.

       

      Thanks in advance

        • 1. Re: Failed: Can't launch ldav.exe - AV install
          MarcRBT Rookie

          Hi All

          I've done a little more digging on this, I still see the issuse on the same machines. I have tried a complete remove of the agent and AV on each machine. After a reinstallI I get the same error.

           

          After some more digging the install failure seems to stem from a failure of LDAV.EXE.

           

          I see the below in installav.log

           

          Installing LANDesk Antivirus client

          Failed (timed out) waiting for process (handle 0x588).  Timeout was 1800000 milliseconds

          ERROR: Failed to execute C:\Program Files (x86)\LANDesk\LDClient\antivirus\LDAV.exe /install (0x32F920)

          Last status: Failed: Can't launch ldav.exe

          AV: Failed to install Kav client.

          Vulscan reboot key exists.  Reboot is needed.

          Reboot is needed.  Will reboot and try again..

           

           

          If i run C:\Program Files (x86)\LANDesk\LDClient\antivirus\LDAV.exe /install manually from the command line I get a Microsoft Visual C++ error in LDAV.EXE.

           

          ldav_install.log shows.....

           

          Fri, 04 Oct 2013 13:29:17 [16] ERROR: Could not find Product section, sleep for 10 seconds and try again

          Fri, 04 Oct 2013 13:29:27 [17] ERROR: Could not find Product section, sleep for 10 seconds and try again

          Fri, 04 Oct 2013 13:29:37 ERROR: Could not find Product section

          Fri, 04 Oct 2013 13:29:39 vulscan app path dir: C:\Program Files (x86)\LANDesk\LDClient\

          Fri, 04 Oct 2013 13:29:39 ERROR: a key file does not exist, unable to activate the license.

          Fri, 04 Oct 2013 13:29:39 Replacing image and layout files...

          Fri, 04 Oct 2013 13:29:39 --------------------------------

          Fri, 04 Oct 2013 13:29:39 Copying images C:\Program Files (x86)\LANDesk\LDClient\antivirus\install\images ==> C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\images

          Fri, 04 Oct 2013 13:29:40 Copying images C:\Program Files (x86)\LANDesk\LDClient\antivirus\install\images\LDHashDir ==> C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\images\LDHashDir

          Fri, 04 Oct 2013 13:29:40 ERROR: Failed to create directory recursively: C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\images\LDHashDir (0x5)

          Fri, 04 Oct 2013 13:29:40 ERROR: Failed to copy C:\Program Files (x86)\LANDesk\LDClient\antivirus\install\images ==> C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\images

          Fri, 04 Oct 2013 13:29:40 Replacing localization files...

          Fri, 04 Oct 2013 13:29:40 --------------------------------

          Fri, 04 Oct 2013 13:29:40 Replace with LANDesk English files...

          Fri, 04 Oct 2013 13:29:40 ERROR: Failed to delete C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\loc\en before updating the folder

          Fri, 04 Oct 2013 13:29:40 Copying images C:\Program Files (x86)\LANDesk\LDClient\antivirus\install\loc\en ==> C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\loc\en

          Fri, 04 Oct 2013 13:29:40 Copying images C:\Program Files (x86)\LANDesk\LDClient\antivirus\install\loc\en\LDHashDir ==> C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\loc\en\LDHashDir

          Fri, 04 Oct 2013 13:29:40 ERROR: Failed to create directory recursively: C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\loc\en\LDHashDir (0x5)

          Fri, 04 Oct 2013 13:29:40 ERROR: Failed to copy C:\Program Files (x86)\LANDesk\LDClient\antivirus\install\loc\en ==> C:\Program Files (x86)\LANDesk\LDClient\antivirus\kav\skin\loc\en

          Fri, 04 Oct 2013 13:29:40 valueStrUTF8: Registered trademarks and service marks are the property of their respective owners.

          Fri, 04 Oct 2013 13:29:40 valueStr: Registered trademarks and service marks are the property of their respective owners.

          Fri, 04 Oct 2013 13:29:40 Successfully set HKLM\Software\LANDesk\ManagementSuite\WinClient\Antivirus\ProductInfo.Warning2.en -> Registered trademarks and service marks are the property of their respective owners.

          Fri, 04 Oct 2013 13:29:40 C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Kaspersky Endpoint Security 8 for Windows does not exist

          Fri, 04 Oct 2013 13:29:40 #########################

          Fri, 04 Oct 2013 13:29:40   Applying settings     

          Fri, 04 Oct 2013 13:29:40 #########################

          Fri, 04 Oct 2013 13:29:40 Enable self-defense: false

          Fri, 04 Oct 2013 13:29:40 [0] ERROR: Could not find Product section, sleep for 10 seconds and try again

          Fri, 04 Oct 2013 13:29:50 [1] ERROR: Could not find Product section, sleep for 10 seconds and try again

          Fri, 04 Oct 2013 13:30:00 [2] ERROR: Could not find Product section, sleep for 10 seconds and try again

          Fri, 04 Oct 2013 13:30:10 [3] ERROR: Could not find Product section, sleep for 10 seconds and try again

          Fri, 04 Oct 2013 13:30:20 [4] ERROR: Could not find Product section, sleep for 10 seconds and try again

           

          Thanks for any help in advance...

          • 2. Re: Failed: Can't launch ldav.exe - AV install
            Positiv Apprentice

            Hey buddy!

             

            Did you managed to resolve this one?