5 Replies Latest reply on Oct 17, 2013 7:28 AM by Stu McNeill

    Don't want to send e-mail for 'Successful Creation' - How do I turn it off?

    Apprentice

      Hi all,

       

      I'm stuck with what would seem like a very obvious problem. When users create a ticket by submitting an e-mail, I have my workflow set up to e-mail them using an automatic action. Unfortunately, Mail Manager wants to mail them too! I don't want to spam my users.  I do however want the Mail Manager to mail them for updates. When I leave the field blank (see screenshot) it just mails them a blank e-mail.

       

      The reason I need to use an automatic action is because that's the only way I can find to include the {id} (ticket #) in the header of the e-mail. LanDesk needs this information to make 'Add Note' updates on specific tickets.

       

      So I need to know one of two things.

       

      1.) How do I make Mail Manager insert the ticket # in the e-mail header on successful ticket creation

       

      2.) If that's not possible, how do I turn off the 'Successful Creation' automatic e-mail, while retaining the other e-mails (updates, failures, etc.)

       

      I'm attaching a screenshot for reference.

       

       

      Thanks very much.

        • 1. Re: Don't want to send e-mail for 'Successful Creation' - How do I turn it off?
          Apprentice

          Sorry, see screenshot. It didn't attach properly the first time.

           

          Untitled.jpg

          • 2. Re: Don't want to send e-mail for 'Successful Creation' - How do I turn it off?
            Apprentice

            Also, I'd like to be able to add notes on closed tickets. Can someone quickly advise on the best way to add a note to a closed ticket without re-opening it?

             

            Thanks.

            • 3. Re: Don't want to send e-mail for 'Successful Creation' - How do I turn it off?
              Stu McNeill Employee

              Hi,

               

              To insert the reference number in the email that you're generating from the assignment use the {Id} placeholder.

               

              To stop the default message being sent out you turn this off on your Mapping.  There is a dropdown called "Send Reply On" with the options None, Creation, Update, Both.

               

              To allow adding notes on closed records you need to update the process design to add the "Add Note" action (and "Add Attachment" if the emails could include them) as optional actions to the relevant status.

              1 of 1 people found this helpful
              • 4. Re: Don't want to send e-mail for 'Successful Creation' - How do I turn it off?
                Apprentice

                Hi Stu,

                 

                Thank you for your helpful response. Please allow me to follow up with a few notes.

                 

                1.) I know how to use the {Id} tag, but I don't know how to specify that it goes into the header of an e-mail, as opposed to the body, without using an automatic action in my process. Ideally, I'd like mail manager to be able to add the ticket # in the header. If it can do this, then it can update tickets using e-mail. I can't figure out how to do this.

                 

                2.) I want all default messages EXCEPT the create one to be sent on creation. Meaning, if the ticket fails on create, I want a message sent. If it successfully creates, I don't. The reason for this is due to what I posted in 1.) If I can't put the {Id} in the header of the e-mail, then I need to set my automatic action to do this. I do not want to send two auto-replies.

                 

                3.) I currently have "Add Note" added to my closed process. However, when I check my mail logs, I get this error:

                Attempt to write to attribute Title of a read-only Process.Process lifecycle object. When a lifecycle object reaches a read-only status they cannot be modified except through a lifecycle action.

                 

                So once my ticket closes, it becomes read-only. Do you know where I can change this setting?

                 

                Thanks a lot, Stu.

                 

                Chad.

                • 5. Re: Don't want to send e-mail for 'Successful Creation' - How do I turn it off?
                  Stu McNeill Employee

                  Hi Chad,

                   

                  No you can't change the subject on the reply sent by Mail Manager directly.  This will always be in the "Re: original subject" format.  The best solution would be to disable that and use an assignment or reminder in the process.

                   

                  I think your error is caused by how your mail mapping is configured.  Take a look at what is mapped to Title, does it have both a green and red tick next to it?  If so right-click it and select "Creation" to ensure the Title only gets updated on creating incidents and not on updating them.  Do the same to Description if that is mapped.  You can still add a note when the incident is read only so we don't need to worry about that side of it.