1 2 Previous Next 19 Replies Latest reply on Mar 1, 2015 2:19 AM by ampotgieter

    HP 840 unable boot into WinPE


      We are demoing an HP 840 and we have tried every 840 g1 nic driver in the WinPE 3.1 (LANDesk 9.5 no SP).  We are not in a place to update to 9.5 SP1 which has WinPE 4.0.  Is there anyone out there that has any ideas to get the Nic driver to load in WinPE 3.1?

        • 1. Re: HP 840 unable boot into WinPE
          sd8it Rookie

          I second the question. Has anyone been able to get this to work?

          • 2. Re: HP 840 unable boot into WinPE

            To really troubleshoot this you would need the Device IDs of the devices in question.  In 9.5 SP1 (which I know is apparently not an option right now) there is a parameter in HiiClient that will dump all the hardware information on the device.  The parameter is /previewall.


            In 9.5 flat and earlier you would need to go into device manager on one of these HP 840 devices and find the device.  Double click it and go to Advanced.  From there find Hardware IDs.  Post the Hardware IDs here and I can help find the appropriate WinPE driver.



            • 3. Re: HP 840 unable boot into WinPE
              sd8it Rookie





              • 4. Re: HP 840 unable boot into WinPE



                I don't have an 840 to test with, but according to the device IDs it should be the file:

                e1d6232.inf (for Win7 x86, or WinPE 3.x)

                e1d6332.inf (for Win8 x86, or WinPE 4.x)

                e1d6432.inf (for Win8.1 x86 or WinPE 5.x)


                For x64 drivers you would use:

                e1d62x64.inf (for Win7 x64, or WinPE 3.x)

                e1d63x64.inf (for Win8 x64, or WinPE 4.x)

                e1d64x64.inf (for Win8.1 x64, or WinPE 5.x)



                Here's a download link for Intel's drivers, valid as of when I posted this:



                Download either the Windows 7 or Windows 8 package.  In reality they are the same file and both Win7 and Win8 (and Win8.1) drivers are included.


                Instead of running the exe package with the parameters to extract the drivers (which I always forget the command line to do) I would just use 7-zip and extract the files.  Once they are extracted you can add the Win7/WinPE 3.x driver to the images.  To do so, use the Add Drivers to WinPE tool and browse to PRO1000\Win32\NDIS62\e1d6232.inf.  Add that driver to boot.wim and bootMedia.wim.  Then browse to PRO1000\Winx64\NDIS62\e1d62x64.inf.  Add that driver to boot_x64.wim.


                Let me know if that driver works for you.



                1 of 1 people found this helpful
                • 5. Re: HP 840 unable boot into WinPE

                  Thank you Mach6.  When I added this driver to the WinPE I made a "minor" error and only put the .inf file in the folder where I chose it for the PE.  I have since learned if you do not have the supporting files in the location of the .inf the PE will have the driver but it will still fail.  I am able to PXE boot this device but I am still having a strange issue on VBooting.  Which makes no sense to me because I am copying the boot.wim from the Core Server.  My guess it has to do with cloning a vboot template but that will have to wait until Monday.


                  Mach6 do you have any insight on creating USB boot media and why after the first time I created a USB boot it no longer creates useable boot media.  I keep getting a problem with the BOOTMGR failed to load.  I know probably another post but just checking.  I read your advice frequently. 



                  • 6. Re: HP 840 unable boot into WinPE
                    sd8it Rookie

                    Thanks for the information. Once I added that driver, I got a new message: "An error occurred with the boot selection. Verify media is present and try again."


                    So I followed these steps:


                    Enabled legacy mode in the BIOS.


                    Boot laptop and press F10.

                    Select [Advanced]

                    Select [Boot Options]

                    Scroll down to [SecureBoot Configuration]

                    Uncheck [SecureBoot]

                    Select [legacy] under Boot Mode

                    Save and exit.

                    Reboot, press [F12]


                    My PXE boot menu loaded, but once I selected my WinPE Menu item, it cycled back to the PXE boot menu after flashing mtftp on the screen .


                    I'm definitely missing something obvious here.

                    • 7. Re: HP 840 unable boot into WinPE

                      Same here, having the same problem on both the HP Elitebook 820 and the 840 models.  


                      I press F12, get a response and press F8, flashes something about MTFTP, and reboots.

                      • 8. Re: HP 840 unable boot into WinPE

                        sd8it and webbway,


                        I would check to make sure that the PXE rep has boot.wim and boot_x64.wim.  Additionally I'd check for the bcd, bcd_x64 and bcd_ia32 files (or something similar) and make sure they're all there.  Let me know what you find out.


                        If you could find out what the MTFTP message is that would also be very useful.



                        • 9. Re: HP 840 unable boot into WinPE
                          sd8it Rookie

                          The PXe rep did have both the 32 and 64 versions of the files.


                          The only MTFTP message that comes up is...MTFTP.


                          I belive we may have come up with a solution, however I no longer have the demo device on site...if someone wants to test my theory....


                          In a similar situation with a mobo replacement, we had to roll back the BIOS version to Windows 7. Perhaps this will work in this situation as well?

                          • 10. Re: HP 840 unable boot into WinPE

                            Same here, PXE rep did have both the 32 and 64 versions of the files.  Still have our demo systems and would be interested in your solution/theory.

                            • 11. Re: HP 840 unable boot into WinPE
                              sd8it Rookie



                              Try to install the Windows 7 BIOS. We did something similar with a Lenovo because we were getting the same MTFTP situation after a mobo replacement. It worked like a charm.

                              • 12. Re: HP 840 unable boot into WinPE
                                DesktopAdmin Rookie

                                Any update on this guys?  We are demoing the Elitebook 820 and 840 models and cannot pxe boot with them.  The only way I could get our company image down was by creating a LANDesk boot disk.  I would prefer not to use a boot disk and to be honest, I probably will not buy these models if this doesn't get fixed soon.  The question I have is this a HP issue, maybe with the BIOS, or is it a LANDesk issue.  We are on LANDesk 9.5 SP1.  Here's something interesting.  A link to Symantecs forums in regards to Altris.  This guy was having the same issue but other folks were able to get it to work.  Maybe this can work for LANDesk too. 



                                • 13. Re: HP 840 unable boot into WinPE

                                  I fought the 820 as well but I can verify adding the e1d6332.inf (for Win8 x86, or WinPE 4.x) driver to your WinPE image using the LD console will allow you to deploy an image. Of course this does not necessarily help the OP because we are currently 9.5SP1. Either way I though i'd throw this one out there in case anyone else is having the trouble.

                                  • 14. Re: HP 840 unable boot into WinPE
                                    ahe Expert



                                    it seems that the problem appear on newer DELL clients with new BIOS since last December and HP clients too.


                                    We found a solution on the PXE server.


                                    On the server the MTFTP settings must be changed.

                                    This can by done with the GUI (sometimes I have had problems that settings are not made in this way)


                                    In PXE Configuration Utility – Boot Server – Configure Boot Server – MTFTP Options.

                                    Uncheck “Enable Multicast Transmit” and restart the PXE services “LANDesk PXE Service” and “LANDesk PXE MTFTP Service”.


                                    or by patching the Registry:


                                    32 Bit server OS:


                                                  MCAST_ENABLE set to 0

                                    64 Bit server OS:


                                              MCAST_ENABLE set to 0





                                    P.S.: in the meantime I found another thread with the hint to this doc: http://community.landesk.com/support/docs/DOC-30310

                                    1 2 Previous Next