2 Replies Latest reply on Jun 3, 2008 5:48 AM by SteveG

    Policy distributions not running on all devices

    Apprentice

       

      Policies seem to work on most (80%) devices. However, the ones that do not run get stuck at pending indefinitely. It is not the same devices each time. We are running 8.8 and the tasks are either batch files, exes or MSIs. The distribution method is policy - required installation. All clients have the same agent.

       

       

      The policy.invoker is running and the policy.sync.log shows no errors (attached). an example of a task that is not running is id no 905. for some reason, this client and a few others will not even try to run task 905 although they successfully run other tasks. The policy.sync.log contains no information regarding task 905 whatsoever.

       

       

      I'm assuming now that this problem is caused on the core somewhere. In non technical terms presumably when you schedule a policy the global scheduler creates a list of devices that should get the task. When the client checks with the core it sees if there are any tasks it should have from that list. If there are it downloads them. If there not it doesn't. If I'm righ, the question must be, why does the global scheduler miss devices off the list? Am I right or is the process completely different?

       

       

      Extract from attached policy.sync.log

       

       

      Thu, 29 May 2008 11:21:59 Policy synchronization stated.

      Thu, 29 May 2008 11:22:00 Sending update request to core server.

      Thu, 29 May 2008 11:22:00 Web request returned 0 The web request was successful.

      Thu, 29 May 2008 11:22:00 Processing update response.

      Thu, 29 May 2008 11:22:01 Process update

      Thu, 29 May 2008 11:22:01 Client Hash:

      Thu, 29 May 2008 11:22:01 No Data Returned for Update check

      Thu, 29 May 2008 11:22:01 Get Update complete.

      Thu, 29 May 2008 11:22:01 Sending policy request to core server.

      Thu, 29 May 2008 11:22:01 Requesting policy for {3328604F-CC1D-B541-BD1B-FD7A9730C144}, user , ldap user , ladp machine

      Thu, 29 May 2008 11:22:01 Web request returned 0 The web request was successful.

      Thu, 29 May 2008 11:22:02 Preparing to download file SDClientTask.MAGPIE.937.xml (hash dx73mCH0IMDHqSTiMUm8iA==)

      Thu, 29 May 2008 11:22:02 Preparing to download file SDClientTask.MAGPIE.501.xml (hash mrezRkqkIqd05/Yh2fuQ==)

      Thu, 29 May 2008 11:22:02 Preparing to download file SDClientTask.MAGPIE.325.xml (hash xIaQAo77RqZ3Z8Qh1KTpCQ==)

      Thu, 29 May 2008 11:22:02 Downloading files to C:\Documents and Settings\All Users\Application Data\LANDesk\ManagementSuite\landesk\files\

      Thu, 29 May 2008 11:22:02 Performing TCP connection with a timeout of -1 milliseconds

      Thu, 29 May 2008 11:22:08 Download information for http://127.0.0.1:9592/landesk/files/SDClientTask.MAGPIE.937.xml : 4,509 bytes in 0:00:04.593 seconds, bandwidth 0.9587 kb/s

      Thu, 29 May 2008 11:22:08 The remote operation file http://127.0.0.1:9592/landesk/files/SDClientTask.MAGPIE.937.xml was downloaded to C:\Documents and Settings\All Users\Application Data\LANDesk\ManagementSuite\landesk\files\SDClientTask.MAGPIE.937.xml.

      Thu, 29 May 2008 11:22:08 Performing TCP connection with a timeout of -1 milliseconds

      Thu, 29 May 2008 11:22:11 Download information for http://127.0.0.1:9592/landesk/files/SDClientTask.MAGPIE.501.xml : 4,694 bytes in 0:00:01.593 seconds, bandwidth 2.8776 kb/s

      Thu, 29 May 2008 11:22:11 The remote operation file http://127.0.0.1:9592/landesk/files/SDClientTask.MAGPIE.501.xml was downloaded to C:\Documents and Settings\All Users\Application Data\LANDesk\ManagementSuite\landesk\files\SDClientTask.MAGPIE.501.xml.

      Thu, 29 May 2008 11:22:11 Performing TCP connection with a timeout of -1 milliseconds

      Thu, 29 May 2008 11:22:12 Performing TCP connection with a timeout of 2500 milliseconds

      Thu, 29 May 2008 11:22:12 SAD ProcessNeedFileReply about to download http://127.0.0.1:9592/landesk/files/SDClientTask.MAGPIE.325.xml from peer 191.37.23.2

      Thu, 29 May 2008 11:22:20 The remote operation file http://127.0.0.1:9592/landesk/files/SDClientTask.MAGPIE.325.xml was downloaded to C:\Documents and Settings\All Users\Application Data\LANDesk\ManagementSuite\landesk\files\SDClientTask.MAGPIE.325.xml.

      Thu, 29 May 2008 11:22:20 Processing new and updated remote operations

      Thu, 29 May 2008 11:22:20 Processing remote operation SDClientTask.MAGPIE.937.xml

      Thu, 29 May 2008 11:22:21 Processing remote operation SDClientTask.MAGPIE.501.xml

      Thu, 29 May 2008 11:22:22 Processing remote operation SDClientTask.MAGPIE.325.xml

      Thu, 29 May 2008 11:22:23 Processing deleted remote operations

      Thu, 29 May 2008 11:22:23 Processing remote operation SDClientTask.MAGPIE.407.xml

      Thu, 29 May 2008 11:22:24 Policy request has been processed.

      Thu, 29 May 2008 11:22:24 Checking for rescheduled policies

      Thu, 29 May 2008 11:22:24 Policy Synchronization application complete.

       

       

      Any help would be greatly appreciated.

       

       

        • 1. Re: Policy distributions not running on all devices
          phoffmann SupportEmployee

          Is your Core patched at all? There's a few patches that are greatly recommended to have in regards to policy problems.

           

          You can request them from support if you do not have them by opening a ticket.

           

          These would be:

          CORE-769588.0

          SWD-748788.0-2 (requires SWD-482688.0-2 as well)

          SWD-482688.0-2 (requires SWD-748788.0-2 as well)

           

          Second - what happens if you re-start this task 905 ? Generally, if a task is not working "globally", it sounds more like (indeed) there is something on the Core-side that's going wrong - Global Scheduler logs may bring up some useful information here potentially (if you're familiar with them?).

           

          Paul Hoffmann

          LANDesk EMEA Technical Lead.

          • 2. Re: Policy distributions not running on all devices
            Apprentice

             

            Hi Paul,

             

             

            Thanks for getting back to me. I do have a ticket logged (00118436) but thought I'd log it here in case someone else had seen it and the problem was resolvable without a patch. The following patches have been applied,

             

             

            SWD-748788.0-2 5/16/2008 10:47:47 AM

            SWD-482688.0-2 5/16/2008 10:47:47 AM

            CORE-769588.0 5/16/2008 10:48:13 AM

            swd-866288-2

             

             

            If I restart the task the same thing happens. I have attached a few log files but to my untrained eyes everything looks error free.  i have also attached a screen shot of task 905. in this instance, 905 is just an example. it seems to happen on all policy tasks. Incidentally, Push works fine.