4 Replies Latest reply on Jan 24, 2014 2:43 AM by tucano

    LANDesk Background Services not starting, COM+ crash, Touchpaper logon failed, reminder not working

    Rookie

      Hi all,

      i'm installing LANDesk 7.6.2 Service Desk and Management Suite on a Windows 2008 R2 with a remote SQL Server 2008.

      I restored LANDesk database the vendor provided to me and configured LDSD and LDMS. Now i'm creating scheduled tasks and creating process automatic reminders, but they don't work.

      I saw that Windows Background Services are down, with also CI Linking Services, Knowledge Management Services.

      I see in the event viewer every minute this error:

       

      TouchpaperException

      Touchpaper Error Code: Exception.Authentication.LogonFailed (-2147218680)

      Logon failed

       

       

      Stack Trace:

         at Touchpaper.Framework.SystemServices.Authenticator.ValidateCredentials(ITpsCredentials tpsCredentials, Boolean isAnonymous)

         at Touchpaper.Framework.SystemServices.Authenticator.Logon(ITpsSession tpsSession, ITpsEnvironment environment, ITpsCredentials tpsCredentials, Boolean isAnonymous)

         at Touchpaper.Framework.SystemServices.SoapExtensions.CombinedExtension.AuthenticateRequest(SoapServerMessage message)

         at Touchpaper.Framework.SystemServices.SoapExtensions.CombinedExtension.ProcessServerMessageAfterDeserialize(SoapServerMessage message)

         at System.Web.Services.Protocols.SoapMessage.RunExtensions(SoapExtension[] extensions, Boolean throwOnException)

         at System.Web.Services.Protocols.SoapServerProtocol.CreateServerInstance()

         at System.Web.Services.Protocols.WebServiceHandler.Invoke()

         at System.Web.Services.Protocols.WebServiceHandler.CoreProcessRequest()

       

       

      Similar Logon error messages are shown for the other services, but only on Windows Start.

       

      Service cannot be started. System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:80

         at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)

         at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

         --- End of inner exception stack trace ---

         at System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)

         at System.Net.HttpWebRequest.GetRequestStream()

         at Microsoft.Web.Services2.SoapWebRequest.GetRequestStream()

         at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

         at Touchpaper.Framework.SoapClient.Web.SoapClientProxy.Invoke(String action, Object[] arrayParams)

         at Touchpaper.Framework.Data.Metadata.MetadataService.GetCatalog(...

       

       

      They basically try to start with the OS, but suddently throw Logon failed and shut down. If I try to start them manually from Services.msc in Windows i get:


      The LandeskServiceDesk Background Service service on Local Computer started and stopped. Some services  stop automatically if they are not in use by other services or programs.

       

      If I start them manually from ConfigurationCentre, it goes on timeout throwing IIS error on the webpage.

       

      Also ServiceDesk.Framework, if I try to click update, simply hangs, like nothing is being done by ConfigurationCentre, but it is up if i reach it through web browser. The DB connection works if I test it.

       

      Furthermore, I notice that LANDesk COM+ Applications Landesk and Landesk1 crash every random interval, and I have to manually re-type the password (Domain Admin privileges) and then they start again. Running them as Built in Service account seems to make them crash less often, but doesn't solve the problem. I also deleted those COM+ apps and rebuilt them following the documentation found on the community.

       

      I also noticed that I have under IIS Default app pool several SSL certificates, not only one. and This might be a problem, since all this started to happen just after a license renewal.

       

      I need to get Windows Services start, and I think all this problems are linked together.

       

      I tried all that is here on community and nothing solved my error. Please do you have any thoughts about how to solve the problem? It's driving me crazy. Thank you.