5 Replies Latest reply on May 30, 2018 2:47 AM by phoffmann

    Inventory scan isn't updating Custom Data values


      Last week I added some Custom Data fields (registry values for Java Update info).  After the inventory scan, the values showed up for the machines (JavaRT & Policy)



      Over the weekend I ran a job to update the registry enties to what we require and inventory got updated as picture above.   However, upon reboot, the registry entries reset to the original values (that;s a different can of worms).


      The Inventory has not reverted even with a FULL SYCN SCAN.   If I use REGEDIT on the machine the values are different then the LDMS Inventory.

      At this point I can't trust the Custom Data I have in inventory.


      How can I get this corrected?


      I'm running LDMS 9.0, SP3.


      Thanks for your help.

        • 1. Re: Inventory scan isn't updating Custom Data values
          MrGadget Expert

          I don't have an answer but here are some thinking points.


          1. The values show up in inventory, this shows the inventory scanner is reading the registry entries so it is working as it is suppose to.


          2. You change the registy entries and on reboot the registry entries you made aren't there. This suggests something running on the computer is constantly writing to these registry entries.


          3.The Inventory has not reverted even with Full Sync Scan. Are you actually doing a Full sync scan? Manual right click on computer in console- Inventory scan- Full sync scan.

          The inventory after a Full Sync Scan should show exactly what it read from the registry.

          Run this on the computer   ldiscn32.exe /o=C:\scaninfo.txt  (You'll probably have to CD to the landesk\ldclient folder to run this)

          This will put the finding of the inventory scan in a file call scaninfo.txt in C:\  (This does not send the results to the core.)

          Look in there and see if the correct custom data is being picked up. If it is somehow its not being sent to the core during a normal Full ync scan.

          • 2. Re: Inventory scan isn't updating Custom Data values

            Mr Gadget-


            Thanks for your response.


            1) Yes, I would agree that the inventory scanner reported the values it saw the first time it read the new Custom Data fields I created.


            2) Yes, I did run a FULL SYNC SCAN (right click | Inventory Scan | FULL SYNC SCAN).  I've run this repeatedly.


            3) I ran the file to a text file on my desktop.  The file had "wrong" values. It contained the values I see in Inventory. 



            It appears that once established, the CUSTOM DATA fields are never updated again.

            • 3. Re: Inventory scan isn't updating Custom Data values
              bcarmody Rookie

              I'm replying to this old thread in hopes that someone might have seen this and know of a solution. We are running into the exact same issue here. We have a process we run periodically to change the common local account passwords on all of our endpoints. When we do this, we modify a registry value noting that the passwords were changed for that period. We have Custom Data set up to monitor this. The task runs properly and updates the registry value properly. However, it seems to take some time before the computer inventory in the LanDesk console recognizes the change. I'd like to say that it eventually does recognize it, although I can't say with 100% certainty, but it seems to take quite a bit of time on some computers and no number if inventory scans speeds it up. As the OP did, I have confirmed on multiple machines that the registry value was updated and have run full scans with output to a text file. While the registry is correct, the outputted text file still contains the incorrect value.


              I feel this has been happening for a while with other Custom Data entries as the behavior has always been erratic. I haven't thought much of it though until now when I need to report the status of these updates to leadership and the numbers can't be trusted.


              Any help is appreciated. Thanks in advance.


              • 4. Re: Inventory scan isn't updating Custom Data values
                meltdowner Apprentice

                I'm experiencing the same problem right now.  In my case, I've created a query that pulls the ReleaseID from the registry (aka the windows 10 version number 1703/1709/1803 so forth).  The data was there and working at one point.  Now, computers that I know have had their version change do not show in landesk.

                • 5. Re: Inventory scan isn't updating Custom Data values
                  phoffmann SupportEmployee

                  I would suggest potentially starting a new thread for this, but the following should help a bit.


                  • Run an output scan ( LDISCN32 /F /O=C:\Temp\MyOutput.scn ) on a device where "stuff don't work", and have a look inside the SCN file (it's just a text file) whether your custom data is in there in the first place.
                    • If it is, proceed further down.
                    • If the custom data ISN'T there, then see what happened to the registry location being queried / searched. Usually a permissions issue can be a problem, and/or "the registry key moved somewhere else now" tends to be the other big variant.



                  • That should cover the 2 most likely scenarios ... let's begin here & go from there.