4 Replies Latest reply on Jun 11, 2008 3:46 AM by nmason

    Problem Silently Deploying an MSI - Avaya IP Softphone

    Rookie

      Trying to deploy the Avaya IP Softphone application to a particular

      client as a test and just cannot seem to get the install to work.

       

      I have created a .MSI file and a .MST file from the original .EXE which

      definitely works and installs just fine, and i can also get the MSI to

      install just fine silently by using the DOS command:

       

      msiexec /i sp_res.msi ADDLOCAL=Complete,IPSP /qn

       

       

       

      and also when i run:

       

       

       

      msiexec /i sp_res.msi TRANSFORMS=sp_res.mst (although this is not silent for some reason it tells me the installer still should work)

       

       

       

      I am sure this is not a permissions error because i can deploy and

      install a .MSI test file from the same location, which works just fine.

       

       

       

      The Distribution Package uses the MSI as its primary file, and as an install option under Command Line, i have specified: "TRANSFORMS=sp_res.mst" - also pointing to the .MST as an additional file....every other option in the Distribution Package is pretty much default.

       

       

       

      In the Scheduled Task i have set that Distribution Package as the Main Package,

      and have tried a Standard Unicast Push, Emergency Distribution as well

      as placing the install as a policy to appear in the Software Deployment

      Portal. Each one of these distributions gives the same error.

       

       

       

      The files are getting to the host as i can see the proper file structure populating in C:\Program Files\LANDesk\LDClient\sdmcache\ although the install will not work

       

       

       

      On the host i get 2 Event Log messages: "Failed to connect to server. Error: 0x800401F0" and "Product: Avaya IP Softphone R6 -- Installation failed."

       

       

       

      and i have attached the log from Landesk (the result shows as "Failed to install package")

       

       

       

      Can anyone see where i am going wrong?

       

       

       

      Thanks