7 Replies Latest reply on Mar 18, 2014 9:40 AM by blwallace

    Preferred = replica = source server

    blwallace Specialist

      New to LANDesk with 9.5sp2 and setting up in our lab first before production.  Configuring HII and trying to create the library.  The library requires a preferred server and I'm getting stuck on this configuration.  My environment will only need on server to hold all patches.  When creating a preferred server, the configuration looks to need a source server and a replica server as well.  Can this all be combined into one?  Can a source server, replica server and preferred server all be the same server?

        • 1. Re: Preferred = replica = source server
          Jack.rotherham Specialist

          You can just add a device in as a preferred server without adding any replication settings. Just fill in the preferred server name, username, password and if required the specific subnets that it will server.

          • 2. Re: Preferred = replica = source server
            amagi Expert

            As jack told, you need to set a device as preferred server, I usually use the core server

            • 3. Re: Preferred = replica = source server
              blwallace Specialist

              I have my preferred server set - no replica, no source.  Read only credentials test successful.  When I move to HII Driver Management -> Build Libary and put in my UNC path to my preferred server and select Save, I get:

               

              "Access to the path \\preferredServer\driverLocation is denied.  The specified user does not have adequate permissions to access the driver location."

               

              So I'm thinking that the permission level is configured using the preferred server properties.  Using Write credentials inside Preferred server properties I get:

               

              "No sources have been selected to test credential against.  At least one source must be selected"

               

              Obviously, I'm missing something.

              • 4. Re: Preferred = replica = source server
                amagi Expert

                Try checking this doc to find what you are missing

                http://community.landesk.com/support/docs/DOC-20782

                • 5. Re: Preferred = replica = source server
                  blwallace Specialist

                  Thanks for that info.  I've previously read that document.  That document suggests needing preferred, replica and souce servers. The following suggests I need a replicator to WRITE files to the Preferred server. I don't need that structure. 

                   

                  Write Credentials

                  • User name: This is the user that will be used by the replicator to WRITE files to the Preferred server. The user should be in the form domain\username. This user name will not be delivered to any client devices other than the replicator. It is recommended that the user be a domain user or service account with the password set to never expire
                  • Password: The password for the above user.
                  • Test credentials...: This will open a tool that will test the write credentials to ensure that all needed shares can be written to.
                  • 6. Re: Preferred = replica = source server
                    amagi Expert

                    Before SP2 setting up a source was not needed, now I saw a weird behavior:

                    in my test core I set up a simple preferred server and tryed to build driver library...and it told me that I need a source.

                    So I created a source pointing to my UNC path for drivers, tryed to build library and everything worked fine.

                    Just for test, I deleted the source and tryed to build library again...still working.

                    Can you try the same?

                    • 7. Re: Preferred = replica = source server
                      blwallace Specialist

                      My experience has been:

                      1. Distribution->Content replication/Preferred servers; my Server name must be an IP address for my Test credentials to work (only testing UNC).  I leave the Selected replicator empty as well as Sources.  Save that configuration. 
                      2. Distribution->HII Driver Management->Build Library; Root UNC path must text match whatever I put in the Preferred server. e.g. prefererd server=192.168.1.100, hii root unc=\\192.168.1.100 or preferred server=myserverName, hii root unc=\\myserverName.  Odd and totally wrong that it doesn't use a DNS lookup for this but must match a text string.
                      3. Once #1 and #2 are in sync, I can build my library
                      4. The only time my Test credentials work (#1) is when I use an IP address in the server name.  If I switch to dns name, my Test credentials (UNC only) do not work.  After my credentials test correctly in #1, I can switch to dns name (#1) then move to HII and text match the Root UNC there and my library builds.

                       

                      Seems like this is a bug...