5 Replies Latest reply on May 12, 2014 5:21 AM by CRB

    9.5 (sp1 and sp2) remote Agents not updating Inventory

    jfisher Rookie

      We have seen strange client scan behavior on our Mac clients for a while, off site Mac OS (Lion through Mavericks) agents will do little more than send in a basic time stamp update to the core inventory service, which is misleading as the sofware and hardware scans are not being updated. When initiating a scan from the client, we saw the following:

       

      ldiscan (303) <Critical>: Last scan date : Sun Dec 31 2000 18:00:00 CST

      ldiscan (303)<Critical>: Last scan date occured more than 24 hours old (115510 hours, 7 minutes)

      ldiscan (303s0<Error>:No destination. Not scanning to the cre, and nto scanning to file, stopping scanning now.

       

      This after new agent installation, rebooting, verifiying (requesting) a certficate successfully to communciate via the gateway,  confirmation that the software portal is fully functional, waiting several days, and attempting to force full scans via terminal on the client and even deleting and recreating the client on the core server, verifying all permissiosn to all of the folders on the core server and verifying all permissions we could think of in general(to cover the high points).

       

      What brought this to our attention was the deployment of updated agents, the name of the LANDesk agent would never update in the console no matter what we tried.

       

      Now I have gone into this same  client again and changed the agent setting to allow it to store inventory scans locally in addition to sending to the core.

       

      Fixed. Core updated immediately upon a scan request from the client. Nothing else changed. We have reproduced this scenario on several systems at this time.

       

       

       

      Now we had local scans turned off, due to concerns that they would build up and eventually take up storage.... so we have two questions:

       

      1. Has anyone had a similar experience?

      2. if scans are allowed to store locally, how are those scans kept cleaned up on the clients for maintenence purposes?

        • 1. Re: 9.5 (sp1 and sp2) remote Agents not updating Inventory
          SupportEmployee

          We would need more information on this one to be helpful.  Really we would want to look at your landesk.log that is located in /Library/Application Support/LANDesk.  Did they scan locally without an issue? Did they have the certificates requested via the management gateway app that is in /Library/Application Support/LANDesk/bin ?

          • 2. Re: 9.5 (sp1 and sp2) remote Agents not updating Inventory
            jfisher Rookie

            See below for one of the test client's log entry for that day...

            1. Once we enabled local scans, the scans are being saved locally and sent into the server as well. We have not tested offline behavior, but can if that would be helpful.

            2. The certs were requested via the gateway app, and can be seen in the  /usr/landesk/common/certs folder.

             

            Thank you for your taking a look!

            • 3. Re: 9.5 (sp1 and sp2) remote Agents not updating Inventory
              jfisher Rookie

              Any one else seeing these kinds of scanning /inventory glitches with Mac OS and 9.5sp2?

              • 4. Re: 9.5 (sp1 and sp2) remote Agents not updating Inventory
                Rookie

                Well I don't know if this is the same but, I upgraded from and old server runnning 9.5 to new server running 9.5 sp2.  Instead of updating all the agents on local machines, I copied the key and .crt files to the new server and had the DNS change to make the new server the old. 

                 

                After that, the Windows Machines started reporting but the MAC's did not. 

                 

                So after creating a new agent from the 9.5 SP2 server I installed it on a MAC and it still did not report to the core.  I opened the landesk agent on the MAC and on the configuration tab, the ldms sever was <ldms server>.ad.<schooldomain.edu>. 

                Know this is the same setting on the agent from the old server for both the Windows and the Mac agent and all worked well on 9.5.  I manually ran and invetory scan on the mac agent and it reported that it saved the file locally but could not connect to the server.

                 

                So on the configuration tab on the MAC I installed the new agent on, I took out the .ad and just have <ldms sever>.<schooldomian.edu>.  Then a manually reran the inventory scan and it worked. 

                 

                Now I am udating the Mac agent with that change and testing.   I don't know if it is a DNS issue however, it worked on the old server with both the Mac agent and Windows agent having the same settings.

                • 5. Re: 9.5 (sp1 and sp2) remote Agents not updating Inventory
                  Specialist

                  Try to restart the LANDesk management gateway service ! It was the easy fix for us.

                   

                  Had sort of same problem.

                  Differance, we are connecting to machines out of our domain via gateway. No Mac but windows