8 Replies Latest reply on Apr 10, 2014 1:09 AM by RobLent

    LDMS 9.5 SP2 and DISM

    RobLent Specialist

      Just upgraded our system to SP2 and after a few initial niggles during the upgrade process it all seems to be working OK!

       

      However just come to add some drivers to the boot.wim as done previoulsy but DISM is failing.

       

      Do I need to upgrade DISM now that SP2 is installed as I believe SP2 installs a later WIM version??

       

      Thanks,

       

      rob

        • 1. Re: LDMS 9.5 SP2 and DISM
          Apprentice

          At what point in the process is DISM failing?

          Can you check the DISM log on your core server located at C:\Windows\Logs\DISM\dism.log? They may provide insight into what part of the DISM process is failing.

           

          From our core server on 9.5 SP2: I am able to load the GUI from the "Manage the drivers in the Windows PE image" link in OSD. I verified that dism.exe launched as a process in Task Manager on the core, then I added a dummy driver and finished the process successfully.

          • 2. Re: LDMS 9.5 SP2 and DISM
            RobLent Specialist

            Thanks for the reply.

             

            I have checked the log.  It fails when I am trying to add drivers to the mounted boot.wim.

             

             

            CDISMManager::CreateImageSession(hr:0xc0000135)

            2014-04-04 08:06:29, Error                 DISM   DismHostLib: Failed to create DismHostManager remote object. Checking for dismhost.exe exit code.

            2014-04-04 08:06:29, Info                  DISM   DismHostLib: Found dismhost.exe exit code.

            2014-04-04 08:06:29, Error                 DISM   DISM Manager: PID=9300 Failed to create Dism Image Session in host. - CDISMManager::LoadImageSession(hr:0xc0000135)

            2014-04-04 08:06:29, Error                 DISM   DISM Manager: PID=9300 Failed to load the image session from the temporary location: C:\Scratch\C283F05E-8BDF-47ED-86A7-87366B0E3574 - CDISMManager::CreateImageSession(hr:0xc0000135)

            2014-04-04 08:06:29, Error                 DISM   DISM.EXE: Could not load the image session. HRESULT=C0000135

            2014-04-04 08:06:29, Error                 DISM   DISM.EXE: Unable to start the servicing process for the image at 'C:\Mount\BootWIM'

             

            I did some research and defined the scratch directory as can be seen int he error log and ensured permissions were set correctly.  I am also running the command prompt as administrator.

             

            This all worked fine until I installed SP2 last week!

            • 3. Re: LDMS 9.5 SP2 and DISM
              Frank Wils ITSMMVPGroup

              Is the boot.wim file mounted correctly in %temp%\imgtmp when you try to add drivers?

               

              Frank

              • 4. Re: LDMS 9.5 SP2 and DISM
                RobLent Specialist

                Hi Frank,

                 

                To be honest you have lost me there.

                 

                I mount the boot.wim in a foler I created under teh C drive.  (C:\Mount\BootWIM)

                 

                I can browse the mounted WIM no problem and edit files OK.

                 

                Does DISM mount the WIM elsewhere too?

                 

                Rob

                • 5. Re: LDMS 9.5 SP2 and DISM
                  Apprentice

                  Based on your DISM log, the image is failing to load from the temp location of C:\Scratch\... Can you verify that this directory exists on your computer and that you have write access to the directory?

                   

                  You might also consider using the "/ScratchDir:" parameter for DISM to change the temporary location of your mounted image.

                   

                  A very similar problem is laid out in Microsoft's TechNet forum here: http://social.technet.microsoft.com/Forums/en-US/7e7a08cb-0981-4b29-9280-b03ba13de66c/unable-to-install-drivers-into-windows-7-aik-image?forum=w7itproinstall

                  • 6. Re: LDMS 9.5 SP2 and DISM
                    RobLent Specialist

                    Hi Kevin,

                     

                    Thanks for the reply.

                     

                    The C:\Scratch DIR was created by me as the original error read the same but from a user temp directory.

                     

                    I used the /ScratchDIR command to point it to the new C:\Scratch folder I created.  I made sure that all the permissions are set on that DIR as per the MS article relating to DISM commands.

                     

                    I still cannot get this to work and the only thing I have changed is install SP2.

                    • 7. Re: LDMS 9.5 SP2 and DISM
                      Apprentice

                      Are you able to modify the boot.wim file on a different system (one that doesn't have LANDesk 9.5 SP2 installed on it)?

                       

                      SP2 uses WinPE 5.0, so you may need to update to WADK to use DISM properly. I am in the process of testing this in my environment as well.

                      • 8. Re: LDMS 9.5 SP2 and DISM
                        RobLent Specialist

                        I'll give that a go Kevin.

                         

                        Will need to setup a system in my lab to try.

                         

                        I used my LDMS lab environemtn to test SP2 but obviously did not test enough!!  :-)