8 Replies Latest reply on Apr 27, 2015 8:19 PM by AndersonYang

    Issue Capturing image in provisioning.

    wrmeadows Rookie

      My capture image provisioning task keeps failing.  For some reason it is not getting the credentials from the preferred server.  Here is the log of MaptoPrefferedHandler


      2014-04-02 17:40:07(1236-1232) maptopreferredhandler.exe:******Mapping to: \\tech\landesk\Images

      2014-04-02 17:40:07(1236-1232) maptopreferredhandler.exe:Drive letter = f

      2014-04-02 17:40:07(1236-1232) maptopreferredhandler.exe:Mode - Require Direct, no preferred server.

      2014-04-02 17:40:07(1236-1232) maptopreferredhandler.exe:Could not get credentials for preferred server.

      2014-04-02 17:40:07(1236-1232) maptopreferredhandler.exe:End of Map Drive.  Path used: - \\tech\landesk\Images\.

      2014-04-02 17:40:07(928-1296) maptopreferredhandler.exe:******UnMapping Drive

      2014-04-02 17:40:07(928-1296) maptopreferredhandler.exe:Drive letter = f

      2014-04-02 17:40:07(928-1296) maptopreferredhandler.exe:Could not map or unmap drive. Error code: 2250

      2014-04-02 17:40:07(928-1296) maptopreferredhandler.exe:End of UnMap Drive.



      Here is the template:




      Any help would be greatly appreciated,



        • 1. Re: Issue Capturing image in provisioning.
          Frank Wils ITSMMVPGroup

          If you open a command prompt in your Windows PE, can you use the net use command to map f: to the drive specified with account entered in the preferred server configuration?



          • 2. Re: Issue Capturing image in provisioning.
            wrmeadows Rookie

            I think I found what the issue is but not sure why it is happening or how to fix it.   When I look at the preferredservers.dat file in Windows PE it is only showing the core server as a preferred server and not the machine I want to map the image to.  If I map the image to the core server it works fine but not if I try to put the image on the other machine.  I checked the preferredservers.dat file on a couple client machines and both preferred are showing.  Now I just need to find out why the .dat file is only showing the one preferred server on Windows PE.



            • 3. Re: Issue Capturing image in provisioning.

              I am experiencing the same behavior. It looks to me like the handler is trying to map to your specified URL with the credentials that are configured for your preferred server. Apparently, this is by design. So, if you add your preferred server credentials to the resource you are trying to connect to, it should be able to connect. However, I think the problem is actually that the handler cannot FIND the preferred server credentials it is supposed to use. It knows what path to connect to but when it tries to get the credentials it wants to use, it cannot find them.


              My preferredservers.dat file in the WinPE image has both our local preferred server and the core listed. It does not have any credentials stored in it (which I would expect.) I am not sure how the handler retrieves these credentials. Does something need to be added to the WinPE image or is this a Core configuration issue. I cannot capture anything to anywhere with Provisioning. All attempts to capture to the core, to the preferred server, or to another URL resource end with the same messages you quote in the OP.


              Hopefully, someone can answer this question.  *fingers crossed* 

              • 4. Re: Issue Capturing image in provisioning.

                Have you tried using the FQDN of the preferred server?  Make sure your preferred server entries match the path exactly as they are specified in your capture image action.


                If you're using \\tech.domain.com\landesk\Images in the capture action, make sure your preferred server entry is listed as \\tech.domain.com\landesk\Images

                • 5. Re: Issue Capturing image in provisioning.

                  I think slimowski is right.  Your log indicates that you are not allowing any preferred server functionality:  2014-04-02 17:40:07(1236-1232) maptopreferredhandler.exe:Mode - Require Direct, no preferred server.


                  The result is that you need to have a preferred server that matches your source exactly.  In this case that would appear to be tech.  Do you have a preferred server entry for tech (not tech.whatever.org or anything, just tech)?  If not, you'll either need to add it or you can just allow the tool to use preferred servers and it will find the closest server that has the image file and use it.

                  • 6. Re: Issue Capturing image in provisioning.
                    jsmith Rookie

                    I was having the same or similar issue.


                    Changing the read-only credentials to an account with write permissions fixed my issue. I only need to capture an image once an awhile so I just changed the credentials back once I had my image.


                    Not sure if this is related to your issue or not, but I hope it helps.

                    • 7. Re: Issue Capturing image in provisioning.
                      jaericho Apprentice

                      I had the same error while trying to deploy an image with 9.6 SP1. My images were stored on another machine. I ended up adding a preferred server pointing to the machine where the images were stored.

                      • 8. Re: Issue Capturing image in provisioning.
                        AndersonYang SupportEmployee

                        Can you map the UNC path with below command :

                        net use h: \\sharingcore\path %password% /u:%user%?