1 2 Previous Next 16 Replies Latest reply on Sep 3, 2014 12:00 PM by eric.wagner

    Reports not being emailed

    eric.wagner Apprentice

      I am runing LDMS 9.5 SP2 and I am trying to schedule a report to be emailed to me. I have tested the SMTP settings (all is working with the test email) in the scheduled task but when I run the task or schedule it I never receive any emails. Can anyone speak to this? How do I fix it. I have validated email addresses within the console, I have validated the report works and have validated that the report is being sent to the core.

        • 1. Re: Reports not being emailed
          Rookie

          Sounds like you've validated everything.  What email system are you using? Perhaps they block emails with certain kinds of attachments? If you're sending it as xls, try sending it as a csv instead.

          • 2. Re: Reports not being emailed
            eric.wagner Apprentice

            we are using exchange 2008 and i have tried all of the version (file extensions) and it is not coming across.

            • 3. Re: Reports not being emailed
              larfun Apprentice

              Custom Report or Standard Report? Does it require any parameters?

              • 4. Re: Reports not being emailed
                JoeDrwiega SupportEmployee

                Do you mean exchange 2010? You might need to create an Exchange connector if anonymous is not allowed. What do you have checked in the SMTP Configuration section of the Scheduled Task?

                • 5. Re: Reports not being emailed
                  eric.wagner Apprentice

                  It is a standard report with no parameters.

                  • 6. Re: Reports not being emailed
                    eric.wagner Apprentice

                    Yes that is what I ment. I will have to talk with my exchange guy to see what is set up. I believe we allow anonymous. As for the configuration it is set on port 25 and has my exchanger server in the SMTP location nothing more.

                    • 7. Re: Reports not being emailed
                      larfun Apprentice

                      I may be re-stating the obvious but is the name a FQDN or just the hostname?

                      • 8. Re: Reports not being emailed
                        eric.wagner Apprentice

                        It is the FQDN.

                        • 9. Re: Reports not being emailed
                          LANDeskWizrd SSMMVPGroup

                          Do you have a reply e-mail set under "Recipients"? I am having a similar issue and I believe this is happening because I can't set a reply email. Every time I set one it doesn't save. I believe there has to be a reply email in order to send the report.

                          • 10. Re: Reports not being emailed
                            JoeDrwiega SupportEmployee

                            Yes a reply is needed. Not saving sounds like time to put a ticket in.

                            • 11. Re: Reports not being emailed
                              LANDeskWizrd SSMMVPGroup

                              Yeah, that is the issue I am having but I was wondering if the issue is the same for the OP

                              • 12. Re: Reports not being emailed
                                Rookie

                                change it in database (PLEASE remember about backup!). This is not a permanent solution, but till fix is ready... ;-)

                                 

                                1. find task id (this query shows all SMTP configs):

                                SELECT [LD_TASK_IDN]

                                      ,[ReplyEmail]

                                      ,[SendUsing]

                                      ,[Host]

                                      ,[Port]

                                      ,[AuthenticationProtocol]

                                      ,[UserName]

                                      ,[Password]

                                      ,[UseSsl]

                                  FROM [dbo].[LD_TASK_SMTP]

                                 

                                2. use [LD_TASK_IDN] to update table:

                                 

                                update LD_TASK_SMTP

                                set [ReplyEmail] = '<youremail@address.com>'

                                where [LD_TASK_IDN] = <PUT LD_TASK_IDN here>

                                 

                                It can be scheduled on SQL server as a job and launched every hour...

                                 

                                So when You deploy a new report, You need to save it with any reply email (just to create a row in DB) and then edit row in DB. It works for me, hope it will help You as well

                                 

                                P.S.: This was done on LDMS 9.6

                                • 13. Re: Reports not being emailed
                                  mlambert Apprentice

                                  Have you checked the publishreports.exe.log?  See if you see any errors in there when you run an email task.

                                   

                                  We ran into an issue like this and it ended up being a problem that prevented non-admin users from running a specific report and also when we tried to email it.  Worked with LANDesk support and it was a "fix in future", however they didn't set a defect case number for it.

                                  • 14. Re: Reports not being emailed
                                    eric.wagner Apprentice

                                    here is a clip from the logfile

                                    09/02/2014 15:50:02 INFO  7188:1     RollingLog : Core has changed, resetting the core language cache

                                    09/02/2014 15:50:02 INFO  7188:1     RollingLog : Getting core language for Key:CurrentLanguage Language:ENU

                                    09/02/2014 15:50:02 INFO  7188:1     RollingLog : Getting core language for Key:LegacyLanguage Language:ENU

                                    09/02/2014 15:50:06 INFO  7188:2     DataServices.OleDbHelper : CloseConnection(); Dispose()-ed a connection with a handle that was not initialized

                                    09/02/2014 15:50:10 INFO  7188:1     RollingLog : Exception when trying to email report to a user:

                                    09/02/2014 15:50:10 INFO  7188:1     RollingLog : System.Web.HttpException (0x80004005): The transport failed to connect to the server.

                                    ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.InteropServices.COMException: The transport failed to connect to the server.

                                     

                                     

                                       --- End of inner exception stack trace ---

                                       at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)

                                       at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)

                                       at System.Web.Mail.SmtpMail.LateBoundAccessHelper.CallMethod(Object obj, String methodName, Object[] args)

                                       at System.Web.Mail.SmtpMail.LateBoundAccessHelper.CallMethod(Object obj, String methodName, Object[] args)

                                       at System.Web.Mail.SmtpMail.CdoSysHelper.Send(MailMessage message)

                                       at System.Web.Mail.SmtpMail.Send(MailMessage message)

                                       at LANDesk.ManagementSuite.SmtpEmail.Smtp.Send(MailMessage message)

                                       at LANDesk.ReportingServices.Publisher.SmtpHelper.Send(MailMessageData data)

                                       at LANDesk.ReportingServices.Publisher.Publisher.EmailReportToUsers(PublishParameters parameters, ISmtpHelper smtp, List`1 users, IFileHelper fileHelper, DateTime dtTimeStamp)

                                    09/02/2014 15:50:12 INFO  7188:1     RollingLog : Exception when trying to email report to a user:

                                    09/02/2014 15:50:12 INFO  7188:1     RollingLog : System.Web.HttpException (0x80004005): The transport failed to connect to the server.

                                    ---> System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.Runtime.InteropServices.COMException: The transport failed to connect to the server.

                                     

                                     

                                       --- End of inner exception stack trace ---

                                       at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)

                                       at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)

                                       at System.Web.Mail.SmtpMail.LateBoundAccessHelper.CallMethod(Object obj, String methodName, Object[] args)

                                       at System.Web.Mail.SmtpMail.LateBoundAccessHelper.CallMethod(Object obj, String methodName, Object[] args)

                                       at System.Web.Mail.SmtpMail.CdoSysHelper.Send(MailMessage message)

                                       at System.Web.Mail.SmtpMail.Send(MailMessage message)

                                       at LANDesk.ManagementSuite.SmtpEmail.Smtp.Send(MailMessage message)

                                       at LANDesk.ReportingServices.Publisher.SmtpHelper.Send(MailMessageData data)

                                       at LANDesk.ReportingServices.Publisher.Publisher.EmailReportToUsers(PublishParameters parameters, ISmtpHelper smtp, List`1 users, IFileHelper fileHelper, DateTime dtTimeStamp)

                                    1 2 Previous Next