13 Replies Latest reply on Jun 24, 2014 6:29 AM by Ascott860

    Hang after reboot action

    Apprentice

      Hi

       

      We install several software during the provisioning, one software needs a reboot after installation. So we put in the reboot action in the template. When we start the scheduled task from the template with 12 clients, 8 clients do the task successfully. The other four clients hang after the reboot action and do nothing (the provisioning agent do not start after the reboot). There are still a few actions pending, the task is active and after a few hours the task is failed.

       

      Have someone an idea, what the problem is with the reboot or why the provisiong does not start after the reboot?

       

      Thanks

        • 1. Re: Hang after reboot action
          LANDave SupportEmployee

          What version are you on?

           

          I would suggest updating to 9.5 SP2 and the latest BASE component patch.

           

          We fixed a few things with Software Distribution actions in the latest component patch.   It may help.

          • 2. Re: Hang after reboot action
            Apprentice

            I am on LDMS 9.5 SP2, the patch is installed. We tried it again, now just 2 clients hang after reboot. The provisioning agent do not start. It always is the same problem but not the same clients.

            • 3. Re: Hang after reboot action
              LANDave SupportEmployee

              Do you see that an action has failed prior to the reboot if you look at the provisioning history?   If so,  I just duplicated that problem in my lab and have development looking at it.

              • 4. Re: Hang after reboot action
                Apprentice

                Nothing is failed. I put an example in the attachement. I think it has nothing to do with the other action because on other clients it works. It is not replicable why it sometimes hangs after a reboot. You see on the attached screenshot that there are a lot of reboots and it is not always the same reboot action where a client could hang.

                FailedAtLastReboot.png

                • 5. Re: Hang after reboot action
                  masterpetz ITSMMVPGroup

                  Hi,

                   

                  we have a customer with exact the same problem and searching for a root cause for a while together with LANDesk support. Untill now without success. We patched the customer to the newest BASE 2014-0417 patch but its still the same. Sometime the device is provisioned without a problem, sometimes the same device stops at a reboot next time it stops at another reboot. There is no pattern we found when or why this happens.

                  Did you find a solution yet?

                   

                  Thanks and kind regards

                  Christian

                  • 6. Re: Hang after reboot action
                    Apprentice

                    Hi,

                     

                    We could observe the following:

                     

                    We have a provisioning task with three clients and one of the clients is very fast with doing the actions. So when this client finishes all actions of the provisioning task, the status of the task turns to 'Successfull', although the other two clients have not finished. So the other two clients continue with their actions (withouth problems) until they have to do the reboot action. When they boot again into windows, the provisioning agent does not start.

                     

                    Could it be that the clients request the core for the next actions but he response that the task is already successful?

                    • 7. Re: Hang after reboot action
                      masterpetz ITSMMVPGroup

                      Sounds like a plausible explanation. If the customer is installing only one device then it seems to work. That means if you do a task for every single device, this problem shouldn't occur. I will ask our customer to double check it.

                      But it would be nice if there is a solution for this from LANDesk...

                      If you found out more, it would be nice if you can update the post, I will do so too.

                       

                      Regards

                      Christian

                      • 8. Re: Hang after reboot action
                        kesch Specialist

                        Hi,

                         

                        I've opened a case for that problem. The only answer I got, was to install the patch, but we've already installed the latest component patch.

                        I'm waiting right now for an answer from LANDesk.

                         

                        Regards,

                        Kevin

                        • 9. Re: Hang after reboot action
                          Jack.rotherham Specialist

                          I've not had the 0417 patch on when attempting this however I have seen simialr behaviour on a couple of customer servers whereby if there is a failure in an action prior to reboot and the action is set to continue on failure, the reboot action will fail with the error of the failing action.

                           

                          This mainly affects software distribution however it also affects the HII action within Windows that installs packages based upon model information. The only "workaround" I have for this at the moment is to have all packages involved in provisioning to have a return code template that sets and result code to successful. I'm still awaiting a viable solution from LANDesk in terms of patch.

                           

                          I've also seen a similar thing at a single customers site where if a computer is already a member of the domain and is being re-provisioned, the device fails to see the core server after it has joined the domain again and rebooted. The fix for this was to delete the computer out of active directory prior to re-provisioning.

                          • 10. Re: Hang after reboot action
                            kesch Specialist

                            The Problem is that is no error message. The client hangs without any reason after a reboot and the task is marked as done. So you can't really work with a workaround. The only thing you can do, is to create one task per client. But who wants to do that, when you have to provision more than 10 clients...

                            • 11. Re: Hang after reboot action
                              Apprentice

                              Replace your 'reboot actions' with 'execute file actions' --> shutdown.exe -r -t 5 This will work..

                              • 12. Re: Hang after reboot action
                                Apprentice

                                We are seeing this problem also, I have recently installed the CP patch 042014 but 1 in 3 systems will still fail from the reboot task at times. The current system I am working on is failing at the reboot task only after the agent is installed. However the reboot tasks before the agent is installed are working ok. I replaced the reboot task with what elkum suggested and used execute file. This is sorta like the patch system task that does not work in 9.5 however if you use execute file and use vulscan /repairgroup then it works. I will let my system build over night and add my name to the fix request with support tomorrow if this is still not working.

                                 

                                EDIT: Provisioning template was a success after using execute command for reboot step after the agent is installed.

                                 

                                Update: Some of my scheduled provisioning tasks still do this, it seemed to good to be true the first time it worked. I have a different agent for our laptops and it still hangs on the reboot command.

                                • 13. Re: Hang after reboot action
                                  Specialist

                                  So I am sure I will jinx myself here as this just worked for me, but did you update your agent after you installed the patches?

                                   

                                  Had the same issues until I updated my agent, now it seems to pick right up after reboots again.