4 Replies Latest reply on May 27, 2014 10:34 AM by NewEraLD

    Not Joining Domain

    Rookie

      Hoping someone could help fix this. I've created a new image and did changes, updates, etc while in audit mode. I then sysprep it with oobe and generalize. Image deploys fine but when it finishes I'm always at the oobe screen, landesk client doesn't install or finish correcty. Should I be sysprep differently or am I missing something else in general?

       

      Unattend.xml Attached.

        • 1. Re: Not Joining Domain
          Alex.Richardson SSMMVPGroup

          Normally this happens if Windows doesnt find your unattend.xml. If you injected your unattend to the c drive but your c drive isnt assigned correctly then you can experience this. 

           

          Can you post a screenshot of your template actions? Are you using LANDesk imaging or ImageX?

           

          This discussion might shed some light too. http://community.landesk.com/support/message/92064#92064

          • 2. Re: Not Joining Domain
            Rookie

            I'm currently using ImageX.

             

            [VALUES]

            Task=8

            ScriptName=XXXXXXXXX_Win7_x64

            ScriptDescription=XXXXXXXXX_Win7_x64

            MCast=0

            FallBackNIC=

            UseFallBackNIC=FALSE

            ImageUserName=username

            ImageDomain=password

            ImagePassword=10746D9D29E7FE5D5E72B0C3A77

            ImageToolType=11

            ImageUNC=\\XXXXXXXXX\Images\Win7_64\Image_1\LD643150931D74.TBI

            ToolUNC=\\XXXXXXXXX\ldmain\osd\imagew 2\imagew.exe

            Partition=2

            ImageToolCmd=h:\osd\IMAGEW~1\imagew.exe /r /o /d:0 /f:"""i:\Win7_64\Image_1\LD6431~1.TBI""" /rb:0

            ImageToolCmdsFile=\\XXXXXXXXX\LDMAIN\LANDESK\FILES\BUF_Win7_x64.txt

            IsSysPrepImage=1

            IsVistaSysPrep=1

            UseExistingSysPrep=0

            ExistingSysPrepFile=

            SysPrepFile=\\XXXXXXXXX\LDMAIN\LANDESK\FILES\BUF_Win7_x64.xml

            RemoteSysPrepCopyPath=c:\unattend.xml

            SysPrepTargetedType=8

            UseInventoryName=1

            ComputerNameTemplate=XXXXXXXXX-nnnnn

            ComputerNameStartNumber=0

            ClientInstallDomain=domain

            ClientInstallUsername=username

            ClientInstallPassword=10746D9D29E7FE5D5E72B0C3A77

            ClientInstallUNC=\\XXXXXXXXX\ldlogon

            ConfigProcessors=0

            ImageHWType=0

            ImageOSType=0

            ImageProcessorType=0

            RemoteProcessorPath=%windir%\inf\hal.inf

            ConfigAdvancedMCast=0

            UseWOL=FALSE

            WOLSeconds=120

            DiscoveryType=0

            MaxTMCThreads=5

            MinTMCSleep=1

            MaxTMCSleep=200

            BANDWIDTH_WAN=100

            BANDWIDTH_LAN=100

            SubrepTTL=14

            TargetTTL=2

            [OWNER]

            GUID=2a5cd3bc-2218-4643-a8a0-bca439b5fed2

            OSDPLUG=TRUE

            DESCRIPTION=XXXXXXXXX_Win7_x64

            NAME=XXXXXXXXX_Win7_x64

            TYPE=WinPE

            [JOBPARAM]

            ABORT_ON_CMD_FAILURE=1

            TASK_COMPLETION_ENABLED=FALSE

            AUTOCOMPUTERNAME=BUF-nnnnn

            AUTOCOMPUTERNAMESTARTNUMBER=0

            [MACHINES]

            REMEXEC0=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/bootfile.exe" /disableclientqueue

            REMEXEC1=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr16.dll" /disableclientqueue

            REMEXEC2=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr32.dll" /disableclientqueue

            REMEXEC3=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/lddefrag.exe" /disableclientqueue

            REMEXEC4=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cicfgmgr.vxd" /disableclientqueue

            REMEXEC5=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cindis.vxd" /disableclientqueue

            REMEXEC6=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/copyfile.exe" /disableclientqueue

            REMEXEC7=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tokreplw.exe" /disableclientqueue

            REMEXEC8=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/boot.img" /disableclientqueue

            REMEXEC9=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ChangeBCD.exe" /disableclientqueue

            REMEXEC10=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="%LDMS_CLIENT_DIR%\BCD" /p="http://%CUSTJOBHOSTIP%/landesk/vboot/BCD.dat" /disableclientqueue

            REMEXEC11=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/files/bcdedit.exe" /disableclientqueue

            REMEXEC12=<qt/>%LDMS_CLIENT_DIR%\ChangeBCD<qt/> <qt/>%LDMS_CLIENT_DIR%\bcdedit.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\BCD<qt/>

            REMEXEC13=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="C:\boot.wim" /p="http://%CUSTJOBHOSTIP%/landesk/vboot/boot.wim" /disableclientqueue

            REMEXEC14=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\boot.img<qt/> <qt/>%LDMS_CLIENT_DIR%\BCD<qt/> \boot\BCD

            REMEXEC15=<qt/>%LDMS_CLIENT_DIR%\lddefrag.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\boot.img<qt/>, STATUS

            REMEXEC16=<qt/>%LDMS_CLIENT_DIR%\bootfile.exe<qt/> %LDMS_CLIENT_DIR%\boot.img /keep /bootunsafe, ASYNC

            BEGINWINPE=TRUE

            REMPING17=WINPE, TIMEOUT=1800

            REMEXEC18=diskpart /s X:\LDClient\rmvol.txt

            REMEXEC19=ldrun drvmap.exe domain\username10746D9D29E7FE5D5E72B0C3A77 I: """\\XXXXXXXXX\Images""", STATUS FACILITY=3513

            REMEXEC20=ldrun drvmap.exe domain\username 10746D9D29E7FE5D5E72B0C3A77 H: """\\XXXXXXXXX\ldmain""", STATUS FACILITY=3513

            REMEXEC21=ldrun sdclient /f /o /dest="X:\LDClient\LDPathExist.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/LDPathExist.exe" /disableclientqueue, STATUS

            REMEXEC22=ldrun LDPathExist.exe """I:\Win7_64\Image_1\LD643150931D74.TBI""", STATUS

            REMEXEC23=ldrun LDPathExist.exe """H:\osd\imagew 2\imagew.exe""", STATUS

            REMEXEC24=diskpart /s X:\LDClient\WIPECLEANDISK0.TXT

            REMEXEC25=ldrun h:\osd\IMAGEW~1\imagew.exe /r /o /d:0 /f:"""i:\Win7_64\Image_1\LD6431~1.TBI""" /rb:0

            REMEXEC26=ldrun sdclient /f /o /dest="X:\LDClient\diskinfo.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/diskinfo.exe" /disableclientqueue, STATUS

            REMEXEC27=ldrun sdclient /f /o /dest="X:\LDClient\assvol2.txt" /p="http://%CUSTJOBHOSTIP%/landesk/files/assvol.txt" /disableclientqueue, STATUS

            REMEXEC28=ldrun sdclient.exe /f /o /dest="x:\ldclient\RMVOLLETTER.TXT" /p="http://%CUSTJOBHOSTIP%/landesk/files/RMVOLLETTER.TXT" /disableclientqueue

            REMEXEC29=ldrun tokreplw X:\LDClient\assvol2.txt partition=2

            REMEXEC30=diskpart /s X:\LDClient\RMVOLLETTER.TXT

            REMEXEC31=diskpart /s X:\LDClient\assvol2.txt

            REMEXEC32=ldrun sdclient.exe /f /o /dest="x:\ldclient\fixvista.bat" /p="http://%CUSTJOBHOSTIP%/landesk/files/FixVista.bat" /disableclientqueue

            REMEXEC33=ldrun sdclient.exe /f /o /dest="x:\ldclient\fixntfs.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/fixntfs.exe" /disableclientqueue

            REMEXEC34=ldrun sdclient.exe /f /o /dest="x:\ldclient\bcdedit.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/bcdedit.exe" /disableclientqueue

            REMEXEC35=ldrun sdclient.exe /f /o /dest="x:\cba8\FixWindows.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/FixWindows.exe" /disableclientqueue

            REMEXEC36=ldrun x:\cba8\FixWindows.exe 2

            REMEXEC37=ldrun sdclient /f /o /dest="C:\unattend.xml" /p="http://%CUSTJOBHOSTIP%/landesk/files/BUF_Win7_x64.xml" /disableclientqueue, STATUS

            REMEXEC38=ldrun sdclient /f /o /dest="C:\ldsleep.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/ldsleep.exe" /disableclientqueue, STATUS

            REMEXEC39=ldrun tokreplw C:\unattend.xml COMPUTERNAME=%Computer - Device Name%

            REMEXEC40=cmd /c copy /y X:\LDClient\guid.pds C:\LDISCAN.CFG

            REMEXEC41=ldrun tokreplw C:\LDISCAN.CFG DEVICEID=%Computer - Device ID%

            REMEXEC42=ldrun tokreplw C:\LDISCAN.CFG IMAGEPATH=\\XXXXXXXXX\Images\Win7_64\Image_1\LD643150931D74.TBI

            REMEXEC43=sdclient.exe /f /o /dest="x:\ldclient\FixUnattend.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/FixUnattend.exe" /attemptpref /disableclientqueue

            REMEXEC44=ldrun x:\ldclient\FixUnattend.exe

            REMEXEC45=ldrun diskinfo extend_last_partition

            REMEXEC46=ldrun sdclient.exe /f /o /dest="x:\ldclient\HIIClient.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/HIIClient.exe" /disableclientqueue

            REMEXEC47=ldrun /qt HIIClient

            REMEXEC48=ldrun reboot, timeout=2

            • 3. Re: Not Joining Domain
              Alex.Richardson SSMMVPGroup

              Your task shows you are running imagew. REMEXEC25=ldrun h:\osd\IMAGEW~1\imagew.exe /r /o /d:0 /f:"""i:\Win7_64\Image_1\LD6431~1.TBI""" /rb:0

               

              If you boot back into WinPE I would check the drive letters assigned as you may find c: was assigned to the system partition for Windows 7 rather than the actual c drive. If this is the case this means you unattend was injected to the wrong place.

               

              Fixwindows is meant to resolve this but as per the link I sent depending on your LDMS version this can be a problem with newer versions of LDMS / WinPE

               

              What version and SP of LDMS are you on?

              • 4. Re: Not Joining Domain
                Rookie

                I'm still having some issues with this, basically computers are imaging fine but no drivers/landesk client installation or domain joining is occuring. I'm currently on LD 9.5, no service packs.