1 2 Previous Next 16 Replies Latest reply on Jul 2, 2014 2:29 PM by rictersmith

    PXE Representative Deployment - Reinstall Fails

    rictersmith Specialist

      Using LD 9.5 SP2 we are still running into an issue where if we use the PXE Representative Deployment task the install works fine.

      After modifying the boot image, the instructions are to redeploy the PXEs.


      If we re-run the deployment task, the only thing that appears to happen is an uninstallation of the PXE rep and services.


      We then have to run it a second time and the services all re-appear.


      Is this a known issue? This is the same problems we saw in LD 9.0 SP2.


      We currently work around the problem by not following the instructions to re-deploy and simply use robocopy to copy the files out to the PXE reps.

        • 1. Re: PXE Representative Deployment - Reinstall Fails
          Tanner Lindsay SupportEmployee

          This isn't an issue that I'm aware of. You can review the Custom Job log for more details and if that doesn't help clear it up, I'd open a case.

          • 2. Re: PXE Representative Deployment - Reinstall Fails
            rictersmith Specialist

            Thanks Tanner, I was actually able to reproduce this problem in the LANDesk Boot Camp and spoke with some of the LANDesk guys about it there as well. I spun up another Win 7 VM and made it a PXE rep. When I did an update, I replicated the problem. That is when I decided to open this question since I reproduced it in a clean LANDesk Boot Camp Environment.

            • 3. Re: PXE Representative Deployment - Reinstall Fails
              marcel Specialist

              i could reproduce this in our environment. it seems that osdprep.msi runs into an unknow success error.

              • 4. Re: PXE Representative Deployment - Reinstall Fails
                jvhooijdonk Apprentice

                The same over here, I had this issue at almost all sites that I have upgraded to 9.5 SP2. Running the OSDREP.MSI my hand did install the PXE bye the way, this is not an option in a large environment.

                • 5. Re: PXE Representative Deployment - Reinstall Fails
                  marcel Specialist

                  does anyone has opened a support case?

                  • 6. Re: PXE Representative Deployment - Reinstall Fails
                    Peter Massa Expert



                    Have you tried using the "Update WinPE Image on PXE Representative" task?  I do not believe a full reinstall of the PXE rep using "PXE Representative Deployment" is necessary.


                    It is a managed script:

                    ;  LANDesk(R) Management Suite Custom Script
                    ;  This script will copy the boot.wim from the core to PXE reps to update
                    ;  the WinPE image. It should only be run on existing PXE reps and can update
                    ;  them to include new drivers or changes to the WinPE image

                    REMCOPY1=%DTMDIR%\landesk\vboot\boot.wim, %LDMS_CLIENT_DIR%\..\PXE\System\images\boot\boot.wim, TOREMOTE



                    Point it at your PXE reps and it should update their .wim file.


                    Let me know if this does not work,


                    • 7. Re: PXE Representative Deployment - Reinstall Fails
                      rictersmith Specialist

                      Marcel - I do not have an official case opened. Every time I have tried or discussed it, no one at LANDesk seems able to reproduce the problem.

                      We currently get around it by using robocopy to do similar to what Peter posted.


                      The correct documented process from LANDesk is to re-deploy the agent.... anything else would be considered a "work around".


                      Peter - Did you get the script from this location? I have not checked my core, but I do not believe there was an update script in the default installation. Updating the WinPE image on PXE representatives



                      I've just pinged our TAM to open an official support case.

                      • 8. Re: PXE Representative Deployment - Reinstall Fails
                        Peter Massa Expert



                        The script was migrated from our 8.8 instance, tweaked for 9, where it was added during installation.


                        What functionality do you feel you are losing by using the above script rather than doing a full reinstall of the PXE rep?




                        • 9. Re: PXE Representative Deployment - Reinstall Fails
                          rictersmith Specialist

                          Peter - We don't believe any functionality itself will be lost. As I said, we are using robocopy to do the exact same thing to keep all of our pxe reps up to date. The problem is that both of us are using a 'work around'. Any time we take our employees through the training (LANDesk boot camp) or reference the LANDesk documentation, they are instructed to re-deploy the agent as the process LANDesk intends us to use. This fails to deploy.


                          We are not looking for a work around, we have that and I appreciate your offering up the script. What we are looking for is to have LANDesk fix the proper process they have documented and are instructing their customers to use, especially now seeing other customers that use the same process are also having the same problems we are. The forum post was to query anyone else having the same problem and validating it's not unique to our environment. Our environment should not break when following LANDesk documented procedures like this.


                          Are you guys using the  script simply to save bandwidth? Or were you guys also having problems with re-deploying the agent?

                          • 10. Re: PXE Representative Deployment - Reinstall Fails
                            Peter Massa Expert



                            That is the process that we teach our technicians to save bandwidth - however in previous use I believe it has worked for us in the way you are describing where it uninstalls then re-installs without issue.


                            This is our deployment script - maybe it would help to compare to yours and check for differences:


                            ;  This file was generated by Desktop Manager
                            REMEXEC0=MsiExec.exe /q /X{F238CE99-6614-4072-9D20-1D2FA7ED951A}

                            ;{These files installed by OSDRep.msi in the older version
                            REMCOPY1=%DTMDIR%\landesk\files\bootmenu.1, %LDMS_CLIENT_DIR%\bootmenu.1, TOREMOTE
                            REMCOPY2=%DTMDIR%\landesk\files\bstrap.0, %LDMS_CLIENT_DIR%\bstrap.0, TOREMOTE
                            REMCOPY3=%DTMDIR%\landesk\files\dosundi.1, %LDMS_CLIENT_DIR%\dosundi.1, TOREMOTE
                            REMCOPY4=%DTMDIR%\landesk\vboot\bootmenu.0, %LDMS_CLIENT_DIR%\bootmenu.0, TOREMOTE
                            REMCOPY5=%DTMDIR%\landesk\vboot\dosundi.0, %LDMS_CLIENT_DIR%\dosundi.0, TOREMOTE

                            ;{These files are needed by winpe2.0 and later
                            REMCOPY6=%DTMDIR%\landesk\vboot\bcd.dat, %LDMS_CLIENT_DIR%\bcd, TOREMOTE
                            REMCOPY7=%DTMDIR%\landesk\vboot\bcd_x64.dat, %LDMS_CLIENT_DIR%\bcd_x64, TOREMOTE
                            REMCOPY8=%DTMDIR%\landesk\vboot\bcd_ia32.dat, %LDMS_CLIENT_DIR%\bcd_ia32, TOREMOTE
                            REMCOPY9=%DTMDIR%\landesk\vboot\boot.sdi, %LDMS_CLIENT_DIR%\boot.sdi, TOREMOTE
                            REMCOPY10=%DTMDIR%\landesk\vboot\boot.wim, %LDMS_CLIENT_DIR%\boot.wim, TOREMOTE
                            REMCOPY11=%DTMDIR%\landesk\vboot\boot_x64.wim, %LDMS_CLIENT_DIR%\boot_x64.wim, TOREMOTE
                            REMCOPY12=%DTMDIR%\landesk\vboot\bootx64.efi, %LDMS_CLIENT_DIR%\bootx64.0, TOREMOTE
                            REMCOPY13=%DTMDIR%\landesk\vboot\bootia32.efi, %LDMS_CLIENT_DIR%\bootia32.0, TOREMOTE
                            REMCOPY14=%DTMDIR%\landesk\vboot\bootmgr.exe, %LDMS_CLIENT_DIR%\bootmgr.exe, TOREMOTE
                            REMCOPY15=%DTMDIR%\landesk\vboot\pxeboot.0, %LDMS_CLIENT_DIR%\startrom.0, TOREMOTE

                            REMEXEC16=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /p="http://%CUSTJOBHOSTIP%/landesk/files/osdrep.msi" /msi /N /An /Ac /g="{F238CE99-6614-4072-9D20-1D2FA7ED951A}" /disableclientqueue
                            REMEXEC17=<qt/>%LDMS_CLIENT_DIR%\LDISCN32.EXE<qt/> /NTT=%CUSTJOBHOSTIP%:5007 /S="%CUSTJOBHOSTIP%" /F /SYNC /NOUI

                            SETSTATUS=1240, ERR



                            I would suggest reviewing a target client after attempting to run your script and see at which point it fails.

                            1. Does it error when you manually run the uninstall command from line 0, possibly its hanging the script and it never makes it to the install portion?

                            2. Do any of the file copies fail to make it over?

                            3. Does it reach line 16 where it does the reinstall?

                            4. Does line 16 fail when you manually run through the steps above?




                            • 11. Re: PXE Representative Deployment - Reinstall Fails
                              Peter Massa Expert

                              I will add onto that and say that if you look at the way it is installing - you will see that there is really no reason to ever uninstall and reinstall the actual PXE rep services unless you have applied a core patch that affects PXE services. If all you have done is alter your WinPE/add drivers then all that needs to change is the WinPE/boot.wim.  All that LANDesk does is copy the files over - so the update script above is best practice and uses their commands to do it - again it is not a work around and I believe is documented back in the 8.8 manuals.


                              I would instruct your technicians to use the update command rather than a reinstall if you are unable to resolve the problem using my steps from above or open a ticket with LANDesk support.


                              As for "What we are looking for is to have LANDesk fix the proper process they have documented and are instructing their customers to use" - very noble but my guess is that you will not get LANDesk to change their product, if anything they might update their documentation to reflect using the update script instead - but at least you can get your technicians to work smartly and effectively.


                              Probably not what you were hoping to hear - but it is the correct option.



                              • 12. Re: PXE Representative Deployment - Reinstall Fails
                                rictersmith Specialist



                                I'd be more than happy if they updated their documentation and training to use the process that Tanner outlined and posted. No sense in spending thousands of dollars in sending our technicians to training, only to then tell them don't use the documented procedures, use this other forum posted suggestion. We've been using LANDesk for several years, long before version 8. We duplicated this same problem in version 8.x and reported it then.


                                The documented procedure is here: http://help.landesk.com/Topic/Index/ENU/LDMS/9.5/Content/Windows/osd_t_update_pxe_representative.htm also page 117 of the LANDesk training manual that all paid LANDesk training uses and the trainers would walk you through is the documented process in this link.


                                Sorry, but we are both still using a documented work around, only documented by Tanner and other TAMs or other customers. The documentation and LANDesk training for version 8 is also the same set of instructions. The intended process for updating PXE reps is to re-deploy the agents.


                                Again, we've used this documented work around for years because we were told that the failures were mainly due to our environment or setup. Having replicated this in LANDesk's own boot camp, that statement no longer holds true and we'd be happy to see either one of two things happen. (1) The installation process as currently documented actually works 100% of the time or (2) All training, training documentation and helpdesk documents indicate that re-installing the agent is known to cause problems and a loss of a PXE rep and its services, DO NOT USE IT, but instead use script X as provided by LANDesk.

                                • 13. Re: PXE Representative Deployment - Reinstall Fails
                                  Peter Massa Expert



                                  1. Did you follow the steps above that I had mentioned?  If you believe it is broken in your environment - open a case with support or I can try to assist you here.

                                  - I just spent 45 minutes doing testing and have determined that the /disableclientqueue flag is preventing the services from reinstalling whenever a vulscan is running or sdclient is already installing another package.  If vulscan is not running or another application is not installing - then it works 100% of the time.  I performed 20 reinstallations.

                                  - Please test this - and if you want the task to queue - just remove that flag and it should install the service at the next available point in time.


                                  2. If you think the documentation should be changed - please submit an ER.


                                  More information on client queuing:

                                  Use the Client queue options page to configure how you want simultaneous distribution jobs handled.

                                  The client queue allows for multiple simultaneous job to be processed by each client in the order they are received, with priority given to push-type jobs.

                                  Jobs are still processed one at a time, but the queue allows multiple jobs to run, instead of failing any incoming jobs if a job is already active.

                                  • Disable client queuing for this package: Disables queuing for the current package. If other jobs are active on a device and that device gets this job, the job will fail.


                                  Hope this resolves your issue,


                                  • 14. Re: PXE Representative Deployment - Reinstall Fails
                                    rictersmith Specialist

                                    Peter - Good find on the /disableclietqueue flag. Our TAM is already in the process of trying to reproduce the problems and cases had already been opened. I'll pass this extra information along for him to try.

                                    I'm currently working offsite all this week so I have not be able to do further testing myself.

                                    1 2 Previous Next