3 Replies Latest reply on Jun 19, 2014 10:17 PM by Peter Massa

    Management console shows 9.50.3.1, but the client shows 9.50.3.2. Is this correct?

    Rookie

      When I go to push a .msi package from the console I receive the following error.

       

      "the selected delivery method and or package requires features that are not provided by the agent installed on this target. This can be resolved by upgrading to the latest version."

       

      Thoughts?

        • 1. Re: Management console shows 9.50.3.1, but the client shows 9.50.3.2. Is this correct?
          Peter Massa Expert

          Hello ctd01,

           

          I am unable to answer the title of this post for certain without more information - but my best guess is that maybe an inventory scan hasn't updated the record in the core database yet.

           

          However I can answer the body of the post.

           

          The error you are getting is because the 9.50.3.2 update added new client features for software deployment that the core believes a 9.50.3.1 client would be unable to handle.  The core is only checking its database record to determine this, not actually asking the client for its version number to reduce the number of network calls made. This would eventually correct itself when the inventory record updates correctly.

           

          The proper work around to avoid these errors and have a successful deployment regardless of version mismatches would be to follow these steps:

          1. In your console click Tools -> Distribution -> Delivery methods

          2. Open each of your deployment methods and change the Downgrade options to support older clients.

           

          Downgrade.png

           

          This will then proceed with your deployments and ignore any new features that the client might not support.

           

          Hope this helps,

          Peter

          1 of 1 people found this helpful
          • 2. Re: Management console shows 9.50.3.1, but the client shows 9.50.3.2. Is this correct?
            Rookie

            Sorry I wasn't very specific regarding the version numbers.

             

            When I go to help -> about landesk in the management console that's where I see 9.50.3.1, but when right clicking on the client and selecting status, the version shows up as 9.50.3.2.

            • 3. Re: Management console shows 9.50.3.1, but the client shows 9.50.3.2. Is this correct?
              Peter Massa Expert

              Ah, to answer that half:

              The core version will not match the clients at all times. If a fix was released just for the clients through patch and compliance it would change the client version forward, but the servers would not change unless a patch is provided for it as well. The opposite can occur as well.

               

              In addition to that you will also see Windows clients and Mac clients have different version codes depending on their individual bug fixes.

               

              On the community site here under downloads you can find sustaining core and client updates that you might be missing.

               

              *Update: For your core version, your clients should be 9.50.4.4 - this explains why the downgrade issue was occurring as well. So look for an update under patch and compliance.

               

              Hope this answers your question,

              Peter