7 Replies Latest reply on Dec 15, 2014 12:38 PM by Tracy

    Create disconnected template error in 9.6

    rdittman Apprentice

      Attempting to create a disconnected template in 9.6.  and I get an error when copying image files.

       

      If I create a test template without an image file the process completes successfully.

      I am able to manually copy the image file after the process has formatted the USB drive and failed.

      The image (.TBI) file is 3.7 GB - I am using an 8GB USB drive.

       

      Any ideas?

       

       

        • 1. Re: Create disconnected template error in 9.6
          Tracy Expert

          I ran into this as well, but it seems to have a few different causes.

           

          Try this (Assuming you are on a remote console)

          1. Enable degbug logging - change log\provisioning\loglevel.ini to DEBUG (if the files does not exist on your remote console, copy it from the core)

          2. Creae a file called coreservername.txt in the managementsuite directory on your remote console.  Then add the name of your core server in that file

           

          -Tracy

          1 of 1 people found this helpful
          • 2. Re: Create disconnected template error in 9.6
            rdittman Apprentice

            Thanks Tracy.

             

            Adding corename.txt got me further. I thought I was home free but then it failed at copying the agent. I tried again to make sure and it failed at the same place. Takes about 25 minutes to get to this spot, not sure if that is normal.

             

            • 3. Re: Create disconnected template error in 9.6
              Tracy Expert

              Do you have your agent set to use a self contained agent package that resides on a share that has preferred server set up (for credentials)?

               

              Also, keep in mind that"disconnected" means that it won't get any info from the core so you can't use variables like %LDHostname% in your unattend. You will get a nice sysprep error and find that it added "Computer" . " Device Name" as the computername in the unattend.xml.

               

              I know your image was < 4GB, but I will mention this in case someone else runs into the issue. To maintain UEFI compatibility, disconnected provisioning media is formatted FAT32, so you will need to capture your images and spanned if they are over 4GB, or you will get an image copy failure (much like the one in the OP)

               

              -Tracy

              • 4. Re: Create disconnected template error in 9.6
                rdittman Apprentice

                Thanks for all your help Tracy. With your assistance this is what ended up fixing it for me:

                1. Adding the corename.txt to the Management Suite directory on the remote console machine

                2. Checking/Selecting the self contained agent in the template

                 

                On a side note the finished USB drive seems a bit dangerous - I connected to a test machine, rebooted and it reimaged the PC without any prompts/pause.

                • 5. Re: Create disconnected template error in 9.6
                  Tracy Expert

                  rdittman wrote:

                   

                  On a side note the finished USB drive seems a bit dangerous - I connected to a test machine, rebooted and it reimaged the PC without any prompts/pause.

                   

                  I noticed the same thing. I was going to put a promp/confirmation somewhere in the startup to prevent "accidents". I gave that same feedback to the developer I was working with so I'm sure it will be addressed in the future.

                   

                  Glad you got it working!

                   

                  -Tracy

                  • 6. Re: Create disconnected template error in 9.6
                    Apprentice

                    Can you please clarify whether you added corename.txt or coreservername.txt along with the correct location?  I have (now) both a corename.txt and a coreservername.txt in my Program Files\management suite folder and just used the host name of my core (XYZ123) and not having any luck.  Also split my image into 3GB spans, but I am trying 2GB now as you reference as does the video.

                     

                    I don't believe this is the case since my DEBUG error is Error Mapping drive, lddwnld returned: 1219  (While trying to map to drive letter F).  However, the http downloads ahead of that all succeeded.

                    • 7. Re: Create disconnected template error in 9.6
                      Tracy Expert

                      rsterling,

                       

                      The coreservername.txt file is only for remote consoles. It was needed so the boot media created on a remote console knew who the core server was (if I remember correctly).

                       

                      Also, you need to have the same "name" in your template that you have setup in your preferred server configuration. e.g. if preferred server setup is server.domain.com and template is calling \\server\path (or the opposite), it will not work.

                       

                      What do the client side provisioning logs say (maptopreferredhandler.log)

                       

                      -Tracy