6 Replies Latest reply on Jun 19, 2015 3:08 AM by miw

    Booting too many machines too fast to pxe results in pxe-e32 tftp open timeout

    ryan.boldt Rookie

      We have pxe booting set as our primary boot order.  We have a preferred server acting as our pxe rep as well.  Pxe booting works perfectly fine when we boot only 1-3 or so machines at a time, or as many machines as we want as long as we boot them slowly, ie several seconds between powering on machines.  However, if you rapidly boot several computers at once, it results in the pxe-e32 tftp open timeout.  We are a school district with computer labs around 30 machines per lab.  If students come in and boot up 30 computers at once, they will all open timeout.  So far I have adjusted the mtftp timeout settings on the pxe rep however that did not resolve the issue.  Any ideas would be greatly appreciated.  Like I said, pxe booting fully works otherwise.  It is only upon rapid booting do we receive timeout issues.

       

      Thanks for the help!

        • 1. Re: Booting too many machines too fast to pxe results in pxe-e32 tftp open timeout
          BigB SupportEmployee

          Ryan, if you do a search on your hard drive for folders with large amounts of files, more than 100,000, you may find that you have a folder with an unhealthy amount of files in it. It was a while back, but due to a bug in 9.5 flat, a folder that stores some temp files with relation to provisioning (I don't recall the folder, and my test core doesn't have any folders in it with much volume). You probably already have the patch but if you did much provisioning when the bug was present, and have not cleaned up the folder, it is possible that you are having the same issue. If you find a folder like this, you will want to clear it out (make sure you don't have anything in there you want). You may not be able to even go into the folder. You will need to use CMD line to delete everything unwanted in the folder.

           

          Also, if you are not scheduling your templates off of a locked template, you will want to change the way you provision. By design, each time you schedule an unlocked template, it will create a new, locked one. If you instead only schedule locked templates, you will not get new templates created. This makes it much easier to manage the templates and follow the provisioning history as well.

           

          Let me know if this doesn't help any, but it sounds like you have something like this that is preventing you from being able to provision more than a few machines at a time.

          • 2. Re: Booting too many machines too fast to pxe results in pxe-e32 tftp open timeout
            ryan.boldt Rookie

            I appreciate the detailed response.  However I am not talking about actually provisioning multiple machines at a time.  We have pxe boot as our first boot order so that if technicians need to choose a provisioning task they can upon boot.  By default we have the machines get a pxe boot ip and then proceed to local boot after 4 seconds.  The timeouts occur if we simply try to boot several machines closely together without any provisioning templates scheduled.  We'd prefer them to get the pxe ip, tftp instructions, and then proceed to local boot if there is no template scheduled.

             

            Thank you so much for your help.

            • 3. Re: Booting too many machines too fast to pxe results in pxe-e32 tftp open timeout
              BigB SupportEmployee

              Ryan, you may have already looked at this doc, but it address your error;

               

              Error: "TFTP Timeout" when attempting to PXE Boot

              • 4. Re: Booting too many machines too fast to pxe results in pxe-e32 tftp open timeout
                ryan.boldt Rookie

                There is no MTU value in the registry for any interface.  Should I add it as a value?

                • 5. Re: Booting too many machines too fast to pxe results in pxe-e32 tftp open timeout
                  BigB SupportEmployee

                  You can. Newer operating systems dynamically detect what MTU (Maximum Transmission Unit) is needed, and sometimes do not have an entry for it. In some environments, the dynamic detection does not work as well as others. Adding an MTU value in will determine what MTU is to be used.

                  • 6. Re: Booting too many machines too fast to pxe results in pxe-e32 tftp open timeout
                    Apprentice

                    We have the exsact same problem, and we are also a school enviroment with 6000+ clients

                     

                    pxe e32 tftp open timeout.

                    can PXE boot the same machine 10 times but in 20% i get TFTP timeout.

                    Ive dug in the network tracing and fount out the LANDESK PXE server is responing late with the DHCP offer then the error occurs i have Tracelogs from Wireshark i can send. I think it is the PxeMtftp.exe application that are to slow at responding 20% of the time.

                    Out server is running WS2008R2 SP1 8GB ram 2Vcpu ( vmware) no load issues