4 Replies Latest reply on Apr 22, 2009 6:53 AM by Dthompkins

    Provisioning fails to complete after scripted install






      I'm running LDMS 8.8 and I'm able to get my XP installation to complete via a provisioning template I have created. I've tried as best as possible to follow the "Best Practices for Provisioning-Unatteded Install" document. Where I'm getting hung up is after the scripted install action completes. The provisioning task seems to end at the OS install even though I have an 'Install agent' and 'join domain' function I'd like to perform in the System configuration portion of the template.



      It appears as if the scripted install has completed and all I'm left with is the welcome screen of XP waiting for me to login. IF I just reboot the computer at this point, the remainded of the provisioning template is executed the next time XP boots up. I can sit there on the welcome screen and watch the hard drive cranking away. If I login I see the provisioning agent performing the install agent action and the join domain is performed as well.



      My question is this: How do I get this system configuration portion of the template to complete without manually touching the client machine for a reboot. I've tried putting a reboot in as the final step of the OS installation to no avail. I've read some of the other posts related to this issue and I saw a recommendation of running a 'configure target os' action in the POST OS installation phase, but the task just comes up as 'failed' in the provisioning history. It never makes it into the WinPE environment; it bypasses the PXE boot to WinPE and boots to Windows, thereby skipping my pre-boot environment Post OS configuration actions.



      Any thoughts on how to get past the needed reboot to allow my provisioning template to complete?



      I've attached my template for visual inspection if anyone cares to take a peek. The attached template is the one that does not have the Post OS installation 'configure target OS' action.