1 2 Previous Next 21 Replies Latest reply on Jun 26, 2008 10:19 AM by ahargreaves

    Problem provisioning (deploying an image) a Dell Optiplex 740

    Apprentice

      Hello Everyone,

       

       

      I am hoping to find an answer to my issue with pushing out an XP

      Pro image to a machine. First a little info: I am using Management Suite 8.7

      with SP5 and new agents on the machines in question. I am using a PXE rep and

      PXE booting the machine being imaged. The machine I am trying to image has been

      wiped completely.The image I am trying to push out was taken from a machine

      with SP3 installed and it has been sysprepped. I am also using the latest

      version of sysprep. I have had no problems capturing the image, which I used

      imagex.exe to do.

       

       

      So here is what I did: I created a provisioning template that

      follows these steps: In the "OS Installation" section of the

      template, 1. Maps a drive to a UNC share that the image is stored; 2. Deploys

      the image using imagex.exe; In the "Post OS Installation" section of

      the template, 3. Injects my sysprep file; 4. Adds a temporary agent to the

      template (with the "Unique ID" checkbox checked); 5. Reboots; In the

      "System Configuration" section of the template, 6. Installs the

      standard LANDesk agent.

       

       

      I am pretty sure that it has something to do with the sysprep

      file I am injecting into the provisioning template. The point at which the

      template fails is Step 4, when it tries to add the temporary agent. The log

      file on the machine being imaged says this:

       

       

      ldProvision.exe:Relpacing variable ldDeviceID = COA-359-35

      *ConfigTargetOSHandler.exe:validate GUID string=COA-359-35 fail will not be

      replacing*

      ConfigTargetOSHandler.exe:Found dir c:\Program Files\LANDesk\Shared Files

      *ConfigTargetOSHandler.exe:Could not write INI file c:\Program

      Files\LANDesk\Shared Files\cbaroot\actions.ini : 3*

      ConfigTargetOSHandler.exe:Could not enable cba8 startup!!!

       

       

      It looks like the "ConfigTargetOSHandler.exe" file is

      failing for some reason. I am not sure where it is trying to start the cba8

      service but I checked on the core and it looks like it is running OK. I even

      rebooted the core just to make sure. And I checked the permissions on the

      "actions.ini" file on my PXE rep and they look OK also. I even opened

      up the Shared folder on the PXE rep to everyone (and turned off the firewall)

      but it still can't be written to. I don't even know what that file does.

       

       

      You will notice that the second line of the log file says that

      it cannot validate the string. To remedy this, I tried to use a Public variable

      called "ldHostName" and put "%ldHostname%" in the

      "computer name" section of my sysprep file. When I did that, I did

      not get the validate GUID error but it still failed right after that. I have

      attached my sysprep file so please let me know if there may be something else

      in that file that is screwing me up.

       

       

      I am also attaching the serviceHost and residentAgent logs from the machine I was trying to image.

       

       

      I hope I didn't forget anything. Sorry for being so long winded

      but I wanted to give as much info as possible. This has been very frustrating

      because I have tried so many different things and I still can't completely push

      out an image...and the thought of manually renaming 70 machines and adding them

      to our domain makes me somewhat perturbed. Please help. Thanks.

       

       

      jeff

        • 1. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
          Apprentice

           

          Couple of quick questions

           

          • Does this machine already exist in the Landesk Database?

          • In your sysprepped image, do you have a folders created for c:\sysprep\i386\$OEM$\ and a cmdlines.txt within that location?

           

           

           

           

          The "ComputerName" part of the sysprep file is easy to get around for troubleshooting. replace %ldhostname% with " * ", that should rule that out.

           

           

          Also, in your CTOS (Configure Target OS) action, try un-checking the "Insert Unique ID" checkbox. This will make Provisioning work with systems that do not already exist in the Landesk Database. I've never had luck with it to be honest, even with systems that are in the database.

           

           

          One last thing, Add a "wait" just after the CTOS action, and give it 900 seconds or so. When you provision next, and it gets to the wait command, open up a new console (Go > New Console> and just do a dir. I want to see how much free space it lists at the end. Its quite possible you're running out of space to lay down the CTOS agent.

           

           

          Thanks

           

           

          1 of 1 people found this helpful
          • 2. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
            Apprentice

             

            hey ahargreaves,

             

             

            thanks for the reply. to answer your questions, yes the machine was in the database already. I imported it via the csvimport tool. and yes the image has an "OEM" folder within the i386 folder. and the cmdlines.txt is there but the only thing is I don't think there is anything in that txt file. What should be there?

             

             

            I had tried unchecking  the uniqueID checkbox and it got farther than it did with the checkbox checked but the provisioning still failed while trying to execute the sysprep file. 

             

             

            How do I get the provisioning to wait? Do i need to add the command to the Prov_Startnet.cmd batch file or do I do it in the template? I could not find where to add a wait command in the template.

             

             

            If it is running out of space, how much should I resize the PE image? Currently there is 20 MB of free space. Should there be more?

             

             

            Thanks again for the help

             

             

            jeff

             

             

            • 3. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
              Apprentice

              Ok lets do this.Keep the CTOS action "Insert Unique ID" unchecked for now.

               

              cmdlines.txt should only need one section within it:

               [COMMANDS] 

               

               

              Modify the sysprep's ComputerName to use " * " as a value, then re-import and re-inject your new sysprep file into your Template.

               

               

               

              To add the Wait

               

               

               

              1. Go into your Post OS Install section and click Add.

              2. Click Yes if you get a message popup (if you use multi template provisioning templates)

              3. Choose the Type: Wait from the pick-list, and give it a name like "wait"

              4. Uncheck the option to stop processing if this action fails

              5. On the next screen, verify that the wait is set to Time and not File

              6. Give it 900 seconds or so. 15 minutes should be plenty.

               

              Now re-provision the system and check the space when you get to the wait. If you left 20 meg of free space, you probably have plenty. The other file that would be helpful to look at & post in this thread will be located on your provisioned system at x:\ldprovision\ldprovision.log

               

              Thanks

              • 4. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                ecoidan Specialist

                 

                Isn't the Optiplex 740 an AMD processor?

                 

                 

                Did you create your sysprep on the Optiplex 740?

                 

                 

                • 5. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                  Apprentice

                   

                  Ok. I kept the "Insert Unique ID" box unchecked and I added a "*" in the computer name part of the sysprep file. I reimported the sysprep file and I re-injected the file into the template. i also checked the image and it does have the %OEM% folder and the cmdlines.txt file in the folder.

                   

                   

                  However, I could not add the wait command to the template. I have attached a screenshot of the options in the drop down menu of the "Post OS installation" part of the template. The wait command is not there. Maybe that is a 8.8 option? We have 8.7.  I could try to add the wait command to the batch file i guess but I would think that the image has enough free space. It has a total of 40 MB of free space now...which seems more than enough.

                   

                   

                  All that being said, it still failed. I have also attached the ldprovision log from the client. I am about to give up on provisioning and go back to Ghost.

                   

                   

                  Thanks so much for the help. Hope we can figure this out.

                   

                   

                  jeff

                   

                   

                  • 6. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                    Apprentice

                     

                    Hi Ecoidan,

                     

                     

                    Yes. It is an AMD processor. And I did run sysprep on that machine. I even downloaded the latest version of Sysprep.

                     

                     

                    Thanks for the reply.

                     

                     

                    jeff

                     

                     

                    • 7. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                      Apprentice

                       

                      Oh dont give up yet! Once you get moved over to a hardware independant, HAL independant, driver independant image you'll wonder why you used Ghost in the first place

                       

                       

                      My apologies for the "wait" reference too, i forget that it wasn't there in 8.7

                       

                       

                       

                       

                       

                      The issue seems to be that CTOS cant understand what value its getting for ldDeviceID. This comes from the "Public Variables" button on the OS Deployment screen (small blue icon). It's usually set to "Computer"."DeviceID". Check that variables list, it might have been changed to point to DeviceName or something.

                       

                       

                      Also, look at the inventory of the computer you imported with csvimport, and see what field it lists for the value "COA-359-35". Thats what the %ldDeviceID% is paired up with.

                       

                       

                      Are you initiating the Provisioning from the client system via the PXE boot menu? If that's the case, you usually dont need to first import the machine into the database (unless you are pushing a provisioning task to the machine). If you are using the Pull method initiating from the client, go ahead and delete the database entry for the client and try it again.

                       

                       

                      We'll get it

                       

                       

                      • 8. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                        Apprentice

                         

                        Yeah I know that provisioning is far superior to Ghost. I just wish it would work.

                         

                         

                        In my public variables, the search value "ldDeviceID" and the replace value is "ldbnf:"Computer"."Device ID". i also created a public variable (in my troubleshooting steps) called "ldHostName" and replaced the value to "ldbnf:"Computer"."Device Name".  But correct me if I am wrong, having that "ldhostname" public variable in there won't matter unless I use it in the sysprep file, correct? If you think that it what is causing the problem, I will take it out.

                         

                         

                        In the inventory for the machine I am imaging there are three fields that have "coa-359-35" in them. Device ID, Device Name, and Display Name. I set it up that way in the csv template so as to make sure the machine would be named properly. I wasn't really sure which one it used.

                         

                         

                        The way I start the provisioning process is I just drag the computer into the template to schedule the task. Then I just right-click and hit "start now" and then turn on the machine. I have never tried initiating the provisioning process from the client....but at this point I will try anything. The only problem with that is I want to do as little as possible on the machine because I have to push out 70 images so I would like to do it all from the core.

                         

                         

                        Thanks for helping me work through this.

                         

                         

                         

                         

                         

                        jeff 

                         

                         

                        • 9. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                          Apprentice

                           

                          OK the issue then is coming from the DeviceID field. If you look in the inventory of another object within Landesk you'll see a GUID listed for the DeviceID, which is how Landesk keeps the records unique blah blah blah

                           

                           

                           

                           

                           

                          So delete the  coa-359-35 system from inventory, re-import it with without filling in the DeviceID field. push your Provisioning task as you already do.

                           

                           

                          You are correct to assume that the variables dont matter unless they are in your sysprep file (or in your provisioning template).

                           

                           

                          Almost there

                           

                           

                          • 10. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                            Apprentice

                             

                            So I should just re-import the machine with only the Mac address? Or should I leave "device name" and "display name" in the csv template and just take out "device ID"?

                             

                             

                             

                             

                             

                            thanks.

                             

                             

                            jeff

                             

                             

                            • 11. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                              Apprentice

                              The latter, import it with the mac, device name, and display name

                              • 12. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                                Apprentice

                                 

                                One more question: Should I recheck the Unique Device Id box again? And if so, should I replace %ldDeviceID% with %ldDeviceName% or something?

                                 

                                 

                                 

                                 

                                 

                                jeff

                                 

                                 

                                • 13. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                                  Apprentice

                                   

                                  Lets get it working first, then start adding things back.

                                   

                                   

                                  Personally, I prefer to leave the "Insert Unique ID" unchecked. If my Helpdesk is re-provisioning a system that is already in the database, they like to see the inventory of the old systems. We come back through with a job to cleanup old systems from the database every 30 days, and remove dupe mac + device names.

                                   

                                   

                                  We'll also be able to add back the line in sysprep.inf ComputerName=%LDHostName% when all is said and done

                                   

                                   

                                  • 14. Re: Problem provisioning (deploying an image) a Dell Optiplex 740
                                    Apprentice

                                     

                                    I unchecked the box and it failed again. The log says: cannot find variable "ldDeviceName". Don't know if this will help but the error code says: "80001701H, file.\SessionData.cpp, line 190"

                                     

                                     

                                    jeff

                                     

                                     

                                    1 2 Previous Next