6 Replies Latest reply on May 20, 2016 8:22 AM by phoffmann

    "Failed to send scan file to server"

    davidg5700 Specialist

      I am testing out the 9.6 Mac agent prior to migration.  I have been able to do an unmanaged device discovery on a Mac (OS 10.9.5 with latest patches) and push the agent to it.  But it does not show up in the device list.

       

      Remote login is enabled, I can ping the core by name and the host name matches the sharing name.  The admin account on the Mac is setup in the scheduler service.  Looking at the Landesk.log file, it gives me "failed to send scan file to server".

       

      Any ideas on how to get this reporting?  I'm sure that I will face others like this when I do the live migration to the new core.

        • 1. Re: "Failed to send scan file to server"
          MarXtar ITSMMVPGroup

          Name resolution issues are generally the problem here. You can try an agent config that has the server name as a FQDN or for testing you could set the server name as the IP address.

           

          Mark McGinn

          MarXtar Ltd/MarXtar Corporation

          http://landeskone.marxtar.co.uk

          LANDESK One Development Partner

           

          The One-Stop Shop for LANDESK Enhancements

          • 2. Re: "Failed to send scan file to server"
            davidg5700 Specialist

            Hi Mark,

             

            Originally, the agent was set to the FQDN.  I tried with just the IP of the core, but same situation.  After it tries to send the scan file to the core, it comes back with "Status from core = HTTP/1.1 503 Service Unavailable"

             

            I have another Mac that I was unable to push the agent to, but after manual install, is giving the same errors in the log.  I have 2 others that I was able to push the client to and have it report without a problem.  Looking over their network configurations, directory bindings, naming etc, I can find no differences in the ones that report and the ones that don't.  It doesn't seem that this would be a core side issue since some report and some don't.

             

            I am concerned about rolling out the new version to existing Mac agents as there is heightened interest in getting LANDESK to do more on the Macs in our organization.

             

            Any thoughts?

             

            Thanks for your help.

            • 3. Re: "Failed to send scan file to server"
              Tom.Phillips Apprentice

              I am having this exact problem with a handful of macs here. 90 or so work fine, but these few do not. I have tried reinstalling the agent to no avail. Has anyone found a solution?

              • 4. Re: "Failed to send scan file to server"
                Northice Expert

                Open Terminal on the Mac and run

                 

                sudo /Library/Application\ Support/LANDesk/bin/ldiscan -s -e

                 

                Pay attention to the last couple of lines in the Terminal window, it’ll give the status as to whether the core server accepted (201) or why it was rejected such as in the 503 example below. 

                 

                May  9 10:09:37  ldscan[21099] <Info>: Sending scan file to server: LDSERVER.ldlab.org

                May  9 10:12:07  ldscan[21099] <Info>: Status from core = HTTP/1.1 503 Service Unavailable

                 

                Typically, the problem is related to DNS.  Make sure you can ping the name of the device listed in the "sending scan file to server."  You can also manually add in the DNS name for the server to the Mac to just test.  Do that by running:

                 

                sudo nano /etc/hosts and add in the name/IP combo and try the manual scan again.


                Anyways, once you know what the http error is, it'll help you better troubleshoot.

                • 5. Re: "Failed to send scan file to server"
                  Tom.Phillips Apprentice

                  Yeah it is a 503 error:

                   

                  May 19 14:40:28  ldiscan[10995] <Info>:   Scanning for Custom Data.

                  May 19 14:40:28  ldiscan[10995] <Info>: Error writing to the baseline file..

                  May 19 14:40:28  ldiscan[10995] <Info>:   Closing scan file

                  May 19 14:40:28  ldiscan[10995] <Info>: Sending scan file to server: ourcorserver

                  May 19 14:40:29  ldiscan[10995] <Info>: Status from core = HTTP/1.1 503 Service Unavailable

                  May 19 14:40:29  ldiscan[10995] <Alert>: Failed to send scan file to server.

                  May 19 14:40:29  ldiscan[10995] <Critical>: Temp file deleted.

                  May 19 14:40:29  ldiscan[10995] <Info>: Scanning done.

                  May 19 14:40:29  ldiscan[10995] <Critical>: Releasing the lock on ldscan.

                   

                  also I noticed this at the top (redacted core name)

                  May 19 14:39:45  ldiscan[10995] <Critical>: Connected to the core server "ourcoreserver".

                  May 19 14:39:45  ldiscan[10995] <Info>: Getting core server preferences.

                  May 19 14:39:46  ldiscan[10995] <Error>: Download of the new LDAppl3.ini file failed.

                   

                  I can ping both the FQDN and the netbios name of the core from the mac just fine.

                  • 6. Re: "Failed to send scan file to server"
                    phoffmann SupportEmployee

                    503 translates into "The Application pool probably ran out of resources & didn't respond". So you may need to up the resources / recycle period (Microsoft's default recycle time is set to 29 hours - which is pretty atrocious in most cases).

                     

                    As a "quick fix" to get you running, running (as admin) "iisreset" on the Core should get IIS back into behaving like you need it to.