6 Replies Latest reply on Nov 14, 2014 7:40 AM by alarson

    Adobe Flash Plugin type won't attempt another install after 1 browser-open install failure.

    alarson Apprentice

      I'm aware that the Adobe Flash Player Plugin updates will fail to install if the Firefox Browser is open.  It does not fail if Chrome is open (not sure why but it's not the point of this discussion).

      I saw this solution to clone the definition to force firefox.exe to quit:  Adobe Flash failing during Security Patching

      However, that's not my immediate concern either.

      Why is it that on all subsequent vulscans, it will detect the need for the flash plugin patch, then not even try to install it even if firefox.exe isn't running.

      Still doesn't work after reboots.  I tried deleting the installer from the local smdcache and it doesn't even try to download the patch locally again, much less try to run it.

      I've looked through the definition and detection rule details but nothing is sticking out.  I am fairly new to LANDesk in the past 6 months, so someone please school me and let me know if this is intended behavior or not.

      In the past i've just resulted to creating a software distribution task for the update and attach a client plugin version query for the targets to try repeatedly. 

      There must be an easier way?!?

      I have example vulscan logs if that is helpful.

      For reference, i'm experiencing this w/ the latest definition:  "FLASHPLAYERPLUGINv15.0.0.223" and it's associated installer "install_flash_player_15.0.0.223.exe"