3 Replies Latest reply on Nov 26, 2014 12:29 PM by jhackett

    New Core, PXE Provisioning not working properly (maybe easy solution?)

    Mark_B Apprentice

      We're doing a side-by-side migration, and we seem to be having issues testing OS deployments. I knew this would be an issue, hence the side-by-side. We were at 9.0 SP3, new one is at 9.6.

       

      I wasn't here when this was originally set up. What I've gathered is that there are certain .inf files that are needed for the pxe provisioning. This is in the OS tab, preboot --> Manage drivers in Windows PE image. I know there's a 32bit and 64bit now instead of the standard boot.wim file.  When I tried to deploy it normally, it timed out before acquiring an IP address.

       

      I tried to copy the boot.wim file from my old core, and that worked, except, as expected, it linked itself to the same old core, but otherwise looked fine. Is there an easy way to just change this part over? There are a lot of custom inf files that would take a while to recreate in the regular one

        • 1. Re: New Core, PXE Provisioning not working properly (maybe easy solution?)
          jhackett SupportEmployee

          Mark B,

          If I'm clear on the issue it is that you are missing drivers in the wim. I would recommend that you take the time to inject the drivers into the new wim. It is a newer PE version that will allow you Image windows 8, 8.1, 2012, 2012R2. It will also allow you to image newer UEFI devices.

          As far as the 32bit vs. 64 wim. The 64 bit wim is only called when imaging a 64 bit UEFI device. If you aren't imaging anything that is 64 bit UEFI you don't need to bother with that wim.

           

          Good luck.

          • 2. Re: New Core, PXE Provisioning not working properly (maybe easy solution?)
            Mark_B Apprentice

            Hi jhackett,

             

            That is indeed helpful. Upon further reflection there aren't too many that are different, and doing a test shows me that this image I'm trying is using the 32bit one, as you said.

             

            I was able to add the necessary NIC driver to the template so tha tit can actually proceed, but now I'm stuck at a new step. Maybe you can assist with this as well?

             

            This was originally a 9.0 template that I went through and made necessary changes to have it point to the newcore. The Pre-OS only has a delete partition task, which succeeded, and then we move to OS Initialization. We do a "Map Drive" which is a shared drive on this new core, it succeeds. Then we do a "Deploy image", but it gets stuck, saying "error:[80001803H] The action failed".

             

            I found a similar case here:

            https://community.landesk.com/support/message/93342#93342

             

            Could there be an issue with the mapping of a drive? it works fine on 9.0. I've attached the two screenshots here as well. The follow one another immediately. (also note I double checked, it is an i, not an L that is listed. Also note there is an images folder inside of the images directory. The paths are sound)

             

            OSD_Issue_1.PNGOSD_Issue_2.PNG

            • 3. Re: New Core, PXE Provisioning not working properly (maybe easy solution?)
              jhackett SupportEmployee

              Mark_B

              In 9.6 we have tried to automate everything more than in past versions. Assuming everything else is setup correctly you should be able to delete the Map drive action.

              The Deploy image action requires a UNC path because it automatically tries to map this drive for you. So you need put in \\YourCore\Images\something_Win7x64_10012014.tbi.

              This should work if you have setup your as a preferred server. If you haven't setup your Core as a preferred server you need to do that.

              Go to Content Replication/Preferred Servers under distribution right click and do new Preferred Server. Fill out only the first page! Configuration.

              Make sure the credentials you enter actually have read/write access to the Core because if you do a capture it will need to write to that share.

               

              If it fails you can add the Map drive back in but you will need to add another map drive to map to the imaging tool. \\YourCore\ldmain\osd\imagew2\imagew.exe

              Then copy the Command-line parameters from deploy image and change it to other.

              Use the mapped locations for the image and tool and paste the command line parameters back in place.

               

              These resolve the issue.

               

              Thanks

               

              Jared