2 Replies Latest reply on Dec 29, 2014 3:02 PM by JoeDrwiega

    Softmon High Reads IOPS after Agent Configuration update deployment

    Rookie

      Hello,

       

      I've deployed yesterday a new landesk Agent Configuration for our VDI environment.

      But immedialty after a strong IO load on our SAN array slow down the desktops.

       

       

      I let time like if it was a forced "inventory scan" but 4 hours after i was worse.

      I found that many VMs were running high IOPS and had a softmon process doing a lot of reads...

      I tried to unset Usage Soft Monitoring and delay the inventory settings to the night but already the same after a new configuration deployment...

      I verified and found our clients were still in 9.5 and as our server is 9.6, i did an client upgrade, from 9.5 to 9.6 with the same desired settings and ... it worked perfectly after an heavy 4 hours operation this night.

      From 04h to 09h00 all seemed perfectly normal.We came back to normal IO rates, like 24 hours before...

       

       

      But after 09h00(until now), since our users reopened their sessions : the same behaviour  : many (not all) VMs are reading intensively with the softmon process.

       

      So, if you can help us to resolve this behaviour it would be great!

       

       

      Regards,

       

       

      Hervé

        • 1. Re: Softmon High Reads IOPS after Agent Configuration update deployment
          JonnyB SupportEmployee

          Can you check the softmon.log on the client?

          • 2. Re: Softmon High Reads IOPS after Agent Configuration update deployment
            JoeDrwiega SupportEmployee

            Do you happen to have real-time inventory set in your agent? If it is enabled try to disable it and uninstall the agent completely and then re-install it. Here is the doc to just remove the service if need be: Re: Removing Softmon Service? Also see if these old issue might help you in your discovery as well: Softmon is causing slowness with our application, but utilization is not high. / Re: Softmon causes application slowness

             

            Here is the script I use to completely remove the agent, you just need to copy the uninstallwinclient.exe from your %LDMSCORE%\ldmain:

            @ECHO OFF

            set CWD=%~d0%~p0

            cls

            C:

            CD %CWD%

             

             

            ECHO Stop LANDESK Services

            net stop "LANDesk Policy Invoker" /yes

            ECHO %ERRORLEVEL%

             

             

            net stop CBA8 /yes

            ECHO %ERRORLEVEL%

             

             

            net stop ISSUSER /yes

            ECHO %ERRORLEVEL%

             

             

            net stop "LANDesk Targeted Multicast" /yes

            ECHO %ERRORLEVEL%

             

             

            ECHO Deleting LANDesk Directory

            IF EXIST C:\ProgramData (

              RMDIR C:\ProgramData\LANDesk /S /Q

              ECHO %ERRORLEVEL%

            ) else (

              RMDIR "C:\Documents and Settings\All Users\Application Data\LANDesk" /S /Q

              ECHO %ERRORLEVEL%

              )

             

             

            ECHO Deleting Registry Common API for LD Agents

            IF EXIST "C:\Program Files (x86)" (

              ECHO Deleting Common APIs for new agents 64bit

              C:\Windows\System32\Reg delete  "HKLM\SOFTWARE\Intel\LANDesk\Common Api" /f

              C:\Windows\System32\Reg delete  "HKLM\SOFTWARE\LANDesk\Common Api" /f

              C:\Windows\System32\Reg delete  "HKLM\SOFTWARE\Wow6432Node\Intel\LANDesk\Common Api" /f

              C:\Windows\System32\Reg delete  "HKLM\SOFTWARE\Wow6432Node\LANDesk\Common Api" /f

              ECHO %ERRORLEVEL%

            ) else (

              ECHO Deleting Common APIs for new agents 32bit

              C:\Windows\System32\Reg delete  "HKLM\SOFTWARE\Intel\LANDesk\Common Api" /f

              C:\Windows\System32\Reg delete  "HKLM\SOFTWARE\LANDesk\Common Api" /f

              ECHO %ERRORLEVEL%

              )

             

             

            ECHO UNInstall Agent

            CD %CWD%

            UninstallWinClient.exe /UI /NOREBOOT /FORCECLEAN

            ECHO %ERRORLEVEL%

             

             

            EXIT /B %ERRORLEVEL%