1 Reply Latest reply on Feb 26, 2015 5:51 AM by Stu McNeill

    HTML Tags being ignored

    jwwtss Apprentice

      I am running Service Desk 7.8 in our dev environment and I am unable to add any html formatting to the emails.  When I try to add additional html to the emails(reminders) as an html email to converts/removes the tags.

       

      Here is an example:

       

       

      "<p style="background-color:gray">"

      -----------------------------------------------------------------------------------

      When replying, please reply above this area.

      -----------------------------------------------------------------------------------

      "</p>"

       

      Incident 16189 has been updated.

      Update: see if this works

       

      The field being used is a HTML SubDataType and have outgoing emails set to send as HTML.

       

      Any help would be appreciated.

        • 1. Re: HTML Tags being ignored
          Stu McNeill Employee

          Hi, this is expected behaviour..

           

          When you enable an attribute for HTML this is not for manually entering HTML code but rather to provide a WYSIWYG editor for the field so you can edit the formatting via the toolbar.  We don't allow you to type the HTML code manually because doing so could open up security vulnerabilities in the web-based interfaces.


          If you want to manually design your outbound email HTML you can turn off HTML on the attribute on Reminder and type HTML into the plain-text editor.  This will get treated as plain text in Service Desk but will be rendered in the resulting emails.