8 Replies Latest reply on Jul 28, 2008 8:50 AM by Fabian Schmidt

    Problems with PolicyUpdate.1.exe

    xefiant Apprentice

       

      Hi members of the community,

       

       

      I have a problem to apply the PolicyUpdate.1.exe Patch on the core server. After applying the MiniRollup 05-08 i wanted to execute PolicyUpdate.1.exe as described:

       

      -


      CR00001688 adds support for Visual Basic scripts to software distribution. The 8.8 update patch includes an automatic update application for the managed nodes: PolicyUpdate.1.exe

       

      This application serves two purposes:

       

       

      - A self-contained and self-extracting package to update the needed portions of the managed node

      - Install the policy update on the core server

       

       

      When installed on the core server, all agents will download and process the new policy update application when policy.sync is run. 

       

       

      To install this package on the core server run the following command line:

      PolicyUpdate.1.exe -setup <url> <ldmainpath>

       

       

      This should be run with the current working directory set to the ldmain directory (so the PolicyUpdate.1.exe application can find the lddwnld library).

       

       

      The <url> should be the http location from which the policy update application is to be downloaded.  For example, if the core name was "mycore" and the update package was placed in ...ldmain\landesk\files the URL would be:

       

       

      "http://mycore/landesk/files/PolicyUpdate.1.exe"

       

       

      The <ldmainpath> is the path to which the ldmain share points (by default c:\Program Files\LANDesk\ManagmentSuite).

       

       

      If this update is not configured on the core and a Windows Script Host package is deployed via policy, the policy invoker will not be able to create an instance of the remote operation object that handles Windows Script Host packages and the policy will fail.

       

      -


       

      If i run PolicyUpdate.1.exe -setup <url> <ldmainpath> nothing happens (with the correct url and ldmainpath). If i don´t use <ldmainpath> then a log and msi file are created but  the msi-file has zero-size and therefore the execution of this file fails. What I am doing wrong?

       

       

       

       

       

       

       

       

        • 1. Re: Problems with PolicyUpdate.1.exe
          Fabian Schmidt Expert

           

          Hello everybody,

           

           

          we have the same Problems with six our customers.

           

           

          Furthermore the policy.sync on the Clients display an error message everytime policy.sync.exe runs.

           

           

          Gretts

          Schmiddi

           

           

          • 2. Re: Problems with PolicyUpdate.1.exe
            Employee

             

            Make a backup of  "web.config" in "%programfiles%\landesk\ManagementSuite\landesk\managementsuite\softwaredistribution\apmservice".

             

             

            Open "web.config" in notepad or any other editor.

             

             

            At the top you see a section refering to PolicyUpdate.1.exe.

             

             

            Delete the entire section.

             

             

            Restart IIS

             

             

            Now, you should be good to go.

             

             

            /Andy

             

             

            • 3. Re: Problems with PolicyUpdate.1.exe
              Employee

              Hello,

               

              if you will update your agents to SP1 re-deploying them or using Patch Manager there is no need to use PolicyUpdate.1.exe.

              Actually I do not know what is causing the issue but I found a solution:

               

              1. on the core browse to \Program Files\LANDesk\ManagementSuite\landesk\managementsuite\softwaredistribution\apmservice.

              2. make a backup copy of the Web.Config file

              3. look for a section like this in the Web.Config file and remove it:

               

               <appSettings> 
              <add key="PerformanceLoggingEnabled" value="false"/> 
              <add key="PolicyUpdateUrl" value="http://swisscards55/ldlogon/policyupdate.1.exe"/> 
              <add key="PolicyUpdateHash" value="ackEbGbiA6hFAv9an8dGmQ=="/> 
              </appSettings>
              

               

              4. Reboot the core server.

               

              Kind regards,

              StockTrader

              • 4. Re: Problems with PolicyUpdate.1.exe
                xefiant Apprentice

                 

                Hi,

                 

                 

                I have already done this but this is only a workaround. In SP1 it is also necessary to apply PolicyUpdate.1.exe. I don't know why LANDesk  integrated it directly in SP1. I hope they will fix it soon

                 

                 

                • 5. Re: Problems with PolicyUpdate.1.exe
                  phoffmann SupportEmployee

                  Just tagging this so that people know we've become aware of this and are looking into this.

                   

                  If I've got updates, I'll try to put them in here.

                   

                  People who are affected/interested in this issue should subscribe themselves to watch this thread.

                   

                  Paul Hoffmann

                  LANDesk EMEA Technical Lead.

                  • 6. Re: Problems with PolicyUpdate.1.exe
                    Employee

                     

                    Hello,

                     

                     

                     

                     

                     

                    I just tried on my test environment 8.8 SP1 to deploy a new client and then try to dstribute a VBS script and I can confirm that this operation worked well without using the PolicyUpdate.1.exe.

                     

                     

                    So seems that if the client is updated using the PolicyUpdate.1.exe is not really needed.

                     

                     

                    Kind regards,

                     

                     

                    StockTrader

                     

                     

                    • 7. Re: Problems with PolicyUpdate.1.exe
                      phoffmann SupportEmployee

                      For any affected - please open a support case referencing CR # 13873 -- that way we can keep track of any affected and give them updates as we get new developments (the issue has been duplicated on our side).

                       

                      Paul Hoffmann

                      LANDesk EMEA Technical Lead.

                      • 8. Re: Problems with PolicyUpdate.1.exe
                        Fabian Schmidt Expert

                         

                        Hey Paul,

                         

                         

                        I already locked a case at support for a few weeks now.

                         

                         

                        Every of our customer applying Rollup 05-08 or SP1 have that issue.

                         

                         

                        Greets

                        Schmiddi