1 Reply Latest reply on Mar 26, 2015 9:35 PM by dmshimself

    Landesk Service Desk 7.4

    Rookie

      Hi,

       

      Currently using Landesk 7.4 as our server, is it possible to use any newer version of the client or do both server and client have to be on the same version? Thanks