8 Replies Latest reply on Apr 22, 2015 2:16 PM by thalamus

    Login problem on fresh installed LDMS 9.6

    Rookie

      Hello.

       

      We want to use management Suite V9.6 so we downloaded trial version. We installed and configured sql 2012 and LDMS9.6 exactly the way it's described on the following Youtube video.

       

      Step by step installation guide for LANDesk Management Suite 9 6 - YouTube

       

      Now we are having trouble to login the management console. When we try to login through management console the following error message appears:

       

      Console Initialization Error:  System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Exception: Error in Utility.GetIntFromRow: column = RIGHTS

      Message: Column 'RIGHTS' does not belong to table .

      StackTrace:    at System.Data.DataRow.GetDataColumn(String columnName)

         at LANDesk.ManagementSuite.UserManagement.Common.Utils.GetIntFromRow(DataRow row, String column)

         at LANDesk.ManagementSuite.MBSDK.MBSDK.GetRights(Boolean clearCache)

       

      When we try to use web console it says invalid user/password but it's not.

       

      Any help?

        • 1. Re: Login problem on fresh installed LDMS 9.6
          Kenyon Expert

          This error is usually seen when the DB connection can not be established but I have a couple other questions;

           

          Have you activated LANDesk?

          What is your databse configuration? Is the DB local to the LANDesk Core?

          Are you logging in as the user you used during the install? If it is a domain user you will need to use domain\user or [email protected]

          • 2. Re: Login problem on fresh installed LDMS 9.6
            Rookie

            Yes, we have activated it.

             

            Yes, database and landesk core run on the same machine.

             

            Yes, we are logging as the same user we used during the setup and it's domain admin.

             

            I saw some suggestions which can be related to this problem on other topics so I have replaced user account landeskcomplus for scheduler service and complus applications landesk and landesk1 with a domain admin account and they are running under that user now but it didnt change anything.

            • 3. Re: Login problem on fresh installed LDMS 9.6
              Kenyon Expert

              Try to connect to the DB using Microsoft's SQL server management studio. The default DB is ulddb. You can double check the DB authentication with the LANDesk Configure Services UI.

              • 4. Re: Login problem on fresh installed LDMS 9.6
                Rookie

                I can connect to the DB using Management Studio with lanadmin (user account I have created in SQL) or domain admin account. I double checked Landesk Conf service settings. It didnt give me any error. Even I tried to enter wrong information to check out and it said cannot connect normally so there is no problem connecting to the DB from conf service ui.

                • 5. Re: Login problem on fresh installed LDMS 9.6
                  Kenyon Expert

                  Interesting. The console you are using is on the LANDesk Core server not on a remote machine correct?

                  • 6. Re: Login problem on fresh installed LDMS 9.6
                    Kenyon Expert

                    also check the :\Program Files\LANDesk\ManagementSuite\log\console.exe.log file to see if it has any details.

                    • 7. Re: Login problem on fresh installed LDMS 9.6
                      Rookie

                      Yes both run on the same server.

                       

                      This is what it says on console log file:

                       

                      04/22/2015 18:25:09 INFO  5764:1     RollingLog : Current language: ENU

                      04/22/2015 18:25:09 INFO  5764:1     RollingLog : Using culture info: en-US

                      04/22/2015 18:25:11 INFO  5764:Main Thread RollingLog : There is an error in XML document (2, 3).

                      04/22/2015 18:25:18 INFO  5764:Main Thread RollingLog : Starting authentication

                      04/22/2015 18:25:19 INFO  5764:Main Thread RollingLog : Resolving rights for user

                      04/22/2015 18:25:23 INFO  5764:Main Thread RollingLog : SoapException Exception: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Exception: Error in Utility.GetIntFromRow: column = RIGHTS

                      Message: Column 'RIGHTS' does not belong to table .

                      StackTrace:    at System.Data.DataRow.GetDataColumn(String columnName)

                         at LANDesk.ManagementSuite.UserManagement.Common.Utils.GetIntFromRow(DataRow row, String column)

                         at LANDesk.ManagementSuite.MBSDK.MBSDK.GetRights(Boolean clearCache)

                         --- End of inner exception stack trace ---

                       

                      My region settings set to Turkish. Might that cause this issue?

                      • 8. Re: Login problem on fresh installed LDMS 9.6
                        Rookie

                        Well it's weird. I changed local format settings to USA and now I am able to login without problem and web console is also working. There is no information about that on setup documents or youtube video.