2 Replies Latest reply on Jul 17, 2008 6:55 AM by rhinovalley

    Unable to run PXE Boot Menu Scripts


      I am able to boot into WinPE, I can run commands/mount network shares from the command prompt, but I am unable to run any scripts from the PXE Boot Menu in WinPE. When I select a script, the PXE Boot Menu closes but absolutely nothing happens. When searching this site I found a fix for the problem (http://community.landesk.com/support/docs/DOC-2183), but it still seems hopeless.



      I have tried creating a WinPE Configuration script to deploy an image, and even just a generic dos task script to no avail. I tried to create a test generic dos task script and even simple commands failed. Here is what I entered into the script:



      echo test



      And here is what the log file spits back:



      "CAWS233","CBA_ERROR:-1917761387",-1917761387,0:03:00,7/15/2008 2:18:11 PM,7/15/2008 2:21:11 PM,"DOS"

      "CAWS233","ERR_Bad_Param",0,0:00:00,7/15/2008 2:21:11 PM,7/15/2008 2:21:11 PM,""

      "CAWS233","ERR_Bad_Param",0,0:00:00,7/15/2008 2:21:11 PM,7/15/2008 2:21:11 PM,""

      ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"


      I'm a little dumbfounded here, and I'm not quite sure if it's just a blatant disregard of the obvious on my behalf or not. Any help would be very appreciated.

        • 1. Re: Unable to run PXE Boot Menu Scripts
          ahe Expert





          you can't start your script in the command shell in PE?



          Can you show us your osd script?



          Which version of LANDesk do you use?










          • 2. Re: Unable to run PXE Boot Menu Scripts

            Thanks for the reply. I'm on LD 8.8 SP1.


            I went into the command shell and tried to run the script and as it turns out it wasn't mounting the file share correctly so that's where it was failing. I went in and edited the script directly and it worked like a charm.



            One more question: When I select the script, the PXE Boot Menu closes and the script runs, but runs completely silent in the background. Is there a way to have the script open in a command shell so I can see the status as it runs?