1 2 Previous Next 16 Replies Latest reply on Jul 22, 2008 7:27 AM by deigor

    PXE Deploys fail after loading entire image

    Rookie

       

      I've got LanDesk 8.6 and I'm trying to do some OS deployments.

       

       

      We've run into this problem before and have always stumbled into a solution, but never really knew what we did to resolve the problem.  It might actually be two different problems, I don't know.

       

       

      We've been using all DOS mode PXE stuff including capture and deploy scripts.  I created a fairly standard XP image, sysprepped it and then did my capture script.  Worked just fine, the file validates successfully using the LANDesk (terabyte) imaging suite.  I captured in DOS and I did a validate with ImageW.exe

       

       

      I created a new deploy script, using all the default settings and command lines.  This is how I always make my scripts, I rarely find a reason to edit a script made from the console.  all i do is specify my image location and the path to the image.exe tool.

       

       

      The deploy script runs fine, gets all the way to the end, and then gets stuck on "waiting for command" right after it's finished copying the entire image.  I'm assuming the step it's getting stuck on is where it's writing the file system because after this the machine is unbootable.

       

       

      This has happened before and we've managed to find ways around it, but this time we're stuck.

       

       

       

       

       

      I tried re-capturing the image using ImageW.exe, but whenever I try to deploy an image captured with imagew.exe using the DOS PXE script, the image.exe program opens and closes without copying anything.  I seem to only be able to use DOS-created images with the DOS PXE scripts.  I've seen others report this problem, but can't find any solutions.

       

       

      I've also tried switching to the WinPE environment, and the same thing happens.  The script either opens and closes the ImageW.exe immediately, or it copies the entire image, but then freezes at the end, leaving the OS unbootable.

       

       

      If I manually open imagew.exe from WinPE and start the imaging, it finishes just fine, so I know the image is valid.

       

       

       

       

       

      anyone got any help to offer?  Sorryt his got long and wordy, I can't think of a better way to phrase it.

       

       

        • 1. Re: PXE Deploys fail after loading entire image
          Rookie

           

          Bump?

           

           

          Thread is getting a lot of traffic but not so much on replies. 

           

           

          • 2. Re: PXE Deploys fail after loading entire image
            ahe Expert

             

            Hello,

             

             

            it could be helpful for all, if you can attach your OSD script...

             

             

            Regards

            Axel

             

             

            • 3. Re: PXE Deploys fail after loading entire image
              Rookie

              Task=6

              ScriptName=DDSClinicJuly08

              ScriptDescription=DDSClinicJuly08

              MCast=0

              FallBackNIC=

              UseFallBackNIC=FALSE

              ImageUserName=mds29396_adm

              ImageDomain=blue

              ImagePassword=2094278B2ABC56D6E4CCE76FF93C1CC04E51F602B26

              ImageToolType=0

              ImageUNC=
              dds01\image$\newcapture\MPTEST00.IMG

              ToolUNC=
              dds01\image$\imaging\IMAGE.EXE

              Partition=1

              ImageToolCmd="command.com /c h:\imaging\IMAGE.EXE /RN /O i:\NEWCAP~1\MPTEST00.IMG", STATUS FACILITY=3510

              ImageToolCmdsFile=
              LDMS\LDMAIN\LANDESK\FILES\DDSClinicJuly08.txt

              IsSysPrepImage=0

              ConfigAdvancedMCast=0

              UseWOL=FALSE

              WOLSeconds=120

              DiscoveryType=0

              MaxTMCThreads=5

              MinTMCSleep=1

              MaxTMCSleep=200

              SubrepTTL=14

              TargetTTL=2

              GUID=ddb69faa-1d98-4c6c-bbde-27f5bdb7a4a6

              OSDPLUG=TRUE

              DESCRIPTION=DDSClinicJuly08

              NAME=DDSClinicJuly08

              ABORT_ON_CMD_FAILURE=1

              TASK_COMPLETION_ENABLED=FALSE

              REMMKDIR0=%LDMS_CLIENT_DIR%

              REMEXEC1=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/bootfile.exe"

              REMEXEC2=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr16.dll"

              REMEXEC3=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr32.dll"

              REMEXEC4=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ldvboot.img"

              REMEXEC5=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/lddefrag.exe"

              REMEXEC6=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/nicinfo.exe"

              REMEXEC7=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cicfgmgr.vxd"

              REMEXEC8=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cindis.vxd"

              REMEXEC9=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/copyfile.exe"

              REMEXEC10=<qt/>%LDMS_CLIENT_DIR%\nicinfo.exe<qt/>

              REMEXEC11=<qt/>%LDMS_CLIENT_DIR%\nicinfo.exe<qt/> ldms

              REMEXEC12=<qt/>%LDMS_CLIENT_DIR%\nicinfo.exe<qt/> dds01

              REMEXEC13=<qt/>%LDMS_CLIENT_DIR%\nicinfo.exe<qt/> core=LDMS

              REMEXEC14=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvboot.img<qt/> <qt/>%LDMS_CLIENT_DIR%\dosnic.ini<qt/> \net\dosnic.ini

              REMEXEC15=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvboot.img<qt/> <qt/>%LDMS_CLIENT_DIR%\lmhosts.ld<qt/> \net\lmhosts.

              REMEXEC16=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvboot.img<qt/> <qt/>%LDMS_CLIENT_DIR%\startnet.ld<qt/> \startnet.bat

              REMEXEC17=<qt/>%LDMS_CLIENT_DIR%\lddefrag.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvboot.img<qt/>, STATUS

              REMEXEC18=<qt/>%LDMS_CLIENT_DIR%\bootfile.exe<qt/> %LDMS_CLIENT_DIR%\ldvboot.img /keep /bootunsafe, ASYNC

              BEGINDOS=TRUE

              REMPING19=DOS

              REMEXEC20=ldlogon.exe mds29396_adm 2094278B2ABC56D6E4CCE76FF93C1CC04E51F602B26 blue, TIMEOUT=300

              REMEXEC21=net use i:
              dds01\image$, STATUS(85) FACILITY=7 TIMEOUT=300

              REMEXEC22=net use h:
              dds01\image$, STATUS(85) FACILITY=7 TIMEOUT=300

              REMEXEC23=r:\net\htget -o r:\dos\tokrepl.exe http://%CUSTJOBHOSTIP%/landesk/files/tokrepl.exe, STATUS

              REMEXEC24=r:\net\htget -o r:\dos\fworkcl.exe http://%CUSTJOBHOSTIP%/landesk/files/fworkcl.exe, STATUS

              REMEXEC25=r:\net\htget -o r:\dos\pworkcl.exe http://%CUSTJOBHOSTIP%/landesk/files/pworkcl.exe, STATUS

              REMEXEC26=r:\net\htget -o r:\dos\prtition.exe http://%CUSTJOBHOSTIP%/landesk/files/prtition.exe, STATUS

              REMEXEC27=r:\net\htget -a h:\imaging\IMAGE.EXE, STATUS FACILITY=7

              REMEXEC28=prtition wipe, STATUS

              REMEXEC29=command.com /c h:

              REMEXEC30=command.com /c cd \imaging

              REMEXEC31=echo Running OS Imaging tool. Please wait...

              REMEXEC32="command.com /c h:\imaging\IMAGE.EXE /RN /O i:\NEWCAP~1\MPTEST00.IMG", STATUS FACILITY=3510

              REMEXEC33=h:\imaging\mouse OFF

              REMEXEC34=r:\dos\tokrepl.exe r:\guid.pds DEVICEID=%Computer - Device ID%

              REMEXEC35=r:\dos\tokrepl.exe r:\guid.pds IMAGEPATH=
              dds01\image$\newcapture\MPTEST00.IMG

              REMEXEC36=r:\dos\fworkcl.exe /c r:\guid.pds 0 1 \LDISCAN.CFG

              REMEXEC37=r:\dos\pworkcl.exe /r 0 1

              REMEXEC38=reboot

              • 4. Re: PXE Deploys fail after loading entire image
                ahe Expert

                 

                Hello,

                 

                 

                I'm not sure but I think your line

                 

                 

                REMEXEC32="command.com /c h:\imaging\IMAGE.EXE /RN /O i:\NEWCAP~1\MPTEST00.IMG", STATUS FACILITY=3510

                 

                 

                does not work because of the directory name NEWCAP~1...

                 

                 

                Could you shorten the directory name and try it again? I can't check it actually on our core... in the office

                 

                 

                Regards

                Axel

                 

                 

                 

                 

                 

                • 5. Re: PXE Deploys fail after loading entire image
                  Rookie

                   

                  I will give that a try, but it seems to be able to get to that point OK.

                   

                   

                  I think it's a command somewhere after that line that fails.  The image utility loads, and I see the status bar for a while as it copies the image, but then after it gets to 100% I just get Waiting for Command

                   

                   

                  • 6. Re: PXE Deploys fail after loading entire image
                    Rookie

                     

                    Changing the path didn't help.  I put the files in a directory named "capture" so that it would be under the 8 character limit.  I also tried changing anywhere the script referenced newcapture to read "NEWCAP~1"  and both times it failed exactly the way it has been. Whole image copies, then stuck at "waiting for command"

                     

                     

                    I'm not 100% clear on the process flow here.  Is the core server somehow "forgetting" to send the command to my client?  The imaging process takes about 45 minutes up to the point where it fails.

                     

                     

                    I've just tried restarting some of the services on the core server in case any of them were the culprit.  Guess I'll try again and see if that worked.

                     

                     

                    • 7. Re: PXE Deploys fail after loading entire image
                      ahe Expert

                       

                      Hello,

                       

                       

                      what does the log file on the core say? <core>\ldmain\log\...

                       

                       

                      Regards

                      Axel

                       

                       

                      • 8. Re: PXE Deploys fail after loading entire image
                        Rookie

                         

                        Everything looks good in the log until the last couple lines:

                         

                         

                         

                         

                         

                        "DDSGD4","ERR_Fail",-1917452033,1:01:22,7/21/2008 9:33:29 AM,7/21/2008 10:34:51 AM,""command.com /c h:\ldimage\image.exe /RN /O i:\Capture\MPTEST00.IMG", STATUS FACILITY=3510"

                        ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"

                         

                         

                         

                         

                         

                        Kind of non-descript...can anyone interpret this?

                         

                         

                        • 9. Re: PXE Deploys fail after loading entire image
                          Rookie
                          1 of 1 people found this helpful
                          • 10. Re: PXE Deploys fail after loading entire image
                            ahe Expert

                             

                            I've had similar errors in the past as I use a 10/100 hub or have less then 100 MBit connection to PXE/Image store...

                             

                             

                            I've no idea yet. Perhaps the link to Ty's description helps a bit... and I propose to consult support too.

                             

                             

                            Regards

                            Axel

                             

                             

                             

                             

                             

                             

                             

                             

                            • 11. Re: PXE Deploys fail after loading entire image
                              Rookie

                               

                              Should be straight up gigabit to the image source.

                               

                               

                              I tried moving the image host to another computer, to see if that would help, but it didn't.  The article above suggests there is a problem with the image or with the streaming of said image.

                               

                               

                              I know it's not a server configuration issue, because this exact setup works just fine with some of our other images/scripts.

                               

                               

                              I'm trying to do a manual non-scripted restore, and we'll see if that works.  If it does I think we can rule out a problem with the image (which we've recaptured about half a dozen times now).

                               

                               

                              That leaves a problem with the image utilities, the script or maybe the network transfer...though I think the latter is unlikely, and I'm trying another known-to-work script right now to verify it's not the network or the server.

                               

                               

                              • 12. Re: PXE Deploys fail after loading entire image
                                Rookie

                                Now I remmember. I had simillar problem. I think you need different drivers for your NIC or update PC's BIOS. Which PC model do you have?

                                • 13. Re: PXE Deploys fail after loading entire image
                                  Rookie

                                   

                                  They are Lenovo 8810s, but I don't think that's it.  I can use older images just fine on them.  This will be the third time they've been imaged using this exact boot iamge.

                                   

                                   

                                  I did just discover that ALL of the images I've captured using the DOS image.exe program are corrupt.

                                   

                                   

                                  The one I captured using imagew.exe is OK, but I'm still having that problem where images that were created using imageW.exe fail immediately when the file transfer starts in the PXE imaging process.  It goes smooth up until the moment it starts copying the file, and then image.exe opens and closes immediately, and goes to sit at Waiting for Command.

                                   

                                   

                                  I'm going to try using a scripted WinPE capture process using a more current version of ImageW than i believe I used the last time.

                                   

                                   

                                  Does anyone know if the v2 terabyte imaging suite is available from LANDesk yet? If so what update does it come in?

                                   

                                   

                                  • 14. Re: PXE Deploys fail after loading entire image
                                    Rookie

                                    Did you use VLM Windows? I think it's your problem. If it not VLM image you can sysprep them 3 times. Then it locked.

                                     

                                    Check List:

                                    • Partition - Small 20Gb partition

                                    • Windows version - Windows Volume License only 
                                           

                                    • Install latest WU client to avoid any WU problems

                                    • Stop AU service and rename folder
                                           C:\WINDOWS\SoftwareDistribution to something like "SD Old". Start AU
                                           service. Check C:\WINDOWS\WindowsUpdate.log for errors.

                                    • Remove all local (temp) account you don't need.

                                    • In "Add/Remove Windows components" remove stuff you don't need. Install "Other Network File and Print Services".

                                    • Run Defragmentation before take an "Windows Image"

                                     

                                    1 2 Previous Next