1 2 3 Previous Next 35 Replies Latest reply on Jul 29, 2008 3:53 AM by MarXtar

    Distribution of batch file that copies a network file to a local folder.

    Rookie

       

      This being my first post I want to first say hello, so "Hello"

       

      We have had LANDesk management suite installed for nearly six months now but we are all still novices with the suite so we're not really using it justifiably.

      I've been trying to make use of the package distribution feature and I've failed to get a batch file to copy a file to the local disk.

       

      The batch file (av02.bat), held on the LD servers package share, contains the following command:

      xcopy /y "C:\Program Files\LANDesk\LDClient\sdmcache\VPHOME\GRC.DAT" "C:\Documents and Settings\All Users\Application Data\Symantec\Symantec AntiVirus Corporate Edition\7.5\"

       

      The package is built as follows:

      Primary file: http:[ |http://rus-ldsk-dg-01/ldpackages/test/av02.batAdditionalAdditional]//rus-ldsk-dg-01/ldpackages/test/av02.bat Additional file in the package: antiviru02\VPHOME\GRC.DAT (antivirus02 is a network server)

       

      I have tried various delivery methods. I succeed in getting the batch file, along with the .dat file, to the local host LANDesk cache but that is all I can achieve. I have not managed to get the batch file to run on its own accord.

       

      The resulting error in the logfile, when the scheduled task is ran, is as follows:

      Thu, 17 Jul 2008 09:22:40 File (http://RUS-LDSK-DG-01/ldpackages/test/av02.bat) is cached locally Thu, 17 Jul 2008 09:22:40 WM_CREATE Thu, 17 Jul 2008 09:22:40 WM_STARTCLIENT Thu, 17 Jul 2008 09:22:40 .\AdditionalFiles.cpp(61): (8DAC4026): Failed to download file [http://LANDesk.Gateway@10.10.X.XX/ldlogon/FileLists/taskmanifest.RUS-LDSK-DG-01.91.43.ini//LANDesk.Gateway@10.10.X.XX/ldlogon/FileLists/taskmanifest.RUS-LDSK-DG-01.91.43.ini] : (8000070B) Thu, 17 Jul 2008 09:22:40 Client thread failed to start Thu, 17 Jul 2008 09:22:40 WinNT Thu, 17 Jul 2008 09:22:40 processing of package is complete, result -1918091226 (0x8dac4026 - code 16422)

       

       

       

       

       

       

      After the scheduled task has ran with errors the batch file is in the local hosts cache: C:\Program Files\LANDesk\LDClient\sdmcache\test\av02.bat and the GRC.DAT file also: C:\Program Files\LANDesk\LDClient\sdmcache\VPHOME\GRC.DAT

       

       

      I can manually run the batch file once it has been successfully placed into the local hosts LANDesk cache, the batch file copies the GRC.DAT file from the local LANDesk cache into the destination folder; this is as intended so there doesn't appear to be anything wrong with the batch command. I have also ran this xcopy command at the local system command prompt and it works, so it isn't that. I have trried the move command also with the same result

       

       

      Please can someone explain what I am omitting from the process or what the reason for the error could be?

       

       

      Thank you!

       

       

        1 2 3 Previous Next