7 Replies Latest reply on Aug 4, 2015 6:28 AM by miw

    Provisioning Unmanaged Computers

    bwallace Apprentice

      I am struggling with how to provision unmanaged computers. Before upgrading to LDMS 9.6sp1 using LDMS 9.5sp3 and OSD rather than provisioning, we could get a computer out of the box, boot to PXE use the PXE imaging menu to select an image and put an image onto the machine (without a corresponding computer object in LDMS). Now that we've upgraded to LDMS 9.6sp1, we're forced to use provisioning. It's taken us a while, but we've finally created all our imaging deployments to provisioning templates and would like to do something similar to what we did with OSD. We have a number of computers that we would like to deploy an image to that will be standalone systems or segmented and will not be managed with LANDesk (for a number of reasons). Here's what I'm doing:

       

      1. We have a Windows image created, it is fully configured doesn't use HII and isn't SysPrepped

      2. We created a provisioning template that simply configures a partition, dumps on an image, ensures the partition is mounted as C: and then reboots. Once rebooted, we'll log into windows an change the computer name and it's good to go. (This is how it worked with OSD).

      3. We hook up the unmanaged computer, boot to PXE and wait until we get the GUI from the Provisioning agent asking for credentials. We enter domain creds and authenticate.

      4. We are presented with a menu to select from the provisioning templates available. We select a template, and then click ok.

      5. With managed computers, we can select any template and it will be deployed. With unmanaged systems, we get "Loading Template... Retry X of 40, waiting for template..." This runs through all 40 retries and then presents the menu again.

       

      Looking in the Provisioning.log from //core/ldmain/logs/provisioning, the following is listed for each retry:

       

      VERBOSE ProvisioningService  5/19/2015 5:02:10 PM  : >>GetTaskXml

      VERBOSE ProvisioningService  5/19/2015 5:02:10 PM  : GetTaskXML, SIDS:

      VERBOSE ProvisioningService  5/19/2015 5:02:10 PM  :     MACAddress: BC305BE03057

      VERBOSE ProvisioningService  5/19/2015 5:02:10 PM  :     SerialNumber: 1PRTXQ1

      ERROR ProvisioningService  5/19/2015 5:02:11 PM  : Unable to find computer

       

      Which I take from researching the issue to mean that it is an unmanaged system and isn't found in LDMS.

       

      Is there a way to put a provisioning template onto a computer without having to import/add the computer to LDMS? The computer will never be managed via LD, so it doesn't make sense to have to add it in and then delete it back out later.

       

      Any assistance would be helpful.

        • 1. Re: Provisioning Unmanaged Computers
          Specialist

          Noticed in 9.6 that you have to right click a device to make it a managed device before you can use it for task. Don't know this is the same principal for deployment ?

          • 2. Re: Provisioning Unmanaged Computers
            Frank Wils ITSMMVPGroup

            If the device isn't a managed device already, WinPE should send in a miniscan which will use the MACaddress of the device as devicename. In your case, you should for example look for a device called BC305BE03057.

             

            If you don't see this device, check the errorscan folder in Managementsuite\Ldscan and/or the Windows Application event viewer. In the errorscan map, the file should have an extention called .miniscn.

             

            It can also be the device is there but was processed after you tried to start a template. In this case, in WinPE, open a cmd, go to x:\ldprovision and run ldprovision.exe to try again.

             

            Finally, make sure your WinPE (PXE Representative) is up-to-date with the version of LANDESK.

             

            Frank

            • 3. Re: Provisioning Unmanaged Computers
              bwallace Apprentice

              In the end, I had to add it manually and then it started deployment. So I guess that everything DOES have to be managed to get a provisioning template put down on it then...Makes my life so much more complicated than the way OSD used to work.

              • 4. Re: Provisioning Unmanaged Computers
                Apprentice

                we have 9.6 Sp2 and have no problems provisioning  unmanaged devices. LANDesk sends a miniscan to the server and I have a scope set to those who have provisioning rights that includes miniscans. 

                • 5. Re: Provisioning Unmanaged Computers
                  bwallace Apprentice

                  For some reason, this one wasn't doing a miniscan, and so it was failing. I had to enter it manually, by MAC using the bare-metal server node. Then it worked.

                  • 6. Re: Provisioning Unmanaged Computers
                    Rookie

                    Have you added the network and hdd drivers in your boot image?. redeploy the PXE rep afterwards to update boot.wim. We average 2000 machines per month on 9.6 sp2. also be sure to use unc naming convention for image location.

                    • 7. Re: Provisioning Unmanaged Computers
                      miw Apprentice

                      I also have this issue, but my unmanaged machine is in the all devices container, but having the same issue, i can deploy "Old" machines but not new ones that is just unpacked from the box.

                       

                      We experienced this issue after we upgraded from SQL 2008 R2 -> MS Sql 2014