7 Replies Latest reply on Jul 24, 2008 6:43 PM by ewade

    Does Imagew 2.x image capture work?

    Rookie

       

      After installing the latest service pack, i decided to try to capture an image using the 2.0 imagew.exe tool to capture an image. It starts up, takes 2 seconds and reboots the machine. Checkign the log gives me a "1 Done" result. Am I doing something wrong? or does it not work yet

       

       

      I created the task using the WinPE Configuration GUI, so I assumed it would work just like the old one.

       

       

      Here is the log:

       

       

      "Machine","CbaStatus","ExitCode","Duration","Begin","End","Command"

      "FSU-99015","OK",0,0:00:00,7/18/2008 8:43:50 AM,7/18/2008 8:43:50 AM,"WINPE, TIMEOUT=1800"

      "FSU-99015","OK",5,0:02:13,7/18/2008 8:43:50 AM,7/18/2008 8:46:03 AM,"diskpart /s X:\LDClient\rmvol.txt"

      "FSU-99015","OK",230227968,0:00:00,7/18/2008 8:46:04 AM,7/18/2008 8:46:04 AM,"drvmap.exe frostburg\ldtest 107521D11C0399239672A161E57 I: <qt/>
      fsuldcore.frostburg.edu\images<qt/>, STATUS FACILITY=3513"

      "FSU-99015","OK",230227968,0:00:00,7/18/2008 8:46:04 AM,7/18/2008 8:46:04 AM,"drvmap.exe frostburg\ldtest 107521D11C0399239672A161E57 H: <qt/>
      fsuldcore.frostburg.edu\imaging<qt/>, STATUS FACILITY=3513"

      "FSU-99015","OK",4,0:00:01,7/18/2008 8:46:04 AM,7/18/2008 8:46:05 AM,"diskpart /s X:\LDClient\assvol.txt"

      "FSU-99015","OK",0,0:00:00,7/18/2008 8:46:05 AM,7/18/2008 8:46:05 AM,"cmd /c del /f /q C:\ldvpe1.img"

      "FSU-99015","OK",68,0:00:05,7/18/2008 8:46:05 AM,7/18/2008 8:46:10 AM,"H:\2.0\imagew.exe /b /uy /d:0 /rb:0 /max:2GB /f:"i:\FSU-99015""

      "FSU-99015","OK",-2147481750,0:00:06,7/18/2008 8:46:10 AM,7/18/2008 8:46:16 AM,"reboot, timeout=2"

      ; "Job Complete","1 Done","0 Failed","0 Off","0 Unknown"

       

       

       

       

       

       

       

       

      Here is the script file:

       

       

       

       

       

      Task=7

      ScriptName=OSD Capture LANDesk Image V2

      ScriptDescription=

      FallBackNIC=

      UseFallBackNIC=FALSE

      ImageUserName=username

      ImageDomain=domain

      ImagePassword=107521D11C0399239672A161E57

      ImageToolType=11

      ImageUNC=
      coreserver\images

      ToolUNC=
      coreserver\imaging\2.0\imagew.exe

      ImageToolCmd=H:\2.0\imagew.exe /b /uy /d:0 /rb:0 /max:2GB /f:"i:\%Computer - Device Name%"

      GUID=dfc52109-8965-4ddd-9549-b90459f5d22a

      OSDPLUG=TRUE

      DESCRIPTION=

      NAME=OSD Capture LANDesk Image V2

      TYPE=WinPE

      ABORT_ON_CMD_FAILURE=1

      TASK_COMPLETION_ENABLED=FALSE

      REMEXEC0=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/bootfile.exe"

      REMEXEC1=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr16.dll"

      REMEXEC2=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tlibr32.dll"

      REMEXEC3=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/lddefrag.exe"

      REMEXEC4=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cicfgmgr.vxd"

      REMEXEC5=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/cindis.vxd"

      REMEXEC6=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/copyfile.exe"

      REMEXEC7=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/winbom.ini"

      REMEXEC8=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ldvpe0.img"

      REMEXEC9=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="C:\ldvpe1.img" /p="http://%CUSTJOBHOSTIP%/landesk/vboot/ldvpe1.img"

      REMEXEC10=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /p="http://%CUSTJOBHOSTIP%/landesk/vboot/tokreplw.exe"

      REMEXEC11=<qt/>%LDMS_CLIENT_DIR%\sdclient.exe<qt/> /f /o /dest="%LDMS_CLIENT_DIR%\diskinfo.exe" /p="http://%CUSTJOBHOSTIP%/landesk/files/diskinfo.exe"

      REMEXEC12=<qt/>%LDMS_CLIENT_DIR%\diskinfo.exe<qt/> update_winnt_sif <qt/>%LDMS_CLIENT_DIR%\winnt.sif.new<qt/>

      REMEXEC13=<qt/>%LDMS_CLIENT_DIR%\copyfile.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvpe0.img<qt/> <qt/>%LDMS_CLIENT_DIR%\winnt.sif.new<qt/> \winnt.sif

      REMEXEC14=<qt/>%LDMS_CLIENT_DIR%\lddefrag.exe<qt/> <qt/>%LDMS_CLIENT_DIR%\ldvpe0.img<qt/>, STATUS

      REMEXEC15=<qt/>%LDMS_CLIENT_DIR%\bootfile.exe<qt/> %LDMS_CLIENT_DIR%\ldvpe0.img /keep /bootunsafe, ASYNC

      BEGINWINPE=TRUE

      REMPING16=WINPE, TIMEOUT=1800

      REMEXEC17=diskpart /s X:\LDClient\rmvol.txt

      REMEXEC18=drvmap.exe domain\username 107521D11C0399239672A161E57 I: <qt/>
      coreserver.domain.edu\images<qt/>, STATUS FACILITY=3513

      REMEXEC19=drvmap.exe domain\username 107521D11C0399239672A161E57 H: <qt/>
      coreserver.domain.edu\imaging<qt/>, STATUS FACILITY=3513

      REMEXEC20=diskpart /s X:\LDClient\assvol.txt

      REMEXEC21=cmd /c del /f /q C:\ldvpe1.img

      REMEXEC22=H:\2.0\imagew.exe /b /uy /d:0 /rb:0 /max:2GB /f:"i:\%Computer - Device Name%"

      REMEXEC23=reboot, timeout=2

       

       

        • 1. Re: Does Imagew 2.x image capture work?
          zman Master

           

          Imagew (terabyteunlimited.com) is a great upgrade from the old version. However, the problem with Dave's programs is when they first come out is they have a lot of issues. The issues are becuase 2.0 is an almost complete rewrite of 1.0 - different file format etc... So there are bound to be some issues. The version included in LANDesk is 2.0.6.0.  Latest version from Terabyte is 2.13 Enough said about that. 

           

           

          So one of the new features is imagew can create log files. Hopefully the logfile will give you some hints as to what is going on.

           

           

          /logfile:x:\path\logfile.txt

           

           

          Manual

           

           

          BTW, I did some "non scientific" benchmarks between Imagew 2.X and imagex and it was significantly faster, however, imagex is somewhat non destructive.

           

           

          +Also, please be advised that the you will not be able to read the new image format 2.x with the older versions of imagew and tbiview. +

           

           

          1 of 1 people found this helpful
          • 2. Re: Does Imagew 2.x image capture work?
            Rookie

             

            Unable to obtain a lock on drive C:

             

            Consider using the free PHYLock add-on which

            can be downloaded from www.terabyteunlimited.com

            Operation Completed with Error Code 68

            Stop

             

             

            • 3. Re: Does Imagew 2.x image capture work?
              zman Master

              Weird, something is accessing the drive. Phylock is only used for hot backups. I've seen this when there are some strange hidden partitions, something in winpe accessing the drive (a simple command prompt open with the drive letter will kill imagew). Hard part now is finding out what is accessing the drive.....

               

              I've used version 2.0 with straight Winpe and Bart's PE with no issues.

               

               

              Wonder if cmd /c del /f /q C:\ldvpe1.img is causing issues....

              • 4. Re: Does Imagew 2.x image capture work?
                phoffmann SupportEmployee

                Well - Process Explorer MAY help ... I've not tried running it in WinPE yet, so not sure (and sorry I can't test it at the moment, a good chunk of my lab decided to blow up irritatingly enough so I need to get that replaced).

                 

                But certainly Process Explorer from sysinternals is a great way of checking what's hitting your hard drive ... but yeah - what ZMAN said about hidden partitions sometimes causing this is very much the case (though I've not yet quite logically figured out HOW they do it). You sure you don't have something like this - a hidden partition?

                 

                Paul Hoffmann

                LANDesk EMEA Technical Lead.

                • 5. Re: Does Imagew 2.x image capture work?
                  Rookie

                  See this post: http://community.landesk.com/support/thread/2794?tstart=0 as a start point

                   

                   

                   

                   

                   

                   

                   

                  Replace everything in
                  osd\tools\ folder (you can move it to temp directory just in case) with
                  Landesk8.8 Install\LANDesk\PF\LD\MS\_non\osd\imaging (install source for LANDesk)

                   

                   

                   

                   

                  During updates not everything is updating, so just do it by hand to make sure you have everything current

                  • 6. Re: Does Imagew 2.x image capture work?
                    zman Master

                     

                    The ones that I've encounterd that are a PITA are the special/hidden partitions that have some BIOS hooks in them (restoration/recovery partitions).  Dave has a technote that may help https://terabyteunlimited.com/kb/article.php?id=050

                     

                     

                    If simply closing applications does not work, there is a way, built into Windows 2000/XP/2003, to force all open files closed.  Please note that this method can result in corrupt files in some cases, and should be used with caution.  To attempt to force all files closed on a given partition, issue the following from a command line:

                     

                     

                    chkdsk /x :

                     

                     

                    Where "n" represents the drive letter in need of locking.  Please

                    note that this command will not help in all cases (for example, it will

                    not allow you to overcome an in-use PAGEFILE.SYS.)

                     

                     

                     

                     

                     

                    • 7. Re: Does Imagew 2.x image capture work?
                      Rookie

                       

                      Oddly enough, the one that I was having problems with did not have a special recovery partition.

                       

                       

                      However, I was working on a new image for some HP machines with Recovery partitions that use an F11 key or something to activate, and version 2 worked on that one. So I figure, I better get an image using the old version, and it would go for a couple minutes and then reboot. I saw the image being created, but it disappeared when it rebooted.

                       

                       

                      It would seem that it works with certain conditions. As long as I can count on it restoring every time, I'll use version 2 for my HP machines and use the old version for previous machines.