1 2 Previous Next 16 Replies Latest reply on Jun 16, 2015 9:09 AM by mkfobian

    Distribute Software Fails (HTTP?)

    mkfobian Apprentice

      Hello all,

       

      Having an issue with Distribute Software.

       

      Packages succeed when run as scheduled tasks, so the packages themselves look good, but they  fail when using Provisioning (whether using a template that reimages a computer, or a template that ONLY runs the software distribution). The packages reference software held on a Windows share on the core server (\\CORE\Packages\)
      I suspect an issue with either IIS configuration or preferred server configuration, but I'm not really sure how to make that determination (or fix it, for that matter). Was wondering if anyone can provide any direction on this matter.

       

       

      The following are logs from a workstation where I have attempted to run this task.

       

      ldprovision.log

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:*********  Begin an action - Distribute_software

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Do EnvironmentCheck

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Is WinPE Action=0, Is WinPe Environment=0

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:In Handle Action.

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:About to download handler.

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Need to download handler:

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Handler remote: /LdLogon/Provisioning/windows/SDClientHandler.exe

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Handler local: c:\ldprovisioning\SDClientHandler.exe

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Looking for existing file (c:\ldprovisioning\SDClientHandler.exe)

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Entering downloadbyproxy.

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Create process (C:\Program Files (x86)\LANDesk\Shared Files\httpclient.exe) with args (  -f "c:\ldprovisioning\SDClientHandler.exe" http://CORE/LdLogon/Provisioning/windows/SDClientHandler.exe)

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Process exit code:0

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:The file (c:\ldprovisioning\SDClientHandler.exe) was successfully downloaded

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Done with download handler.

      2015-06-05 16:21:34(3572-4008) ldProvision.exe:Launching action handler [SDClientHandler.exe] with parameters ["]

      2015-06-05 16:21:40(3572-4008) ldProvision.exe:handler launched.

      2015-06-05 16:21:40(3572-4008) ldProvision.exe:Report might reboot status to core.

      2015-06-05 16:21:40(3572-4008) ldProvision.exe:Call web service SetActionStatus()

      2015-06-05 16:21:40(3572-4008) ldProvision.exe:Start TryallWebService Attempt:0.

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:End TryallWebService Attempt:0. ExitCode:0

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:Reporting action status: 5 to core

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:Call web service GetStatusString()

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:Start TryallWebService Attempt:0.

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:End TryallWebService Attempt:0. ExitCode:0

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:StatusString = The action failed.

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:Call web service SetActionStatus()

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:Start TryallWebService Attempt:0.

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:End TryallWebService Attempt:0. ExitCode:0

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:End of action - Distribute_software

      2015-06-05 16:21:41(3572-4008) ldProvision.exe:Last action failed

       

       

      SDClientHandler.log

      2015-06-05 16:21:34(1880-1728) SDClientHandler.exe:Starting Software Deployment.

      2015-06-05 16:21:34(1880-1728) SDClientHandler.exe:Checking for SDClient Mutex.

      2015-06-05 16:21:36(1880-1728) SDClientHandler.exe:Got mutex attempting distribution.

      2015-06-05 16:21:36(1880-1728) SDClientHandler.exe:id=23112015-06-05 16:21:36(1880-1728) SDClientHandler.exe:Executing: C:\Program Files (x86)\LANDesk\LDClient\SDClient.exe /pkgid=2311

      2015-06-05 16:21:36(1880-1728) SDClientHandler.exe:Going to execute "C:\Program Files (x86)\LANDesk\LDClient\SDClient.exe" /pkgid=2311 /disableclientqueue /taskid=2980

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:SDClient call retcode: -1918107543 (code - 105).

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:Getting returncode mapping from http://CORE/LANDesk/ManagementSuite/softwaredistribution/apmservice/PackageInfo.asmx

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:Requesting for PackageID: 2311, ReturnCode: -1918107543

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:Request:

          <?xml version="1.0" encoding="UTF-8" standalone="yes"?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Body><MapReturnCode xmlns="http://tempuri.org/"><iPackageId>2311</iPackageId><iRetCode>-1918107543</iRetCode></MapReturnCode></soap:Body></soap:Envelope>

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:Found httpclient.exe at C:\Program Files (x86)\LANDesk\Shared Files\httpclient.exe

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:httpclient args:  -H"c:\ldprovisioning\headerHII.txt" -o"c:\ldprovisioning\bodyHII.xml" -f"c:\ldprovisioning\resultHII.xml" http://CORE/LANDesk/ManagementSuite/softwaredistribution/apmservice/PackageInfo.asmx

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:TryallWebService exitcode: 0

      2015-06-05 16:21:40(1880-1728) SDClientHandler.exe:Failed to install package based on return code mapping, retcode: -1918107543 (code - 105).

       

      Based on the logs and what I've seen, I'm guessing (but not totally sure) that typical scheduled tasks are using UNC, which appears to be working (screenshot below) but HTTP does not.

       

      anonymousaccess.png

        1 2 Previous Next