4 Replies Latest reply on Sep 30, 2015 9:48 AM by ma92675

    Partitions not being expanded during imaging

    Rookie

      It is copying my images, both Win7x64 and Win8.1x64 to the new workstation, but is failing when expanding the partition to the full size of the target drive. Error is " Partition expansion fail (1/2/56) Please run a file system check.

      This has just started, I have not made any changes to my images and they worked correctly last week.

        • 1. Re: Partitions not being expanded during imaging
          nick.evans SupportEmployee

          Hi MEhrenberger,

          Can you post your template so we can see how you have your actions configured? Are you using the standard 'deployment template' format generated within 9.6 or are you using custom partition expansion partitions? Posting your template could help identify some potential causes.

           

          How to Import/Export Provisioning Templates - V... | LANDESK User Community

          https://community.landesk.com/support/docs/DOC-33549

           

          Nick

          • 2. Re: Partitions not being expanded during imaging
            Rookie

            Its the standard 9.6 template. Thank you for your help.

             

            <template id="e4e903b9-36b0-442f-ade7-241fbfe6afb8" name="RemoteCodersWin7x86" version="4">

            <description>Remote Coders</description>

            <preboot-os>WindowsPE</preboot-os>

            <final-os>

              <name>Windows</name>

              <type-id>All</type-id>

              <family-id>Windows</family-id>

              <vendor-id>All</vendor-id>

              <major-ver>-1</major-ver>

              <minor-ver>-1</minor-ver>

              <architecture>All</architecture>

            </final-os>

            <variables>

              <variable name="_ShowClientUI" transform="none">True</variable>

              <variable name="_CloseClientUI" transform="none">wait30</variable>

              <variable name="_RemoveClientFolder" transform="none">True</variable>

            </variables>

            <section id="SystemMigration" name="System migration">

              <description>Back up personal or custom files before the system is modified.</description>

              <action name="Vboot" version="4">

               <description />

               <action-type>Reboot_shutdown</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">false</option>

               </options>

               <parameters>

                <type>vboot</type>

                <TimeOut>0</TimeOut>

               </parameters>

              </action>

            </section>

            <section id="PreOsInstall" name="Pre-OS installation">

              <description>Configure the hardware and get the system ready for installing the target OS.</description>

              <action name="Create Default Partitions" version="4">

               <description />

               <action-type>Partition</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <diskID>0</diskID>

                <action>autocreate</action>

               </parameters>

              </action>

            </section>

            <section id="OsInstall" name="OS installation">

              <description>Install the target operating system with the specified options.</description>

              <action name="Deploy Image" version="4">

               <description />

               <action-type>Deploy_image</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <application>c:\ldprovision\imagew.exe</application>

                <arguments> /r /o /x /d:0 /rb:0 /f:\\phnsdalnt10\LANDesk\Images\HIIImage01\RCWin7x86.TBI</arguments>

                <imagetype>LANDeskWinV2</imagetype>

                <imagepath>\\phnsdalnt10\LANDesk\Images\HIIImage01\RCWin7x86.TBI</imagepath>

                <use_multicast>False</use_multicast>

               </parameters>

              </action>

            </section>

            <section id="PostOsInstall" name="Post-OS installation">

              <description>Add additional items after OS installation, before rebooting into the target OS. For example, you might add service pack updates.</description>

              <action name="Ensure the OS partition is mounted as C:" version="4">

               <description />

               <action-type>Partition</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <action>autoassign</action>

               </parameters>

              </action>

              <action name="Inject unattend file" version="4">

               <description />

               <action-type>Inject_script</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <target>c:\windows\panther\unattend.xml</target>

                <scriptid>f67f0aa2-3f46-40d8-b937-6494030f91c4</scriptid>

               </parameters>

              </action>

              <action name="Hardware Independent Imaging" version="4">

               <description />

               <action-type>HII</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <GetDriverFilesMethod>copy</GetDriverFilesMethod>

                <ForceUnsigned>True</ForceUnsigned>

               </parameters>

              </action>

              <action name="Configure Target OS" version="4">

               <description />

               <action-type>Configure_target_os</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <Insert_uniqueID>False</Insert_uniqueID>

               </parameters>

              </action>

            </section>

            <section id="SystemConfiguration" name="System configuration">

              <description>Automate system configuration that must happen after booting into the target OS such as installing drivers and applications and updating scan files.</description>

              <action name="Install LANDESK Agent" version="4">

               <description />

               <action-type>Configure_agent</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <PasswordIsVariable>False</PasswordIsVariable>

                <RebootIfRequired>True</RebootIfRequired>

                <exe_agent_path>\\phnsdalnt10\LANDesk\LANDesk\Agent\9.6_Workstation_with_status.exe</exe_agent_path>

                <usepref>True</usepref>

                <use_pref_credentials>True</use_pref_credentials>

                <configuration>9.6_Workstation</configuration>

                <usepeer>True</usepeer>

                <PasswordIsEncrypted>True</PasswordIsEncrypted>

                <pConfigurationId>6</pConfigurationId>

                <use_exe_agent>True</use_exe_agent>

                <usesource>True</usesource>

                <type>namedconfig</type>

                <configtool>wscfg32.exe</configtool>

                <corename />

               </parameters>

              </action>

              <action name="Hardware Independent Imaging" version="4">

               <description />

               <action-type>HII</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <GetDriverFilesMethod>copy</GetDriverFilesMethod>

                <ForceUnsigned>False</ForceUnsigned>

               </parameters>

              </action>

              <action name="Force update of LANDESK client policies" version="4">

               <description />

               <action-type>Execute_file</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters>

                <application>%%LDMS_CLIENT_DIR%%\PolicySync.exe</application>

                <arguments>/wait</arguments>

                <retvalop>EqualTo</retvalop>

                <retvalarg1>0</retvalarg1>

                <workingdirectory />

                <environmentvariables />

                <capture_output>True</capture_output>

               </parameters>

              </action>

              <action name="Install Mapped Software" version="4">

               <description />

               <action-type>MappedSoftwareInstaller</action-type>

               <variables />

               <options>

                <option name="StopProcessingTemplateIfActionFails">true</option>

               </options>

               <parameters />

              </action>

            </section>

            </template>

            • 3. Re: Partitions not being expanded during imaging
              Rookie

              Hi MEhrenberger

               

              Did you manage to get your issue resolved?  I am getting the same Error when I try to image Windows 10.

               

              - Update ... Never Mind, I Ran a Check Disk ... Then Sysprepped again and recaptured the image and now it works!

               

              Thanks

               

              Paul.

              • 4. Re: Partitions not being expanded during imaging
                ma92675 Apprentice

                I am also getting this error.  Any resolution on this?