4 Replies Latest reply on Jul 21, 2015 12:14 PM by Butz.Booc

    Connection Terminated after waking from suspend/sleep mode on WT41N0 devices.

    Butz.Booc Apprentice

      I was working on WT41N0 sleep timeout parameter, and set it to sleep every 2 minutes. However, after I wake the device from suspend/sleep mode, it will terminate the connection.

        • 1. Re: Connection Terminated after waking from suspend/sleep mode on WT41N0 devices.
          Matt Dermody SSMMVPGroup

          It could be your host application server that is terminating the session and not the Terminal Emulation software. When the WT41N0 enters sleep mode it's wireless radio is disabled in order to conserve battery. This has the effect of disassociating the device from the wireless network and thereby, the session with your host application server. I suggest expanding that sleep timer to 20-30 minutes and then set the backlight timeout to 2 minutes if you're worried about conserving battery.

          • 2. Re: Connection Terminated after waking from suspend/sleep mode on WT41N0 devices.
            Butz.Booc Apprentice

            Jmdermody,

             

            Thank you for your response. How come the WT4090 when in sleep mode doesn't disable the radio, and thus when waking up from suspend mode retains the current session. Is there a way to fix or to tell the radio not to turn off when in suspend mode? If the host application server is the one who's terminating my session, how come it only terminate the WT41N0, and not the WT4090?

             

            Thank you!

            • 3. Re: Connection Terminated after waking from suspend/sleep mode on WT41N0 devices.
              Matt Dermody SSMMVPGroup

              Maybe you have CAM (Continuously Active) enabled within the Wireless Profile on the WT4090 and PSP (Power Save) on the WT41N0. CAM will keep the radio enabled even when the device goes to sleep.

              • 4. Re: Connection Terminated after waking from suspend/sleep mode on WT41N0 devices.
                Butz.Booc Apprentice

                I push down my wireless profile through our server. I set this as a custom network properties, and selected CAM mode. Do you think there's a setting in emulation parameters for this? I am currently testing the emulation parameters settings for this. If nothing works, then I'm thinking it could be my host application.

                Kindly take a look at my wireless log below. I set a custom network properties to CAM, but you can still see that my Radio was turned off when it's in suspend mode.

                14:04:07  Log Initialized

                14:10:21  Unbinding adapter.

                14:10:21  Radio Power Off

                14:10:47  Binding adapter.

                14:10:47  RAL type: Full functional

                14:10:47  Power limit tables successfully downloaded

                14:10:47  Regulatory table downloaded to radio.

                14:10:47  Disabling 802.11d.

                14:10:47  Setting country code to: US

                14:10:47  Radio Power On

                14:10:47  Using profile: Wavelink Enabler

                14:10:48  Setting SSID: RF102

                14:10:48  Country code set to: US

                14:10:48  Associated with b4:c7:99:b1:bb:c2

                14:10:48  Authentication not required.

                14:10:48  Negotiating keys.

                14:10:48  Connected to network.

                14:10:51  Associated with b4:c7:99:df:1c:c1

                14:10:51  Negotiating keys.

                14:10:51  Connected to network.

                14:10:58  IP Address: 172.27.113.116