12 Replies Latest reply on Jul 24, 2008 12:06 PM by deigor

    HP DC7800 WinPE drive issue

    Rookie

       

      I have a new HP DC7800 machine that I am creating an image for upcoming purchases. I am ready to image the machine but booting into WinPE gives me an error about the drive:

       

       

      The disk you pecified is not valid.

       

       

      There is no disk selected.

       

       

      "There is not an available hard disk, or the hard disk driver is not loaded. Please inject the proper driver......"

       

       

       

       

       

      I tried injecting the SATA drivers per http://www.droppedpackets.org/osd/osdsata without any luck. I also injected the driver specifically from the HP site for this system  without any luck. I attempted to boot to DOS PE, but it just locked up, not that i want the slower DOS version.

       

       

      Anybody have a similar system that it may be working on?

       

       

      I actually can see the c: drive. So I am wondering if the recovery partition is causing the problem. Perhaps the multi-card reader could cause an issue? I know in Windows, I get 4 drive letters for the card readers (SD/CompactFlash/etc).

       

       

      On some Lenovo machines, I used to just set the SATA to compatibility mode instead of AHCI, but I don't see that option on the HP machines. I would prefer to run the machines in the mode they come in so that I don't need to fool with the BIOS on every machine.

       

       

       

       

       

        • 1. Re: HP DC7800 WinPE drive issue
          Rookie

          Did you redeployed PXE after you injected drivers?? Everytime you modify image you need to redeploy PXE rep

          • 2. Re: HP DC7800 WinPE drive issue
            ahe Expert

             

            It is enough to copy the WinPE image file... but as "deigor" mentioned, the PE image from your core
            coreserver\ldmain\landesk\vboot\ldvpe1.img must be update on your PXE server...

             

            1. copy the file from
              coreserver\ldmain\landesk\vboot\ldvpe1.img to the pxe server C:\Program Files\LANDesk\PXE\System\images

            2. rename the file ldvpe1.img to peboot.img on pxe server

            Regards

            Axel

             

             

             

             

            • 3. Re: HP DC7800 WinPE drive issue
              Rookie

               

              I have been injecting directly into the PXE rep boot image to save time. I have verified that I have the files in a driver directory (driver.0 in this case) in the i386\system32 directory.

               

               

               

               

               

              The txtsetup.oem file has the default set to:

               

               

               

              scsi = iaAHCI_ICH8M

               

               

              with the iaAHCI_ICH8M driver corresponding to:

               

               

              iaAHCI_ICH8M = "Intel(R) 82801HEM/HBM SATA AHCI Controller (Mobile ICH8M-E/M)"

               

               

               

               

               

              I also tried the iaStor_ICH8M designation too.

               

               

              • 4. Re: HP DC7800 WinPE drive issue
                Rookie

                 

                Seems like you have Intel RAID controller :). Did you configured RAID or not?

                 

                 

                • 5. Re: HP DC7800 WinPE drive issue
                  Rookie

                  The BIOS settings for SATA were set from the factory to emulate IDE. When I changed it to RAID, the drive is not recognized.

                  • 6. Re: HP DC7800 WinPE drive issue
                    Rookie

                     

                    OK, so you have  RAID0 or RAID1??

                     

                     

                    To make sure you have correct drivers you can do following:

                     

                     

                    - get latest from Intelhere http://www.intel.com/support/chipsets/imsm/index.htm#anchor2(you'll need PV 8.2) 

                     

                     

                    - Boot PC from Windows CD (by the way it's XP or Vista?)

                     

                     

                    - If it Win XP, insert floppy choose your RAID drivers (you probably will have 6-8 to choose from)

                     

                     

                    - If it recognise drive, then you have right drivers 

                     

                     

                    • 7. Re: HP DC7800 WinPE drive issue
                      Rookie

                      By the way. Stay away from "emulate IDE". You'll lose SATA performance

                      • 8. Re: HP DC7800 WinPE drive issue
                        Rookie

                         

                        I would say no RAID is present since changing emulation to RAID makes the drive not work at all.

                         

                         

                        I really don't think the problem is directly related to the hard drive controller at this point after thinking about it for awhile. I can see the C: drive that I want to image when I launch a new console in WinPE. Obviously it sees the drive controller if it sees the drive. Also, when I performed a repair on the OS (XP SP3), I did not have to press F6 (or whatever key) to choose a non standard controller card. So XP has the proper driver built in. This leads me to believe it is talking about another drive, which leaves the removable media in the card readers. Without media in the card readers, I would not think it would try to access those slots.

                         

                         

                         

                         

                         

                        • 9. Re: HP DC7800 WinPE drive issue
                          Rookie

                          It was those stupid media card readers built into the front bezel. I disconnected it from the motherboard and it boots fully into WinPE

                          • 10. Re: HP DC7800 WinPE drive issue
                            Rookie

                            Glad you find it !http://community.landesk.com/support/images/emoticons/happy.gif!.

                             

                            Question is right now, why media card readers create this issue?

                             

                             

                            Also I recommend to use change settings to RAID0 or RAID1 Don't use emulation mode. It's extra work for you, but it worth it

                            • 11. Re: HP DC7800 WinPE drive issue
                              Rookie

                               

                              I am guessing that they are taking up a drive letter.

                               

                               

                              In windows, they each take up a drive letter even when no media is inserted. I am still looking for a way to disable the card reader in the BIOS so we do not have to open up every machine. I found an entry in the BIOS to disable booting to removable media, but it still had the issue. Maybe there is a card reader driver that I could install to make WinPE think that all drives have drivers.

                               

                               

                              • 12. Re: HP DC7800 WinPE drive issue
                                Rookie

                                 

                                Using letter - sounds about right.

                                 

                                 

                                if you go to Advance Edit of the script, you can modify which drive you need.To test thet you can uncomment last line "reboot" then boot to WinPE and ny hand check what is mapped, what is not