9 Replies Latest reply on Jun 24, 2017 10:11 PM by Gary7

    Provisioning Template wont load

    Rookie

      Hi,  for some unknown reason to me, I can't seem to provision my Master template anymore.  After entering the domain and login credentials LD, I then navigate and point to the template I want to provision.  After which on the command screen it will show "Loading Template...."  and retry  x40 before going back to the LD Provisioning Agent screen.

      FullSizeRender2.jpg
      I haven't changed anything and was previously able to provision the template to new machines.  I looked  in the templates folder and did see multiple instances/copies of it with the timestamp.  I've deleted these and now only has the Master Template.  It still wont work.

       

      Appreciate any help here.

      Cheers,

      Poch

      (Landesk Noob)

        • 1. Re: Provisioning Template wont load
          Alex.Richardson SSMMVPGroup

          This step is when LDMS creates the locked copy of the template to use for this deployment. When you have this problem it is normally due to a software package that is part of the template having an issue.

          Do you have any software packages in this template?

           

          If you don't then this doco can help find the cause Issue: Provisioning task failing after try 40 of 40

          • 2. Re: Provisioning Template wont load
            Rookie

            Hi Alex,  yes there are several packages in this template.  Any suggestions how I would determine which package was causing the issue?

            • 3. Re: Provisioning Template wont load
              Alex.Richardson SSMMVPGroup

              If you check the provisioning.log under \\core\ldmain\log\provisioning you will see details on why it failed

               

              Corrupt Template
              • A corrupt template can prevent correct scheduling. One cause if this is if a template is imported, the drop down boxes are not filled in as they were pointing to objects from the previous core. For example, Software Distribution actions do not have a package specified. Same with Configure Agent actions. Also any actions with scripts will have this issue.
              • Another way to determine if your template is not configured properly is by reviewing the Provisioning.log on the core. If you see the following:

              INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Action LANDesk.Provisioning.Business.PAction_Distribute_software
              INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Got package ID 60, requesting snippet
              INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Requesting snippet for packageId 60
              INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Requesting SWD snippet with task IDN 2214, package ID 60
              ERROR    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Exception encountered trying to get snippet (LANDesk.ManagementSuite.SoftwareDistribution.Business.PackageNotFoundException): This package has been deleted.
              ERROR    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : GetSoftwareSnippet failed

              • 4. Re: Provisioning Template wont load
                Rookie

                Thanks again Alexa, found the log file...

                VERBOSE ProvisioningService  11/09/2015 3:33:35 PM  :     MACAddress: 308D99BFB000

                VERBOSE ProvisioningService  11/09/2015 3:33:35 PM  :     SerialNumber: 5CG5253M17

                ERROR ProvisioningService  11/09/2015 3:33:35 PM  : Unable to find computer

                 

                I don't quite understand why or what it means when it cant find the computer....

                • 5. Re: Provisioning Template wont load
                  Frank Wils ITSMMVPGroup

                  Do you see the device with this MAC address/Serial number in your Inventory on the Core Server?

                   

                  Frank

                  • 6. Re: Provisioning Template wont load
                    Rookie

                    Hi Frank, thanks for helping out.

                    When you say Core Server do you mean LDM Console?

                    *This is a new machine I am trying to provision our SOE on.

                    ld.png

                     

                    I found this in the doco link Alex sent.  Looks like it may be related to my issue as my provision.log shows unable to find computer.

                    Just not sure where to go   My Configure > Services is greyed out.

                    ld2.png

                    • 7. Re: Provisioning Template wont load
                      Rookie

                      Not sure if this is related....

                      Since I can't provision our SOE into this new laptop.  I thought of manually installing the LD agent and then try to provision the apps later.

                      After installing the Agent I ran the Inventory scan exe. and got this error message.

                       

                      IMG_2211.JPG

                       

                      Is this related? or a separate issue?

                      • 8. Re: Provisioning Template wont load
                        Rookie

                        Hi All.

                        Finally fixed the issue!  It was sorta related to that screenshot above.

                        I logged into the server where LDMS was hosted, went to the services.msc and restarted the Landesk Inventory Server.

                         

                        Thank you for the responses.

                         

                        Cheers,

                        Poch


                        • 9. Re: Provisioning Template wont load
                          Gary7 Rookie

                          I had this issue on 2016 sp3.  the inventory server service was set to automatic, but was  not started